aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-07-08 16:51:31 +0800
committerdanfe <danfe@FreeBSD.org>2014-07-08 16:51:31 +0800
commit688ab61be741f66220dfbf93ffa516bc525506ca (patch)
treeffb83bca73db8505fa31a6a02f1b382119344955 /games
parent101e9e81e6de0ed88e612ad3fad7f1a5c53927e7 (diff)
downloadfreebsd-ports-gnome-688ab61be741f66220dfbf93ffa516bc525506ca.tar.gz
freebsd-ports-gnome-688ab61be741f66220dfbf93ffa516bc525506ca.tar.zst
freebsd-ports-gnome-688ab61be741f66220dfbf93ffa516bc525506ca.zip
Reduce the differences between `quake*-data' ports:
- Consistently use vertical bar (pipe) in :S substitutions - Do not abuse .error statement, set IGNORE knob instead - Drop some unnecessary quotation marks in comparisons - Add a comment on why we cannot depend on particular .pak file - Simplify extraction of the `linuxq3apoint-1.32b-3.x86.run'
Diffstat (limited to 'games')
-rw-r--r--games/quake-data/Makefile.include6
-rw-r--r--games/quake2-data/Makefile.include5
-rw-r--r--games/quake3-data/Makefile9
-rw-r--r--games/quake3-data/Makefile.include6
4 files changed, 13 insertions, 13 deletions
diff --git a/games/quake-data/Makefile.include b/games/quake-data/Makefile.include
index c7ef90861f9c..a34a825adb69 100644
--- a/games/quake-data/Makefile.include
+++ b/games/quake-data/Makefile.include
@@ -5,13 +5,13 @@ Q1PKGNAMEPREFIX?= quake-
Q1DIR?= ${LOCALBASE}/share/quake
.if defined(PKGNAMEPREFIX) && ${PKGNAMEPREFIX} == ${Q1PKGNAMEPREFIX} && defined(OPTIONSMKINCLUDED)
-. error include before <bsd.port.options.mk> if using Q1PKGNAMEPREFIX
+IGNORE= is using Q1PKGNAMEPREFIX, but <bsd.port.options.mk> included too early
.endif
MAKE_ENV+= Q1DIR="${Q1DIR}"
-PLIST_SUB+= Q1DIR="${Q1DIR:S/${LOCALBASE}\///}"
+PLIST_SUB+= Q1DIR="${Q1DIR:S|${LOCALBASE}/||}"
SUB_LIST+= Q1DIR="${Q1DIR}"
-.if ${PORTNAME} != "data"
+.if ${PORTNAME} != data
RUN_DEPENDS+= ${Q1DIR}/id1/pak0.pak:${PORTSDIR}/games/quake-data
.endif
diff --git a/games/quake2-data/Makefile.include b/games/quake2-data/Makefile.include
index 3b83e37ccb4d..2f52221b769c 100644
--- a/games/quake2-data/Makefile.include
+++ b/games/quake2-data/Makefile.include
@@ -48,7 +48,7 @@
Q2PKGNAMEPREFIX?= quake2-
Q2DIR?= ${LOCALBASE}/share/quake2
-.if defined(PKGNAMEPREFIX) && ${PKGNAMEPREFIX} == "${Q2PKGNAMEPREFIX}" && defined(OPTIONSMKINCLUDED)
+.if defined(PKGNAMEPREFIX) && ${PKGNAMEPREFIX} == ${Q2PKGNAMEPREFIX} && defined(OPTIONSMKINCLUDED)
IGNORE= is using Q2PKGNAMEPREFIX, but <bsd.port.options.mk> included too early
.endif
@@ -56,6 +56,7 @@ MAKE_ENV+= Q2DIR="${Q2DIR}"
PLIST_SUB+= Q2DIR="${Q2DIR:S|${LOCALBASE}/||}"
SUB_LIST+= Q2DIR="${Q2DIR}"
-.if ${PORTNAME} != "data"
+.if ${PORTNAME} != data
+# Not depending on the particular .pak file since they are OPTIONS-dependent
RUN_DEPENDS+= ${Q2DIR}:${PORTSDIR}/games/quake2-data
.endif
diff --git a/games/quake3-data/Makefile b/games/quake3-data/Makefile
index 458fcf872bde..44c00d2ec937 100644
--- a/games/quake3-data/Makefile
+++ b/games/quake3-data/Makefile
@@ -5,13 +5,12 @@ PORTNAME= data
DISTVERSION= 1.32b-3
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
-MASTER_SITE_SUBDIR= quake3/linux
+MASTER_SITES= IDSOFTWARE/quake3/linux
PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= linuxq3apoint-${DISTVERSION}.x86
EXTRACT_SUFX= .run
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= games@FreeBSD.org
COMMENT= Quake III Arena data files
DATADIR= ${Q3DIR}
@@ -32,8 +31,8 @@ TEAMARENA_DESC= Install Quake III Team Arena data files
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
- @cd ${WRKDIR} && ${TAIL} +356 \
- ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | ${TAR} xzf -
+ @${TAIL} +356 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} xzf - -C ${WRKDIR}
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
index 466a586e7ee5..d8e5c757cf93 100644
--- a/games/quake3-data/Makefile.include
+++ b/games/quake3-data/Makefile.include
@@ -5,13 +5,13 @@ Q3PKGNAMEPREFIX?= quake3-
Q3DIR?= ${LOCALBASE}/share/quake3
.if defined(PKGNAMEPREFIX) && ${PKGNAMEPREFIX} == ${Q3PKGNAMEPREFIX} && defined(OPTIONSMKINCLUDED)
-. error include before <bsd.port.options.mk> if using Q3PKGNAMEPREFIX
+IGNORE= is using Q3PKGNAMEPREFIX, but <bsd.port.options.mk> included too early
.endif
MAKE_ENV+= Q3DIR="${Q3DIR}"
-PLIST_SUB+= Q3DIR="${Q3DIR:S/${LOCALBASE}\///}"
+PLIST_SUB+= Q3DIR="${Q3DIR:S|${LOCALBASE}/||}"
SUB_LIST+= Q3DIR="${Q3DIR}"
-.if ${PORTNAME} != "data"
+.if ${PORTNAME} != data
RUN_DEPENDS+= ${Q3DIR}/baseq3/pak1.pk3:${PORTSDIR}/games/quake3-data
.endif