aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-04-21 22:16:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-04-21 22:16:29 +0800
commit6d059af3b4607b2941f09621a9533163de634e24 (patch)
tree8c43dbbf5931c2ff10f88a1fa6452b8a5bb4978d /games
parent76ff92c827012c55e4b36fcf131c7bf2950ac6ee (diff)
downloadfreebsd-ports-gnome-6d059af3b4607b2941f09621a9533163de634e24.tar.gz
freebsd-ports-gnome-6d059af3b4607b2941f09621a9533163de634e24.tar.zst
freebsd-ports-gnome-6d059af3b4607b2941f09621a9533163de634e24.zip
- Fix shebangs
- Add missing python dependency
Diffstat (limited to 'games')
-rw-r--r--games/quakeforge/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 112ba9c2bef1..d22e0e825e48 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quakeforge
PORTVERSION= 0.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/quake/quake/${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -18,7 +18,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
-USE_CSTD= gnu89
+USES= bison compiler:c11 gmake libtool localbase python:run shebangfix tar:bzip2
+SHEBANG_FILES= tools/qfcc/source/qfpreqcc
GNU_CONFIGURE= yes
CONFIGURE_ENV= Z_CFLAGS=" " Z_LIBS="-lz"
CONFIGURE_ARGS= --disable-alsa \
@@ -30,8 +31,8 @@ CONFIGURE_ARGS= --disable-alsa \
--with-global-cfg=${PREFIX}/etc/quakeforge.conf \
--with-ipv6 \
--with-sharepath=${Q1DIR}
+USE_CSTD= gnu89
INSTALL_TARGET= install-strip
-USES= bison compiler:c11 gmake libtool localbase tar:bzip2
USE_LDCONFIG= yes
SUB_FILES= pkg-message