aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2016-05-11 07:22:29 +0800
committersbruno <sbruno@FreeBSD.org>2016-05-11 07:22:29 +0800
commit7fdfb3479e9dd2c14de8311d3f5ea2a85e1a7957 (patch)
tree0b689450c37f432486c379c9e408b6c816427b62 /games
parentb3bd214ce76d741772ca7c6453f9dcd4c3f142fa (diff)
downloadfreebsd-ports-gnome-7fdfb3479e9dd2c14de8311d3f5ea2a85e1a7957.tar.gz
freebsd-ports-gnome-7fdfb3479e9dd2c14de8311d3f5ea2a85e1a7957.tar.zst
freebsd-ports-gnome-7fdfb3479e9dd2c14de8311d3f5ea2a85e1a7957.zip
Add USES=compiler:c++11-lib to successfully build on 9.3 release.
This has the effect of pulling in gcc48 to do the build, but it at least succeeds. On 10 and higher, this will use clang to build.
Diffstat (limited to 'games')
-rw-r--r--games/cockatrice/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/cockatrice/Makefile b/games/cockatrice/Makefile
index e5ae877a34cf..046ab20ceb8d 100644
--- a/games/cockatrice/Makefile
+++ b/games/cockatrice/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Cockatrice
PORTVERSION= 0.0.g2016.04.27
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= sbruno@FreeBSD.org
@@ -15,7 +16,7 @@ LIB_DEPENDS= libprotobuf.so:devel/protobuf
USE_GITHUB= yes
GH_TAGNAME= ff1091a
-USES= cmake
+USES= cmake compiler:c++11-lib
USE_QT5= buildtools concurrent core multimedia network printsupport \
qmake svg linguisttools widgets