aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-06-17 02:50:44 +0800
committerlioux <lioux@FreeBSD.org>2002-06-17 02:50:44 +0800
commit8b67a12954155cda89aea24e79d0668270b7d359 (patch)
tree4a159bff785edd7f204acb878d349e557b54b4b3 /games
parente9f79422d51bbf3695023fdf8f90522f3771c93c (diff)
downloadfreebsd-ports-gnome-8b67a12954155cda89aea24e79d0668270b7d359.tar.gz
freebsd-ports-gnome-8b67a12954155cda89aea24e79d0668270b7d359.tar.zst
freebsd-ports-gnome-8b67a12954155cda89aea24e79d0668270b7d359.zip
Add USE_PERL5 since perl is required to run a script inside the
Makefile. Adding USE_PERL5 is mandatory since it is no longer available in base system of -CURRENT. Approved by: maintaner (only not utserver* ports)
Diffstat (limited to 'games')
-rw-r--r--games/halflifeserver/Makefile1
-rw-r--r--games/hlserver-cs/Makefile1
-rw-r--r--games/linux-quake3/Makefile1
-rw-r--r--games/q3server-ra3/Makefile1
-rw-r--r--games/q3server/Makefile1
-rw-r--r--games/quake3-ra3/Makefile1
-rw-r--r--games/utserver-to/Makefile1
-rw-r--r--games/utserver/Makefile1
8 files changed, 8 insertions, 0 deletions
diff --git a/games/halflifeserver/Makefile b/games/halflifeserver/Makefile
index 264588e094e5..4afb9f2d2cee 100644
--- a/games/halflifeserver/Makefile
+++ b/games/halflifeserver/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= pat@FreeBSD.org
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/hlds_l
diff --git a/games/hlserver-cs/Makefile b/games/hlserver-cs/Makefile
index 4e315c86ef90..b41bddc8a670 100644
--- a/games/hlserver-cs/Makefile
+++ b/games/hlserver-cs/Makefile
@@ -26,6 +26,7 @@ USE_SUBMAKE= yes
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
.if (${PORTNAME}==cs)
diff --git a/games/linux-quake3/Makefile b/games/linux-quake3/Makefile
index f88684f69e34..4b4d608cc3be 100644
--- a/games/linux-quake3/Makefile
+++ b/games/linux-quake3/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= pat@FreeBSD.org
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/games/q3server-ra3/Makefile b/games/q3server-ra3/Makefile
index 8cf83b2b6717..2662d747a54f 100644
--- a/games/q3server-ra3/Makefile
+++ b/games/q3server-ra3/Makefile
@@ -24,6 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/games/quake3/q3ded:${Q3SERVER_PORT}
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
.if (${PORTNAME}==ra3)
diff --git a/games/q3server/Makefile b/games/q3server/Makefile
index f88684f69e34..4b4d608cc3be 100644
--- a/games/q3server/Makefile
+++ b/games/q3server/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= pat@FreeBSD.org
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/games/quake3-ra3/Makefile b/games/quake3-ra3/Makefile
index 8cf83b2b6717..2662d747a54f 100644
--- a/games/quake3-ra3/Makefile
+++ b/games/quake3-ra3/Makefile
@@ -24,6 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/games/quake3/q3ded:${Q3SERVER_PORT}
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
.if (${PORTNAME}==ra3)
diff --git a/games/utserver-to/Makefile b/games/utserver-to/Makefile
index aee997605c6e..c8b0056688c5 100644
--- a/games/utserver-to/Makefile
+++ b/games/utserver-to/Makefile
@@ -24,6 +24,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/games/ut-server/System/ucc-bin:${UTSERVER_PORT}
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
.if (${PORTNAME}==to)
diff --git a/games/utserver/Makefile b/games/utserver/Makefile
index 2345f0c1f657..db895f32899b 100644
--- a/games/utserver/Makefile
+++ b/games/utserver/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/ut-server