aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-04-08 20:29:06 +0800
committernemysis <nemysis@FreeBSD.org>2014-04-08 20:29:06 +0800
commit8c4fefa53840bc95b4ec06e36c05e766b7931f91 (patch)
tree70e869774a5200561ef471ee285a6f2474b223f9 /games
parent67cc67ea32fa14b5be980782e5680054d854513d (diff)
downloadfreebsd-ports-gnome-8c4fefa53840bc95b4ec06e36c05e766b7931f91.tar.gz
freebsd-ports-gnome-8c4fefa53840bc95b4ec06e36c05e766b7931f91.tar.zst
freebsd-ports-gnome-8c4fefa53840bc95b4ec06e36c05e766b7931f91.zip
- Change Makefile header, Created by to <des@FreeBSD.org>
- Remove TODO from DOCS, add Option - Change Desktop entry file - Break lines around 80 characters - Mute MKDIR
Diffstat (limited to 'games')
-rw-r--r--games/abuse_sdl/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/abuse_sdl/Makefile b/games/abuse_sdl/Makefile
index 28c2c808caf8..7e76b370c35a 100644
--- a/games/abuse_sdl/Makefile
+++ b/games/abuse_sdl/Makefile
@@ -1,3 +1,4 @@
+# Created by: Dag-Erling C. Smørgrav <des@FreeBSD.org>
# $FreeBSD$
PORTNAME= abuse_sdl
@@ -22,15 +23,17 @@ CONFIGURE_ARGS= --with-assetdir=${DATADIR} --enable-release
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+PORTDOCS= AUTHORS ChangeLog NEWS README
+OPTIONS_DEFINE= DOCS
-DESKTOP_ENTRIES="Abuse-SDL" "${COMMENT}" "abuse" \
- "abuse" "Game;StrategyGame;" false
+DESKTOP_ENTRIES="Abuse-SDL" "" "abuse" \
+ "abuse" "Game;StrategyGame;" ""
post-install:
- ${INSTALL_DATA} ${WRKSRC}/doc/abuse.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/doc/abuse.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>