aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2012-12-09 07:28:37 +0800
committerrakuco <rakuco@FreeBSD.org>2012-12-09 07:28:37 +0800
commit9a811b97de68cf39c0cb77a5735cae17196deab6 (patch)
tree767ee5d3f56317f313b23dfb13e4124ea4f33d31 /games
parent86d7cffb04602e75bd69119c0b288942901b3479 (diff)
downloadfreebsd-ports-gnome-9a811b97de68cf39c0cb77a5735cae17196deab6.tar.gz
freebsd-ports-gnome-9a811b97de68cf39c0cb77a5735cae17196deab6.tar.zst
freebsd-ports-gnome-9a811b97de68cf39c0cb77a5735cae17196deab6.zip
Update to 1.2.
PR: ports/173535 Submitted by: Green Dog <fiziologus@gmail.com> (maintainer) Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/frogatto/Makefile25
-rw-r--r--games/frogatto/distinfo4
-rw-r--r--games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg11
-rw-r--r--games/frogatto/files/patch-src-IMG_savepng.cpp10
-rw-r--r--games/frogatto/files/patch-src-custom_object.cpp11
-rw-r--r--games/frogatto/files/patch-src-server.cpp11
6 files changed, 37 insertions, 35 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 1e974621533e..41afcc88108b 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -1,25 +1,25 @@
-# New ports collection makefile for: Frogatto & Friends
-# Date created: 14 Jul 2010
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= frogatto
-PORTVERSION= 1.1.1
-PORTREVISION= 3
+PORTVERSION= 1.2
CATEGORIES= games
-MASTER_SITES= http://www.frogatto.com/files/
+MASTER_SITES= GH
MAINTAINER= fiziologus@gmail.com
COMMENT= An old-school 2D classic adventure platformer game
-NO_PACKAGE= Package will be 144M, set FORCE_PACKAGE if you really want it
-
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
png15:${PORTSDIR}/graphics/png
-USE_BZIP2= yes
+NO_PACKAGE= Package will be 144M, set FORCE_PACKAGE if you really want it
+
+USE_GITHUB= yes
+GH_ACCOUNT= frogatto
+GH_PROGECT= frogatto
+GH_TAGNAME= ${PORTVERSION}
+GH_COMMIT= 64c84bf
+
USE_GMAKE= yes
ALL_TARGET= game server
USE_GL= glew
@@ -35,7 +35,7 @@ post-patch:
-e 's,= (ccache )?g\+\+,:= $$(CXX) $$(CXXFLAGS),' \
-e 's, -O2,, ; s, -g,, ; s, -L/usr/lib,, ; s, -L/sw/lib,,' \
-e '/server/s,`.*mixer,-L${LOCALBASE}/lib ${PTHREAD_LIBS},' \
- -e 's,-mt,,g' ${WRKSRC}/Makefile
+ -e 's,-mt,,g' -e 's,-lpng,-lpng15,g' ${WRKSRC}/Makefile
# Point to the right location where to look for resources on FreeBSD
@${REINPLACE_CMD} -e 's,HAVE_CONFIG_H,__FreeBSD__,' \
-e 's,DATADIR,"${DATADIR}",' ${WRKSRC}/src/filesystem.cpp
@@ -49,6 +49,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/bin/${PORTNAME}-server
cd ${WRKSRC} && ${COPYTREE_SHARE} "data images music sounds" \
${DATADIR}
+ cd ${WRKSRC}/locale && ${MV} hu_HU hu && ${MV} ms_MY ms
cd ${WRKSRC} && ${COPYTREE_SHARE} "locale" ${PREFIX}/share
# Fix permissions on DATADIR after COPYTREE_SHARE (cpio(1) defaults to 700
# if target directory (${DATADIR}) does not exist)
diff --git a/games/frogatto/distinfo b/games/frogatto/distinfo
index cd348673e229..ec8b4dcf5c41 100644
--- a/games/frogatto/distinfo
+++ b/games/frogatto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (frogatto-1.1.1.tar.bz2) = d2404d8d83d5d5e2b42b25f632113d5fbfc22d2ef72c4a44ec7833257e550670
-SIZE (frogatto-1.1.1.tar.bz2) = 151088361
+SHA256 (frogatto-1.2.tar.gz) = b735bda8d409612eecc79e84d218b3bd460470f8bccca3472d08c893d91d1232
+SIZE (frogatto-1.2.tar.gz) = 261545835
diff --git a/games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg b/games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg
new file mode 100644
index 000000000000..55d5a4c7fe12
--- /dev/null
+++ b/games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg
@@ -0,0 +1,11 @@
+--- data/objects/enemies/milgramen/milgram_pod_launcher.cfg.orig 2012-11-10 21:52:46.000000000 +0400
++++ data/objects/enemies/milgramen/milgram_pod_launcher.cfg 2012-11-10 21:54:05.000000000 +0400
+@@ -74,7 +74,7 @@
+
+ on_die="spawn('explosion_big_recurring', midpoint_x, midpoint_y, facing)"
+
+- solid_area=10,20,38,50
++ solid_area=14,20,34,50
+
+ [base:animation]
+ image=enemies/milgram-pod-launcher.png
diff --git a/games/frogatto/files/patch-src-IMG_savepng.cpp b/games/frogatto/files/patch-src-IMG_savepng.cpp
deleted file mode 100644
index 939b4c614bc0..000000000000
--- a/games/frogatto/files/patch-src-IMG_savepng.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/IMG_savepng.cpp.orig 2011-04-08 16:11:45.000000000 +0200
-+++ src/IMG_savepng.cpp 2012-05-25 18:51:10.000000000 +0200
-@@ -27,6 +27,7 @@
-
- #ifdef IMPLEMENT_SAVE_PNG
- #include <png.h>
-+#include <zlib.h>
- #endif
-
- #include <stdlib.h>
diff --git a/games/frogatto/files/patch-src-custom_object.cpp b/games/frogatto/files/patch-src-custom_object.cpp
new file mode 100644
index 000000000000..10ab1b8e5f64
--- /dev/null
+++ b/games/frogatto/files/patch-src-custom_object.cpp
@@ -0,0 +1,11 @@
+--- src/custom_object.cpp.orig 2011-11-30 09:31:31.000000000 +0400
++++ src/custom_object.cpp 2012-11-10 21:39:11.000000000 +0400
+@@ -1394,7 +1394,7 @@
+ set_driver_position();
+
+ if(blur_) {
+- blur_->next_frame(start_x, start_y, x(), y(), frame_, time_in_frame_, face_right(), upside_down(), rotate_.value());
++ blur_->next_frame(start_x, start_y, x(), y(), frame_, time_in_frame_, face_right(), upside_down(), rotate_.as_float());
+ if(blur_->destroyed()) {
+ blur_.reset();
+ }
diff --git a/games/frogatto/files/patch-src-server.cpp b/games/frogatto/files/patch-src-server.cpp
deleted file mode 100644
index 5304afd98839..000000000000
--- a/games/frogatto/files/patch-src-server.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/server.cpp.orig 2012-03-12 10:21:03.000000000 +0300
-+++ src/server.cpp 2012-03-12 10:21:15.000000000 +0300
-@@ -37,7 +37,7 @@
- private:
- void start_accept()
- {
-- socket_ptr socket(new tcp::socket(acceptor_.io_service()));
-+ socket_ptr socket(new tcp::socket(acceptor_.get_io_service()));
- acceptor_.async_accept(*socket, boost::bind(&server::handle_accept, this, socket, boost::asio::placeholders::error));
- }
-