aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-07 23:21:02 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-07 23:21:02 +0800
commita103e6d1f9b8c94a142cf0e7e3fc91adc2f6d970 (patch)
tree116b6bcbacd75265cca85b72f9c94a511fb4b3bb /games
parent33168c2b2d064a6417ec3cf81e06695955494585 (diff)
downloadfreebsd-ports-gnome-a103e6d1f9b8c94a142cf0e7e3fc91adc2f6d970.tar.gz
freebsd-ports-gnome-a103e6d1f9b8c94a142cf0e7e3fc91adc2f6d970.tar.zst
freebsd-ports-gnome-a103e6d1f9b8c94a142cf0e7e3fc91adc2f6d970.zip
Stagify.
Diffstat (limited to 'games')
-rw-r--r--games/crafty-open-large/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/crafty-open-large/Makefile b/games/crafty-open-large/Makefile
index be1bd3364851..fa73d854a207 100644
--- a/games/crafty-open-large/Makefile
+++ b/games/crafty-open-large/Makefile
@@ -13,14 +13,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The large opening book for crafty
BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
-RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
+RUN_DEPENDS= ${BUILD_DEPENDS}
DIST_SUBDIR= crafty
USES= zip
NO_WRKSUBDIR= yes
CONFLICTS= crafty-open-enormous-* crafty-open-medium-* crafty-open-default-*
-NO_STAGE= yes
post-extract:
@${ECHO_MSG} '================================================================'
@${ECHO_MSG} 'Ignore warnings about illegal moves. These warnings are normal.'
@@ -32,9 +31,9 @@ do-build:
(${CHOWN} nobody ${WRKDIR}; cd ${WRKDIR}; crafty <${FILESDIR}/book-building)
do-install:
- ${MKDIR} ${PREFIX}/lib/crafty
- ${INSTALL_DATA} ${WRKDIR}/book.bin ${PREFIX}/lib/crafty/book.bin
- ${CHOWN} nobody:nogroup ${PREFIX}/lib/crafty/book.bin
- ${CHMOD} 664 ${PREFIX}/lib/crafty/book.bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/crafty
+ ${INSTALL_DATA} ${WRKDIR}/book.bin ${STAGEDIR}${PREFIX}/lib/crafty/book.bin
+ ${CHOWN} nobody:nogroup ${STAGEDIR}${PREFIX}/lib/crafty/book.bin
+ ${CHMOD} 664 ${STAGEDIR}${PREFIX}/lib/crafty/book.bin
.include <bsd.port.mk>