aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-08-29 01:03:43 +0800
committersat <sat@FreeBSD.org>2006-08-29 01:03:43 +0800
commita589c2fa442b4bbe247777b260fdf6edd5754308 (patch)
treeadc808e8b11c7f93b17007494163dc546491ed2f /games
parent8751eb266b4415e27be4454d6e5b78e71c3434b9 (diff)
downloadfreebsd-ports-gnome-a589c2fa442b4bbe247777b260fdf6edd5754308.tar.gz
freebsd-ports-gnome-a589c2fa442b4bbe247777b260fdf6edd5754308.tar.zst
freebsd-ports-gnome-a589c2fa442b4bbe247777b260fdf6edd5754308.zip
Add port games/palomino:
Palomino is an open-source action flight simulator with its own 3D engine. WWW: http://www.palomino3d.org/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/palomino/Makefile39
-rw-r--r--games/palomino/distinfo3
-rw-r--r--games/palomino/pkg-descr4
-rw-r--r--games/palomino/pkg-plist29
5 files changed, 76 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 836e50a6623c..55197794d515 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -493,6 +493,7 @@
SUBDIR += p5-Games-Dice
SUBDIR += p5-Games-Tournament-RoundRobin
SUBDIR += pachi
+ SUBDIR += palomino
SUBDIR += pathological
SUBDIR += pcgen
SUBDIR += pear-Games_Chess
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
new file mode 100644
index 000000000000..e02163b2ff51
--- /dev/null
+++ b/games/palomino/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: palomino
+# Date created: 28 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= palomino
+PORTVERSION= 20060827
+CATEGORIES= games
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}-sim
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Action flight simulator with its own 3D engine
+
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_GL= yes
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_WRKSRC= ${WRKSRC}/${PORTNAME}/game/pony
+MAKEFILE= GNUmakefile
+
+post-patch:
+ ${REINPLACE_CMD} -Ee 's!(string installDir = ).*$$!\1"${DATADIR}/";!' \
+ -e 's!../game/!!' ${WRKSRC}/palomino/game/pony/src/game_pony_init.cc
+
+do-install:
+ @${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/out/palomino ${PREFIX}/bin/
+ @${INSTALL} -d ${DATADIR}/pony/out
+ @${CP} -R ${INSTALL_WRKSRC}/models ${INSTALL_WRKSRC}/textures ${DATADIR}/pony/
+ @${CHMOD} -R a+rX,u+w,go-w ${DATADIR}/pony
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/src/game_pony.py \
+ ${WRKSRC}/palomino/engine/src/eng.py ${DATADIR}/pony/out/
+
+.include <bsd.port.mk>
diff --git a/games/palomino/distinfo b/games/palomino/distinfo
new file mode 100644
index 000000000000..ab2d8902152a
--- /dev/null
+++ b/games/palomino/distinfo
@@ -0,0 +1,3 @@
+MD5 (palomino_20060827.zip) = 5487172783ab6c2733bfe0b9b1d59551
+SHA256 (palomino_20060827.zip) = ef94db2e55fcbfe0fb2d2a2a5f058b9c0ebe3b145a5f6dbfc854ee04b254f006
+SIZE (palomino_20060827.zip) = 1100864
diff --git a/games/palomino/pkg-descr b/games/palomino/pkg-descr
new file mode 100644
index 000000000000..73c7eadbc553
--- /dev/null
+++ b/games/palomino/pkg-descr
@@ -0,0 +1,4 @@
+Palomino is an open-source action flight simulator with its own
+3D engine.
+
+WWW: http://www.palomino3d.org/
diff --git a/games/palomino/pkg-plist b/games/palomino/pkg-plist
new file mode 100644
index 000000000000..34e062e63655
--- /dev/null
+++ b/games/palomino/pkg-plist
@@ -0,0 +1,29 @@
+bin/palomino
+%%DATADIR%%/pony/models/f-14tomcat.pal
+%%DATADIR%%/pony/models/tank.pal
+%%DATADIR%%/pony/out/eng.py
+%%DATADIR%%/pony/out/game_pony.py
+%%DATADIR%%/pony/textures/cloud1.tga.gz
+%%DATADIR%%/pony/textures/desert1.tga.gz
+%%DATADIR%%/pony/textures/explosion1.tga.gz
+%%DATADIR%%/pony/textures/grass1.tga.gz
+%%DATADIR%%/pony/textures/hangar1.tga.gz
+%%DATADIR%%/pony/textures/road1.tga.gz
+%%DATADIR%%/pony/textures/sand1.tga.gz
+%%DATADIR%%/pony/textures/tree1.tga.gz
+%%DATADIR%%/pony/textures/tree2.tga.gz
+%%DATADIR%%/pony/textures/tree3.tga.gz
+%%DATADIR%%/pony/textures/tree4.tga.gz
+%%DATADIR%%/pony/textures/treeCactus1.tga.gz
+%%DATADIR%%/pony/textures/treeDead1.tga.gz
+%%DATADIR%%/pony/textures/treeOrange1.tga.gz
+%%DATADIR%%/pony/textures/treePalmSabal1.tga.gz
+%%DATADIR%%/pony/textures/treePine1.tga.gz
+%%DATADIR%%/pony/textures/treePine2.tga.gz
+%%DATADIR%%/pony/textures/treeShrub1.tga.gz
+%%DATADIR%%/pony/textures/water1.tga.gz
+@dirrm %%DATADIR%%/pony/models
+@dirrm %%DATADIR%%/pony/out
+@dirrm %%DATADIR%%/pony/textures
+@dirrm %%DATADIR%%/pony
+@dirrm %%DATADIR%%