aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-12-17 21:42:42 +0800
committernemysis <nemysis@FreeBSD.org>2013-12-17 21:42:42 +0800
commitb1d1e45490ac74cacbf5d00b400109ddee608e0d (patch)
tree30fc794cc919b63464f00034a87b898c2a333115 /games
parentc1ebaac7f9fd5cbbc828bd8ce6af687f24ae9dbc (diff)
downloadfreebsd-ports-gnome-b1d1e45490ac74cacbf5d00b400109ddee608e0d.tar.gz
freebsd-ports-gnome-b1d1e45490ac74cacbf5d00b400109ddee608e0d.tar.zst
freebsd-ports-gnome-b1d1e45490ac74cacbf5d00b400109ddee608e0d.zip
Blob Wars : Metal Blob Solid is a platform game, not unlike those found on
the Amiga and SNES. The object of the game is to take on the role of solider Blob, Bob, and play through the various levels and attempt to rescue as many MIA (Missing In Action) Blobs as possible. This is not quite as straight forward as it sounds, since the MIAs will often be not directly reachable and will require some extra thought. Bob also has to contend with environmental hazards, alien invaders and assimilated Blobs. WWW: http://www.parallelrealities.co.uk/p/blob-wars-metal-blob-solid.html Approved by: pawel (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/blobwars/Makefile59
-rw-r--r--games/blobwars/distinfo2
-rw-r--r--games/blobwars/files/patch-src__CReplayData.cpp12
-rw-r--r--games/blobwars/files/patch-src__pak.cpp20
-rw-r--r--games/blobwars/pkg-descr9
-rw-r--r--games/blobwars/pkg-plist16
7 files changed, 119 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 642ef50cd52c..c6ce24b297ac 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -81,6 +81,7 @@
SUBDIR += blinkensisters
SUBDIR += blobby
SUBDIR += bloboats
+ SUBDIR += blobwars
SUBDIR += block
SUBDIR += blockade
SUBDIR += blockout
diff --git a/games/blobwars/Makefile b/games/blobwars/Makefile
new file mode 100644
index 000000000000..a719ef0b8178
--- /dev/null
+++ b/games/blobwars/Makefile
@@ -0,0 +1,59 @@
+# Created by: Loren M. Lang <lorenl@alzatex.com>
+# $FreeBSD$
+
+PORTNAME= blobwars
+PORTVERSION= 1.19
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Mission and Objective based 2D Platform Game
+
+LICENSE= GPLv2 CCbyNCSA3
+LICENSE_COMB= dual
+LICENSE_NAME_CCbyNCSA3=Attribution-NonCommercial-ShareAlike 3.0 Unported
+LICENSE_FILE= ${WRKSRC}/doc/license
+LICENSE_TEXT_CCbyNCSA3=CC-BY 3.0
+LICENSE_PERMS_CCbyNCSA3=dist-mirror pkg-mirror auto-accept
+
+USES= gmake
+USE_SDL= image mixer net sdl ttf
+WITH_ZLIB= yes
+MAKEFILE= makefile
+
+INSTALLS_ICONS= yes
+
+PORTDOCS= *.gif *.png *.html changes hacking porting readme samples
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|mkdir -p $$(DESTDIR)$$(DOCDIR)|| ; \
+ s|cp -p $$(DOCS) $$(DESTDIR)$$(DOCDIR)|| ; \
+ s|USEPAK ?= 0|USEPAK ?= 1| ; \
+ s|/usr|${LOCALBASE}| ; \
+ s|$$(PREFIX)/games/|$$(PREFIX)/bin/| ; \
+ s|/share/games/blobwars/|/share/blobwars/| ; \
+ s| -Werror||' \
+ -e '/LIBS =/s/-lz/-lz -lintl/' \
+ ${WRKSRC}/makefile
+
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -i '' -e '/LOCALE_MO =/d' \
+ ${WRKSRC}/makefile
+.endif
+
+post-install:
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/64x64/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/blobwars/distinfo b/games/blobwars/distinfo
new file mode 100644
index 000000000000..e42e2bcf1005
--- /dev/null
+++ b/games/blobwars/distinfo
@@ -0,0 +1,2 @@
+SHA256 (blobwars-1.19.tar.gz) = f9bafe59ead9e370ceaba4aae3d280241bf05fa06c8ae006eec0322c2fe9e2ed
+SIZE (blobwars-1.19.tar.gz) = 67019647
diff --git a/games/blobwars/files/patch-src__CReplayData.cpp b/games/blobwars/files/patch-src__CReplayData.cpp
new file mode 100644
index 000000000000..dfe24dcb1650
--- /dev/null
+++ b/games/blobwars/files/patch-src__CReplayData.cpp
@@ -0,0 +1,12 @@
+--- ./src/CReplayData.cpp.orig 2011-04-17 16:56:56.000000000 +0200
++++ ./src/CReplayData.cpp 2013-12-08 23:21:23.000000000 +0100
+@@ -38,7 +38,8 @@
+
+ void ReplayData::printReplayInformation()
+ {
+- tm *timeinfo = localtime(&header.randomSeed);
++ time_t t = header.randomSeed;
++ tm *timeinfo = localtime(&t);
+ printf("Recorded on : %s", asctime(timeinfo));
+ printf("Map : %s\n", header.map);
+ printf("Score : %d\n", header.score);
diff --git a/games/blobwars/files/patch-src__pak.cpp b/games/blobwars/files/patch-src__pak.cpp
new file mode 100644
index 000000000000..5cb183a5430c
--- /dev/null
+++ b/games/blobwars/files/patch-src__pak.cpp
@@ -0,0 +1,20 @@
+--- ./src/pak.cpp.orig 2011-04-17 16:56:56.000000000 +0200
++++ ./src/pak.cpp 2013-12-08 23:09:51.000000000 +0100
+@@ -119,7 +119,7 @@
+ {
+ printf("Couldn't open %s for reading!\n", filename);
+ closedir(dirp);
+- gzclose(pak);
++ gzclose((gzFile)pak);
+ exit(1);
+ }
+
+@@ -141,7 +141,7 @@
+ {
+ printf("Couldn't open %s for reading!\n", filename);
+ closedir(dirp);
+- gzclose(pak);
++ gzclose((gzFile)pak);
+ exit(1);
+ }
+ else
diff --git a/games/blobwars/pkg-descr b/games/blobwars/pkg-descr
new file mode 100644
index 000000000000..4fb839cabc49
--- /dev/null
+++ b/games/blobwars/pkg-descr
@@ -0,0 +1,9 @@
+Blob Wars : Metal Blob Solid is a platform game, not unlike those found on
+the Amiga and SNES. The object of the game is to take on the role of
+solider Blob, Bob, and play through the various levels and attempt to rescue as
+many MIA (Missing In Action) Blobs as possible. This is not quite as straight
+forward as it sounds, since the MIAs will often be not directly reachable and
+will require some extra thought. Bob also has to contend with environmental
+hazards, alien invaders and assimilated Blobs.
+
+WWW: http://www.parallelrealities.co.uk/p/blob-wars-metal-blob-solid.html
diff --git a/games/blobwars/pkg-plist b/games/blobwars/pkg-plist
new file mode 100644
index 000000000000..f15d1cebee11
--- /dev/null
+++ b/games/blobwars/pkg-plist
@@ -0,0 +1,16 @@
+bin/blobwars
+share/applications/blobwars.desktop
+%%DATADIR%%/blobwars.pak
+share/icons/hicolor/16x16/apps/blobwars.png
+share/icons/hicolor/32x32/apps/blobwars.png
+share/icons/hicolor/64x64/apps/blobwars.png
+%%NLS%%share/locale/ca/LC_MESSAGES/blobwars.mo
+%%NLS%%share/locale/da/LC_MESSAGES/blobwars.mo
+%%NLS%%share/locale/de/LC_MESSAGES/blobwars.mo
+%%NLS%%share/locale/es/LC_MESSAGES/blobwars.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/blobwars.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/blobwars.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/blobwars.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/blobwars.mo
+share/pixmaps/blobwars.png
+@dirrm %%DATADIR%%