aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-04 07:27:49 +0800
committeradamw <adamw@FreeBSD.org>2014-07-04 07:27:49 +0800
commitb4256b24b1bf1e135d2a8763631b37415683e27d (patch)
treee7d95d834917f67398c73adb4e273ae1fb7c5187 /games
parent6056c4913313b7fc003873bbce7c5b0abce62c06 (diff)
downloadfreebsd-ports-gnome-b4256b24b1bf1e135d2a8763631b37415683e27d.tar.gz
freebsd-ports-gnome-b4256b24b1bf1e135d2a8763631b37415683e27d.tar.zst
freebsd-ports-gnome-b4256b24b1bf1e135d2a8763631b37415683e27d.zip
Remove NOPORTDOCS.
Diffstat (limited to 'games')
-rw-r--r--games/dodgindiamond2/Makefile6
-rw-r--r--games/doom-freedoom/Makefile4
-rw-r--r--games/moria/Makefile6
-rw-r--r--games/pinball/Makefile4
-rw-r--r--games/sol/Makefile4
-rw-r--r--games/unnethack/Makefile4
-rw-r--r--games/xroads/Makefile4
7 files changed, 15 insertions, 17 deletions
diff --git a/games/dodgindiamond2/Makefile b/games/dodgindiamond2/Makefile
index 8b147c1e093a..3b7a25513a7d 100644
--- a/games/dodgindiamond2/Makefile
+++ b/games/dodgindiamond2/Makefile
@@ -15,9 +15,13 @@ USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/games
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|COPYING||g' ${WRKSRC}/Makefile.in
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} '/install-data-am:/s/install-docsDATA//' \
${WRKSRC}/Makefile.in
.endif
diff --git a/games/doom-freedoom/Makefile b/games/doom-freedoom/Makefile
index 4ce45a280bb2..e3eed18479f7 100644
--- a/games/doom-freedoom/Makefile
+++ b/games/doom-freedoom/Makefile
@@ -22,15 +22,15 @@ PLIST_FILES= %%DATADIR%%/doom2.wad
PLIST_DIRS= %%DATADIR%%
PORTDOCS= ChangeLog NEWS README
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/doom2.wad ${STAGEDIR}${DATADIR}
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include "${.CURDIR}/../doom-data/Makefile.include"
diff --git a/games/moria/Makefile b/games/moria/Makefile
index 11256c0d18e7..88b00b6f6a72 100644
--- a/games/moria/Makefile
+++ b/games/moria/Makefile
@@ -17,9 +17,9 @@ ALL_TARGET= moria
MAKE_ENV+= DOCSDIR="${DOCSDIR}" MKDIR="${MKDIR}" TOUCH="${TOUCH}" \
STAGEDIR="${STAGEDIR}" DATADIR="${DATADIR}"
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
+
+OPTIONS_DEFINE= DOCS
do-configure:
${REINPLACE_CMD} -e "s:%%DATADIR%%:${DATADIR}:g" ${WRKSRC}/source/config.h
@@ -28,8 +28,6 @@ do-configure:
do-install:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install
${INSTALL_MAN} ${WRKSRC}/doc/moria.6 ${STAGEDIR}${PREFIX}/man/man6/
-.if !defined(NOPORTDOCS)
cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install
-.endif
.include <bsd.port.mk>
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 191cf88e795d..fff17aaa10a6 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -19,6 +19,8 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
+OPTIONS_DEFINE= DOCS
+
.if defined(WITH_ALLEGRO)
BROKEN= support with Allegro is (temporarily?) broken as of version 0.3.1
LIB_DEPENDS+= liballeg.so:${PORTSDIR}/devel/allegro
@@ -40,11 +42,9 @@ pre-configure:
${REINPLACE_CMD} -e 's,^dnl,# dnl,;/echo.*RANLIB/,+1d'
post-install:
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/sol/Makefile b/games/sol/Makefile
index 00df7b3ccf0e..eb5668dcaca9 100644
--- a/games/sol/Makefile
+++ b/games/sol/Makefile
@@ -20,7 +20,7 @@ CONFLICTS= gnome-games-*
USES= gmake
USE_XORG= xpm x11 xaw
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
pre-build:
cd ${WRKSRC} && ${MAKE_CMD} readme.var
@@ -35,10 +35,8 @@ do-install:
@${CHMOD} 2755 ${STAGEDIR}${PREFIX}/bin/sol
@${CHMOD} 770 ${STAGEDIR}${PREFIX}/share/sol
@${CHMOD} 660 ${STAGEDIR}${PREFIX}/share/sol/sol.score
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/sol
${INSTALL_DATA} ${WRKSRC}/CREDITS ${STAGEDIR}${PREFIX}/share/doc/sol
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${PREFIX}/share/doc/sol
-.endif
.include <bsd.port.post.mk>
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index 298831ed271a..52f8931708f2 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -28,6 +28,8 @@ SUB_FILES= pkg-deinstall
SUB_LIST= VARDIR="${VARDIR}"
PLIST_SUB= VARDIR="${VARDIR_REL}"
+OPTIONS_DEFINE= DOCS
+
post-patch:
${MV} ${WRKSRC}/doc/nethack.6 ${WRKSRC}/doc/${PORTNAME}.6
@@ -40,9 +42,7 @@ post-install:
*) ${MV} $$fn unnethack_$$fn ;; \
esac; \
done
-.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${FILESDIR}/sample.unnethackrc ${STAGEDIR}${DOCSDIR}
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/games/xroads/Makefile b/games/xroads/Makefile
index 223354d63c16..0fe2dd17d40a 100644
--- a/games/xroads/Makefile
+++ b/games/xroads/Makefile
@@ -13,7 +13,7 @@ COMMENT= Commodore 64 "Crossroads"-like video game for X Window System
USE_XORG= x11 xpm xext
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xroads ${STAGEDIR}${PREFIX}/bin
@@ -21,11 +21,9 @@ do-install:
.for file in 00 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17 18
${INSTALL_DATA} ${WRKSRC}/map${file}.xrm ${STAGEDIR}${PREFIX}/share/xroads
.endfor
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/xroads
.for file in BUGS CHANGELOG README
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/share/doc/xroads
.endfor
-.endif
.include <bsd.port.post.mk>