aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-08-03 03:50:23 +0800
committeracm <acm@FreeBSD.org>2006-08-03 03:50:23 +0800
commitc41ab131eaf64409426bbeb582e63de03d2cce4f (patch)
tree904466caed6db70840c7c83970de53f0003fb60d /games
parentce32498d6dc4ca438bfde8a1faf04746849d185a (diff)
downloadfreebsd-ports-gnome-c41ab131eaf64409426bbeb582e63de03d2cce4f.tar.gz
freebsd-ports-gnome-c41ab131eaf64409426bbeb582e63de03d2cce4f.tar.zst
freebsd-ports-gnome-c41ab131eaf64409426bbeb582e63de03d2cce4f.zip
- Update to 1.3
- Removed USE_X_PREFIX - Added NO_CDROM and NO_PACKAGE - Added linux- prefix to all quake* scripts Approved by: garga (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/linux-quake4/Makefile13
-rw-r--r--games/linux-quake4/distinfo6
-rw-r--r--games/linux-quake4/files/pkg-message.in4
-rw-r--r--games/linux-quake4/pkg-plist28
4 files changed, 31 insertions, 20 deletions
diff --git a/games/linux-quake4/Makefile b/games/linux-quake4/Makefile
index 4e91489fedc9..f460e9df1e2c 100644
--- a/games/linux-quake4/Makefile
+++ b/games/linux-quake4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= quake4
-PORTVERSION= 1.2.1
+PORTVERSION= 1.3
PORTEPOCH= 1
CATEGORIES= games linux
MASTER_SITES= ${MASTER_SITE_IDSOFTWARE:S|$|quake4/linux/|} \
@@ -21,9 +21,10 @@ COMMENT= Quake 4 for Linux
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
ONLY_FOR_ARCHS= i386 amd64
-USE_X_PREFIX= yes
USE_LINUX= yes
NO_WRKSUBDIR= yes
+NO_CDROM= Redistribution is limited, see license
+NO_PACKAGE= Package will be 230MB, set FORCE_PACKAGE if you really want it
Q4DIR= lib/${PORTNAME}
PLIST_SUB+= Q4DIR="${Q4DIR}" \
LINUXBASE="${LINUXBASE}"
@@ -54,18 +55,18 @@ do-build:
@${SED} \
-e 's|@Q4DIR@|${PREFIX}/${Q4DIR}|' \
-e 's|@APP@|${FILE}.x86|' \
- ${FILESDIR}/run.sh.in > ${WRKSRC}/${FILE}.sh
+ ${FILESDIR}/run.sh.in > ${WRKSRC}/${PKGNAMEPREFIX}${FILE}.sh
.endfor
do-install:
# Executables
@${MKDIR} ${PREFIX}/${Q4DIR}
.for FILE in quake4 q4ded
- ${INSTALL_SCRIPT} ${WRKSRC}/${FILE}.sh ${PREFIX}/bin/${FILE}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PKGNAMEPREFIX}${FILE}.sh ${PREFIX}/bin/${PKGNAMEPREFIX}${FILE}
${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/x86/${FILE}.x86 ${PREFIX}/${Q4DIR}
.endfor
.if !defined(WITHOUT_SMP)
- ${INSTALL_SCRIPT} ${WRKSRC}/quake4smp.sh ${PREFIX}/bin/quake4smp
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PKGNAMEPREFIX}quake4smp.sh ${PREFIX}/bin/${PKGNAMEPREFIX}quake4smp
${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/x86/quake4smp.x86 ${PREFIX}/${Q4DIR}
.endif
@@ -79,7 +80,7 @@ do-install:
-exec ${INSTALL_DATA} "{}" "${PREFIX}/${Q4DIR}/{}" \;
# Q4base
@cd ${WRKSRC} && \
- ${FIND} -E q4base -type f -iregex ".*\.(cfg|scriptcfg|pk4)" \
+ ${FIND} -E q4base -type f -iregex ".*\.(cfg|scriptcfg|pk4|off)" \
-exec ${INSTALL_DATA} "{}" "${PREFIX}/${Q4DIR}/{}" \;
# All version (except germany) or only germany version
diff --git a/games/linux-quake4/distinfo b/games/linux-quake4/distinfo
index 51645fcec8d7..00beee47b093 100644
--- a/games/linux-quake4/distinfo
+++ b/games/linux-quake4/distinfo
@@ -1,3 +1,3 @@
-MD5 (quake4-linux-1.2.1.x86.run) = ed9ecbddf8d3e5cf4e7d5330303c3610
-SHA256 (quake4-linux-1.2.1.x86.run) = 1e23a3f509a3d3ce86519c3ad0a29677eb05e2cc28f773dca1971ad025032622
-SIZE (quake4-linux-1.2.1.x86.run) = 123174709
+MD5 (quake4-linux-1.3.x86.run) = 90f9c1390e38e723e62a5a07fd96cc91
+SHA256 (quake4-linux-1.3.x86.run) = 3ac59bec1e4b3120677ed062293582fb72d2b2bbb11bdaab35efb8f03500c688
+SIZE (quake4-linux-1.3.x86.run) = 239447744
diff --git a/games/linux-quake4/files/pkg-message.in b/games/linux-quake4/files/pkg-message.in
index e77d702c78fb..62741ae88e43 100644
--- a/games/linux-quake4/files/pkg-message.in
+++ b/games/linux-quake4/files/pkg-message.in
@@ -1,4 +1,4 @@
-------------------------------------------------------------
+###############################################################################
1) In order to play Quake 4, you need to copy some data files
from the Quake 4 DVD or CD's. Please read the following
@@ -10,4 +10,4 @@ file:
Have fun!
-------------------------------------------------------------
+###############################################################################
diff --git a/games/linux-quake4/pkg-plist b/games/linux-quake4/pkg-plist
index 0717e98d4d25..27c9694556a9 100644
--- a/games/linux-quake4/pkg-plist
+++ b/games/linux-quake4/pkg-plist
@@ -1,6 +1,6 @@
-%%SMP%%bin/quake4smp
-bin/q4ded
-bin/quake4
+%%SMP%%bin/linux-quake4smp
+bin/linux-q4ded
+bin/linux-quake4
%%Q4DIR%%/pb/htm/la001307.htm
%%Q4DIR%%/pb/htm/lc001095.htm
%%Q4DIR%%/pb/htm/ma001307.htm
@@ -20,6 +20,7 @@ bin/quake4
%%Q4DIR%%/q4base/game200.pk4
%%Q4DIR%%/q4base/mapcycle-mp1.scriptcfg
%%Q4DIR%%/q4base/mapcycle-mp2.scriptcfg
+%%Q4DIR%%/q4base/mapcycle-mp3.scriptcfg
%%Q4DIR%%/q4base/mapcycle.scriptcfg
%%Q4DIR%%/q4base/pak013.pk4
%%Q4DIR%%/q4base/pak014.pk4
@@ -27,16 +28,25 @@ bin/quake4
%%Q4DIR%%/q4base/pak016.pk4
%%Q4DIR%%/q4base/pak017.pk4
%%Q4DIR%%/q4base/pak018.pk4
+%%Q4DIR%%/q4base/pak019.pk4
+%%Q4DIR%%/q4base/pak020.pk4
%%Q4DIR%%/q4base/teamdm.cfg
%%Q4DIR%%/q4base/tourney.cfg
+%%Q4DIR%%/q4base/zpak_czech_01.pk4.off
%%Q4DIR%%/q4base/zpak_english_01.pk4
%%Q4DIR%%/q4base/zpak_english_02.pk4
-%%Q4DIR%%/q4base/zpak_french_01.pk4
-%%Q4DIR%%/q4base/zpak_french_02.pk4
-%%Q4DIR%%/q4base/zpak_italian_01.pk4
-%%Q4DIR%%/q4base/zpak_italian_02.pk4
-%%Q4DIR%%/q4base/zpak_spanish_01.pk4
-%%Q4DIR%%/q4base/zpak_spanish_02.pk4
+%%Q4DIR%%/q4base/zpak_english_03.pk4
+%%Q4DIR%%/q4base/zpak_french_01.pk4.off
+%%Q4DIR%%/q4base/zpak_french_02.pk4.off
+%%Q4DIR%%/q4base/zpak_french_03.pk4.off
+%%Q4DIR%%/q4base/zpak_italian_01.pk4.off
+%%Q4DIR%%/q4base/zpak_italian_02.pk4.off
+%%Q4DIR%%/q4base/zpak_italian_03.pk4.off
+%%Q4DIR%%/q4base/zpak_polish_01.pk4.off
+%%Q4DIR%%/q4base/zpak_russian_01.pk4.off
+%%Q4DIR%%/q4base/zpak_spanish_01.pk4.off
+%%Q4DIR%%/q4base/zpak_spanish_02.pk4.off
+%%Q4DIR%%/q4base/zpak_spanish_03.pk4.off
%%SMP%%%%Q4DIR%%/quake4smp.x86
%%Q4DIR%%/q4ded.x86
%%Q4DIR%%/quake4.x86