aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-05-08 08:04:32 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-05-08 08:04:32 +0800
commitcd5d5c90d44156f6bb46ccd86412f2bddef08374 (patch)
tree6bc475f8adcc17d4b895fa2006644b3c1aea9af2 /games
parent5f760994ff7c31d36780db2098751640eb2c1a79 (diff)
downloadfreebsd-ports-gnome-cd5d5c90d44156f6bb46ccd86412f2bddef08374.tar.gz
freebsd-ports-gnome-cd5d5c90d44156f6bb46ccd86412f2bddef08374.tar.zst
freebsd-ports-gnome-cd5d5c90d44156f6bb46ccd86412f2bddef08374.zip
Add sdlsand 20060207, a simulation of falling sand and other materials.
PR: 96905 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/sdlsand/Makefile38
-rw-r--r--games/sdlsand/distinfo3
-rw-r--r--games/sdlsand/pkg-descr7
4 files changed, 49 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ab495dab60e2..c27572322304 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -558,6 +558,7 @@
SUBDIR += sdb
SUBDIR += sdlquake2
SUBDIR += sdlroids
+ SUBDIR += sdlsand
SUBDIR += seabattle
SUBDIR += seahaven
SUBDIR += senken
diff --git a/games/sdlsand/Makefile b/games/sdlsand/Makefile
new file mode 100644
index 000000000000..d017be8bee62
--- /dev/null
+++ b/games/sdlsand/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: sdlsand
+# Date created: 22 Apr 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdlsand
+PORTVERSION= 20060207
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= sldsand-src-${PORTVERSION}
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Simulation of falling sand and other materials
+
+USE_ZIP= yes
+USE_SDL= sdl
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/SDL\ Sand/SDL\ Sand
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= readme.txt
+
+do-build:
+ cd ${WRKSRC} && ${CXX} -o ${PORTNAME} ${CXXFLAGS} \
+ `${SDL_CONFIG} --cflags --libs` main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/sdlsand/distinfo b/games/sdlsand/distinfo
new file mode 100644
index 000000000000..99649553a92d
--- /dev/null
+++ b/games/sdlsand/distinfo
@@ -0,0 +1,3 @@
+MD5 (sldsand-src-20060207.zip) = c2611a17ad7665bcbfb28352dc95434e
+SHA256 (sldsand-src-20060207.zip) = cab31d00789115fbd13a57b29a5a4e6752e3f70b718d168389785cdda8d649d5
+SIZE (sldsand-src-20060207.zip) = 552046
diff --git a/games/sdlsand/pkg-descr b/games/sdlsand/pkg-descr
new file mode 100644
index 000000000000..29c637483cae
--- /dev/null
+++ b/games/sdlsand/pkg-descr
@@ -0,0 +1,7 @@
+The SDL Sand game (The Falling SDL-Sand Game) is a C++ implementation of the
+original 'World of Sand' (and later 'Hell of Sand') game implemented in JAVA.
+SDL Sand uses the SDL (Simple DirectMedia Library - http://www.libsdl.org/)
+library for screen output. Therefore the implementation can possibly run on
+every platform supported by SDL.
+
+WWW: http://sourceforge.net/projects/sdlsand/