aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-17 05:30:34 +0800
committermiwi <miwi@FreeBSD.org>2008-05-17 05:30:34 +0800
commitcfed8817f35ab394d82665222d422957793c97e1 (patch)
tree7d9cbd0d5da628df4a7f2e7596a69c10b8b28a0b /games
parent508a12f8b7388dab577ad67f5e59c48f3e45cbe5 (diff)
downloadfreebsd-ports-gnome-cfed8817f35ab394d82665222d422957793c97e1.tar.gz
freebsd-ports-gnome-cfed8817f35ab394d82665222d422957793c97e1.tar.zst
freebsd-ports-gnome-cfed8817f35ab394d82665222d422957793c97e1.zip
brickshooter is a small puzzle game, where you'll have
to clear the central area from different colored bricks. Three or more same colored bricks that touch will vanish. You can shoot bricks into the playing field from the fringes. WWW: http://bilious.homelinux.org/~paxed/brickshooter/ PR: ports/123540 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/brickshooter/Makefile42
-rw-r--r--games/brickshooter/distinfo3
-rw-r--r--games/brickshooter/pkg-descr6
-rw-r--r--games/brickshooter/pkg-plist35
5 files changed, 87 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 0d60f77599a0..056ffabcc48b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -97,6 +97,7 @@
SUBDIR += bomns
SUBDIR += boswars
SUBDIR += braincurses
+ SUBDIR += brickshooter
SUBDIR += briquolo
SUBDIR += brutalchess
SUBDIR += bs
diff --git a/games/brickshooter/Makefile b/games/brickshooter/Makefile
new file mode 100644
index 000000000000..45d41b6343ff
--- /dev/null
+++ b/games/brickshooter/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: brickshooter
+# Date created: 09 May 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= brickshooter
+PORTVERSION= 0.04
+CATEGORIES= games
+MASTER_SITES= http://bilious.homelinux.org/~paxed/brickshooter/ \
+ http://www.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Push blocks on to the playing field, match block colors to remove them
+
+USE_SDL= sdl mixer image
+
+PORTDOCS= *
+
+post-patch:
+.for dir in gfx levels snd
+ @${REINPLACE_CMD} -e 's|${dir}/|${DATADIR}/&|g' ${WRKSRC}/${PORTNAME}.c
+.endfor
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c \
+ `${SDL_CONFIG} --libs --cflags` -lSDL_image -lSDL_mixer
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.for dir in gfx levels snd
+ ${MKDIR} ${DATADIR}/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/brickshooter/distinfo b/games/brickshooter/distinfo
new file mode 100644
index 000000000000..560f67b9ca0e
--- /dev/null
+++ b/games/brickshooter/distinfo
@@ -0,0 +1,3 @@
+MD5 (brickshooter-0.04.tar.gz) = 9b2308e44591917b8d1f0b0382b7e878
+SHA256 (brickshooter-0.04.tar.gz) = 6ad01eada201261e50b29a57cafce34f0af33777896ca5ff9a0f2208111a6698
+SIZE (brickshooter-0.04.tar.gz) = 2278635
diff --git a/games/brickshooter/pkg-descr b/games/brickshooter/pkg-descr
new file mode 100644
index 000000000000..21322ebaa190
--- /dev/null
+++ b/games/brickshooter/pkg-descr
@@ -0,0 +1,6 @@
+brickshooter is a small puzzle game for linux, where you'll have
+to clear the central area from different colored bricks. Three or
+more same colored bricks that touch will vanish. You can shoot
+bricks into the playing field from the fringes.
+
+WWW: http://bilious.homelinux.org/~paxed/brickshooter/
diff --git a/games/brickshooter/pkg-plist b/games/brickshooter/pkg-plist
new file mode 100644
index 000000000000..30c8d617ce75
--- /dev/null
+++ b/games/brickshooter/pkg-plist
@@ -0,0 +1,35 @@
+bin/brickshooter
+%%DATADIR%%/gfx/background.png
+%%DATADIR%%/gfx/background2.png
+%%DATADIR%%/gfx/background3.png
+%%DATADIR%%/gfx/background4.png
+%%DATADIR%%/gfx/background5.png
+%%DATADIR%%/gfx/background6.png
+%%DATADIR%%/gfx/charset.png
+%%DATADIR%%/gfx/charset.xcf
+%%DATADIR%%/gfx/cursor.png
+%%DATADIR%%/gfx/explosion.png
+%%DATADIR%%/gfx/explosion.xcf
+%%DATADIR%%/gfx/level_bg.png
+%%DATADIR%%/gfx/level_bg.xcf
+%%DATADIR%%/gfx/score_bg.png
+%%DATADIR%%/gfx/score_bg.xcf
+%%DATADIR%%/gfx/targeting.png
+%%DATADIR%%/gfx/targeting.xcf
+%%DATADIR%%/gfx/tile.xcf
+%%DATADIR%%/gfx/tiles.png
+%%DATADIR%%/gfx/window_border.png
+%%DATADIR%%/levels/aigyptos.dat
+%%DATADIR%%/snd/blockhit.wav
+%%DATADIR%%/snd/blockout.wav
+%%DATADIR%%/snd/cantmove.wav
+%%DATADIR%%/snd/explode.wav
+%%DATADIR%%/snd/finishset.wav
+%%DATADIR%%/snd/gameover.wav
+%%DATADIR%%/snd/nextlevel.wav
+%%DATADIR%%/snd/shootblock.wav
+%%DATADIR%%/snd/startup.wav
+@dirrm %%DATADIR%%/snd
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%