aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-04-22 00:32:53 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-04-22 00:32:53 +0800
commitd97d6153282f27eb6abc89e8088a0e9ca667b822 (patch)
treef851f9e176955f3fa43a673761c1aa09a74c5fec /games
parented4be690a08ad871e3161b02518c4ea8325b8c38 (diff)
downloadfreebsd-ports-gnome-d97d6153282f27eb6abc89e8088a0e9ca667b822.tar.gz
freebsd-ports-gnome-d97d6153282f27eb6abc89e8088a0e9ca667b822.tar.zst
freebsd-ports-gnome-d97d6153282f27eb6abc89e8088a0e9ca667b822.zip
- Add LICENSE
- Fix plist
Diffstat (limited to 'games')
-rw-r--r--games/golly/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/golly/Makefile b/games/golly/Makefile
index 6890466d1f34..2ad330bfee09 100644
--- a/games/golly/Makefile
+++ b/games/golly/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Conway's Game of Life and other cellular automata
+LICENSE= GPLv2+
+
USES= compiler:c++11-lib cmake:outsource perl5 python
USE_CXXSTD= c++11
USE_WX= 3.0
@@ -17,11 +19,14 @@ WX_UNICODE= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/gui-wx
-DESKTOP_ENTRIES= "Golly" "${COMMENT}" "${PREFIX}/share/pixmaps/golly.xpm" \
- "${PREFIX}/bin/golly" "Education;" "true"
+DESKTOP_ENTRIES="Golly" "${COMMENT}" "${PREFIX}/share/pixmaps/golly.xpm" \
+ "${PREFIX}/bin/golly" "Education;" "true"
SUB_FILES= golly
+post-extract:
+ @${FIND} ${WRKSRC} -name "._*" -delete
+
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/golly ${STAGEDIR}/${PREFIX}/bin