aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-09-14 14:21:14 +0800
committerjgh <jgh@FreeBSD.org>2012-09-14 14:21:14 +0800
commite205b4e9dbd27e00ea20ed11aa68ee442d58ec03 (patch)
tree0aeb7f9f219de4712f4f3b62a69b9ad4ab143be1 /games
parentbd484359f9d591369adeec5b8237a2b03fb7db82 (diff)
downloadfreebsd-ports-gnome-e205b4e9dbd27e00ea20ed11aa68ee442d58ec03.tar.gz
freebsd-ports-gnome-e205b4e9dbd27e00ea20ed11aa68ee442d58ec03.tar.zst
freebsd-ports-gnome-e205b4e9dbd27e00ea20ed11aa68ee442d58ec03.zip
- add startup script
- adopt optionsNG for DOCS - while here adjust run depends listing PR: 170738 Submitted by: maintainer, nemysis@gmx.ch
Diffstat (limited to 'games')
-rw-r--r--games/mopesnake/Makefile22
-rw-r--r--games/mopesnake/files/mopesnake.in7
2 files changed, 17 insertions, 12 deletions
diff --git a/games/mopesnake/Makefile b/games/mopesnake/Makefile
index 2d2aea94ce6c..7ab37e4aac63 100644
--- a/games/mopesnake/Makefile
+++ b/games/mopesnake/Makefile
@@ -1,44 +1,42 @@
-# New Ports collection makefile for: mopesnake
-# Date created: 2012-05-16
-# Whom: nemysis@gmx.ch
-#
# $FreeBSD$
-#
PORTNAME= mopesnake
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-pc-${DISTVERSION}
MAINTAINER= nemysis@gmx.ch
-COMMENT= A classic snake game in which you attempt to eat all the pain
+COMMENT= Classic snake game in which you attempt to eat all the pain
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=0:${PORTSDIR}/devel/py-game
USE_ZIP= yes
USE_PYTHON= yes
NO_BUILD= yes
-PLIST_FILES= bin/mopesnake \
+PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
PORTDATA= *
PORTDOCS= TODO.txt index.html
+SUB_FILES= ${PORTNAME}
+
post-patch:
# Fix path to python interpreter
@${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
${WRKSRC}/*.py ${WRKSRC}/mopelib/*.py
@(cd ${WRKSRC} && ${RM} *.py.bak mopelib/*py.bak)
+.include <bsd.port.options.mk>
+
do-install:
# Scripts
- @${PRINTF} "#!/bin/sh\n\ncd ${DATADIR} &&\
- ./${PORTNAME}.py\n" > ${WRKDIR}/${PORTNAME}.sh
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
# Executable
${MKDIR} ${DATADIR}
@@ -52,7 +50,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/version ${DATADIR}
# Documentation
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
diff --git a/games/mopesnake/files/mopesnake.in b/games/mopesnake/files/mopesnake.in
new file mode 100644
index 000000000000..e99c4d4c75b7
--- /dev/null
+++ b/games/mopesnake/files/mopesnake.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+echo "Master Of Pain (Eating) - Snake: Starting up..."
+cd "%%DATADIR%%"
+./mopesnake.py \ No newline at end of file