aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-08-17 14:56:12 +0800
committerkris <kris@FreeBSD.org>2000-08-17 14:56:12 +0800
commitea2ecc46ac85e67985d7587fe665c7f090bd3d0f (patch)
tree18f43ed4cc2c1b6ba91a201e1b99b1d1445af98f /games
parent94b12eea8d7e30e71b2375a86c5b88fc3a03d91f (diff)
downloadfreebsd-ports-gnome-ea2ecc46ac85e67985d7587fe665c7f090bd3d0f.tar.gz
freebsd-ports-gnome-ea2ecc46ac85e67985d7587fe665c7f090bd3d0f.tar.zst
freebsd-ports-gnome-ea2ecc46ac85e67985d7587fe665c7f090bd3d0f.zip
Make this setgid games to avoid a world-writable file
Diffstat (limited to 'games')
-rw-r--r--games/xemeraldia/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/xemeraldia/Makefile b/games/xemeraldia/Makefile
index 8a1886e1da41..2c9503ba04a9 100644
--- a/games/xemeraldia/Makefile
+++ b/games/xemeraldia/Makefile
@@ -21,8 +21,11 @@ USE_IMAKE= yes
NO_INSTALL_MANPAGES= yes
post-install:
+ @${CHOWN} root:games ${PREFIX}/bin/xemeraldia
+ @${CHMOD} 2755 ${PREFIX}/bin/xemeraldia
@${MKDIR} ${PREFIX}/lib/X11/xemeraldia
@${TOUCH} ${PREFIX}/lib/X11/xemeraldia/xemeraldia.scores
- @${CHMOD} 666 ${PREFIX}/lib/X11/xemeraldia/xemeraldia.scores
+ @${CHOWN} root:games ${PREFIX}/lib/X11/xemeraldia/xemeraldia.scores
+ @${CHMOD} 664 ${PREFIX}/lib/X11/xemeraldia/xemeraldia.scores
.include <bsd.port.mk>