aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-21 05:18:54 +0800
committeredwin <edwin@FreeBSD.org>2005-12-21 05:18:54 +0800
commitef29426b7c8f0b364f8b4e1f91e5e081bcfb1be1 (patch)
tree1dce311f30e18e22645887e3bb4f9087e6e5de8c /games
parentdd981a4fa00fe786577003f80cb0ac9d026fbd98 (diff)
downloadfreebsd-ports-gnome-ef29426b7c8f0b364f8b4e1f91e5e081bcfb1be1.tar.gz
freebsd-ports-gnome-ef29426b7c8f0b364f8b4e1f91e5e081bcfb1be1.tar.zst
freebsd-ports-gnome-ef29426b7c8f0b364f8b4e1f91e5e081bcfb1be1.zip
[BUG]: games/linux-nwnclient dependency problem
The linux-nwnclient port checks to see if WITH_NVIDIA_GL is defined to determine whether or not it should depend on the nvidia-driver instead of linux_dri. However, both dependencies are needed as linux_dri provides 'libGLU.so.1', which does not come with the nvidia-driver. This is needed in order to run linux-nwnclient. I use the nvidia-driver port and had to install linux_dri by hand after installing nwn. It seems to be working fine in conjunction with the driver. My suggestion is to either drop the nvidia-driver dependency entirely, or at least depend on linux_dri whether WITH_NVIDIA_GL is defined or not.
Diffstat (limited to 'games')
-rw-r--r--games/linux-nwnclient/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 1a40576a9cb4..9392f69d2b68 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -18,12 +18,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Neverwinter Nights Linux (x86) Client
RUN_DEPENDS= ${LOCALBASE}/share/nwndata/NWNv129.txt:${PORTSDIR}/games/nwndata \
- ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.ifdef(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-.else
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.endif
NO_BUILD= yes