aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-01-30 18:53:08 +0800
committeredwin <edwin@FreeBSD.org>2005-01-30 18:53:08 +0800
commitf04818aec41662893dc9e9fe5aaca3bd11ef0605 (patch)
tree8d06508c8ddb27e5ea3aa73ce890f2cf203ad463 /games
parent946a0860f30571d1fb32684a16efa5fc02d3402d (diff)
downloadfreebsd-ports-gnome-f04818aec41662893dc9e9fe5aaca3bd11ef0605.tar.gz
freebsd-ports-gnome-f04818aec41662893dc9e9fe5aaca3bd11ef0605.tar.zst
freebsd-ports-gnome-f04818aec41662893dc9e9fe5aaca3bd11ef0605.zip
New game!
Einstein puzzle is cross-platform open source remake of old DOS game Sherlock which was inspired by Albert Einstein's puzzle. Einstein said that only those with an intelligence quotient of 98 percentile and higher should be able to solve it.
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/einstein/Makefile23
-rw-r--r--games/einstein/distinfo2
-rw-r--r--games/einstein/files/patch-Makefile110
-rw-r--r--games/einstein/pkg-descr9
-rw-r--r--games/einstein/pkg-message3
-rw-r--r--games/einstein/pkg-plist1
7 files changed, 149 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 2cc07523da63..dc93e281b26d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -115,6 +115,7 @@
SUBDIR += egoboo
SUBDIR += eif
SUBDIR += eights
+ SUBDIR += einstein
SUBDIR += el
SUBDIR += emacs-chess
SUBDIR += empire
diff --git a/games/einstein/Makefile b/games/einstein/Makefile
new file mode 100644
index 000000000000..c367599a3d4b
--- /dev/null
+++ b/games/einstein/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: einstein
+# Date created: 30 january 2005
+# Whom: edwin@mavetju.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= einstein
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.babichev.info/files/einstein/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= Remake of old DOS game Sherlock, which was inspired by Albert Einstein's puzzle.
+
+USE_SDL= sdl ttf
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/einstein/distinfo b/games/einstein/distinfo
new file mode 100644
index 000000000000..b43b5e7b4255
--- /dev/null
+++ b/games/einstein/distinfo
@@ -0,0 +1,2 @@
+MD5 (einstein-1.0-src.tar.gz) = b52325a7ec1a552216d25c2f967b6f94
+SIZE (einstein-1.0-src.tar.gz) = 824047
diff --git a/games/einstein/files/patch-Makefile b/games/einstein/files/patch-Makefile
new file mode 100644
index 000000000000..b8b3fa592c16
--- /dev/null
+++ b/games/einstein/files/patch-Makefile
@@ -0,0 +1,110 @@
+--- Makefile.orig Sun Jan 30 21:45:02 2005
++++ Makefile Sun Jan 30 21:51:08 2005
+@@ -5,7 +5,6 @@
+ ########################################
+
+ # installation prefix
+-PREFIX=/usr/local
+
+ ########################################
+ #
+@@ -15,8 +14,8 @@
+
+ OPTIMIZE=#-O6 -march=pentium4 -mfpmath=sse -fomit-frame-pointer -funroll-loops
+ DEBUG=-ggdb
+-CXXFLAGS=-pipe -Wall $(OPTIMIZE) $(DEBUG) `sdl-config --cflags` -DPREFIX=\"$(PREFIX)\"
+-LNFLAGS=-pipe -lSDL_ttf -lfreetype `sdl-config --libs` -lz
++CXXFLAGS=-pipe -Wall $(OPTIMIZE) $(DEBUG) `${SDL_CONFIG} --cflags` -DPREFIX=\"$(PREFIX)\"
++LNFLAGS=-pipe -lSDL_ttf -lfreetype `${SDL_CONFIG} --libs` -lz
+
+ TARGET=einstein
+
+@@ -52,86 +51,5 @@
+ run: $(TARGET)
+ ./$(TARGET)
+
+-# DO NOT DELETE
+-
+-puzgen.o: /usr/include/stdlib.h /usr/include/features.h
+-puzgen.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
+-puzgen.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
+-puzgen.o: /usr/include/stdio.h /usr/include/bits/types.h
+-puzgen.o: /usr/include/bits/wordsize.h /usr/include/bits/typesizes.h
+-puzgen.o: /usr/include/libio.h /usr/include/_G_config.h /usr/include/wchar.h
+-puzgen.o: /usr/include/bits/wchar.h /usr/include/gconv.h
+-puzgen.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stdarg.h
+-puzgen.o: /usr/include/bits/stdio_lim.h /usr/include/bits/sys_errlist.h
+-puzgen.o: puzgen.h iconset.h exceptions.h utils.h resources.h widgets.h
+-puzgen.o: font.h
+-main.o: /usr/include/stdlib.h /usr/include/features.h
+-main.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
+-main.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h main.h
+-main.o: exceptions.h screen.h resources.h random.h utils.h widgets.h font.h
+-main.o: storage.h
+-screen.o: screen.h exceptions.h
+-resources.o: /usr/include/zlib.h /usr/include/zconf.h resources.h
+-resources.o: exceptions.h main.h screen.h random.h utils.h widgets.h font.h
+-utils.o: /usr/include/stdio.h /usr/include/features.h
+-utils.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
+-utils.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
+-utils.o: /usr/include/bits/types.h /usr/include/bits/wordsize.h
+-utils.o: /usr/include/bits/typesizes.h /usr/include/libio.h
+-utils.o: /usr/include/_G_config.h /usr/include/wchar.h
+-utils.o: /usr/include/bits/wchar.h /usr/include/gconv.h
+-utils.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stdarg.h
+-utils.o: /usr/include/bits/stdio_lim.h /usr/include/bits/sys_errlist.h
+-utils.o: /usr/include/stdlib.h /usr/include/sys/time.h /usr/include/time.h
+-utils.o: /usr/include/bits/time.h /usr/include/sys/select.h
+-utils.o: /usr/include/bits/select.h /usr/include/bits/sigset.h
+-utils.o: /usr/include/sys/types.h /usr/include/sys/stat.h
+-utils.o: /usr/include/bits/stat.h /usr/include/unistd.h
+-utils.o: /usr/include/bits/posix_opt.h /usr/include/bits/confname.h utils.h
+-utils.o: resources.h exceptions.h widgets.h font.h main.h screen.h random.h
+-game.o: main.h exceptions.h screen.h resources.h random.h utils.h widgets.h
+-game.o: font.h puzzle.h iconset.h puzgen.h verthints.h horhints.h topscores.h
+-game.o: opensave.h game.h options.h
+-widgets.o: widgets.h font.h main.h exceptions.h screen.h resources.h random.h
+-widgets.o: utils.h
+-iconset.o: /usr/include/string.h /usr/include/features.h
+-iconset.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
+-iconset.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
+-iconset.o: iconset.h utils.h resources.h exceptions.h widgets.h font.h
+-puzzle.o: puzzle.h iconset.h puzgen.h widgets.h font.h main.h exceptions.h
+-puzzle.o: screen.h resources.h random.h utils.h
+-rules.o: puzgen.h iconset.h utils.h resources.h exceptions.h widgets.h font.h
+-rules.o: main.h screen.h random.h
+-random.o: random.h utils.h resources.h exceptions.h widgets.h font.h
+-horhints.o: horhints.h iconset.h puzgen.h widgets.h font.h main.h
+-horhints.o: exceptions.h screen.h resources.h random.h utils.h
+-menu.o: main.h exceptions.h screen.h resources.h random.h utils.h widgets.h
+-menu.o: font.h topscores.h opensave.h game.h puzgen.h iconset.h verthints.h
+-menu.o: horhints.h puzzle.h descr.h options.h
+-font.o: font.h main.h exceptions.h screen.h resources.h random.h utils.h
+-font.o: widgets.h
+-conf.o: /usr/include/ctype.h /usr/include/features.h /usr/include/sys/cdefs.h
+-conf.o: /usr/include/gnu/stubs.h /usr/include/bits/types.h
+-conf.o: /usr/include/bits/wordsize.h
+-conf.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
+-conf.o: /usr/include/bits/typesizes.h /usr/include/endian.h
+-conf.o: /usr/include/bits/endian.h /usr/include/string.h
+-conf.o: /usr/include/stdlib.h /usr/include/stdio.h /usr/include/libio.h
+-conf.o: /usr/include/_G_config.h /usr/include/wchar.h
+-conf.o: /usr/include/bits/wchar.h /usr/include/gconv.h
+-conf.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stdarg.h
+-conf.o: /usr/include/bits/stdio_lim.h /usr/include/bits/sys_errlist.h conf.h
+-storage.o: storage.h tablestorage.h conf.h
+-tablestorage.o: tablestorage.h storage.h conf.h
+-topscores.o: topscores.h widgets.h font.h storage.h utils.h resources.h
+-topscores.o: exceptions.h
+-opensave.o: /usr/include/time.h /usr/include/bits/types.h
+-opensave.o: /usr/include/features.h /usr/include/sys/cdefs.h
+-opensave.o: /usr/include/gnu/stubs.h /usr/include/bits/wordsize.h
+-opensave.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
+-opensave.o: /usr/include/bits/typesizes.h exceptions.h utils.h resources.h
+-opensave.o: widgets.h font.h storage.h opensave.h game.h puzgen.h iconset.h
+-opensave.o: verthints.h horhints.h puzzle.h
+-descr.o: widgets.h font.h
+-options.o: options.h widgets.h font.h storage.h main.h exceptions.h screen.h
+-options.o: resources.h random.h
++install:
++ ${BSD_INSTALL_PROGRAM} ${TARGET} ${PREFIX}/bin
diff --git a/games/einstein/pkg-descr b/games/einstein/pkg-descr
new file mode 100644
index 000000000000..6e8fd7928ba8
--- /dev/null
+++ b/games/einstein/pkg-descr
@@ -0,0 +1,9 @@
+Einstein puzzle is cross-platform open source remake of old DOS
+game Sherlock which was inspired by Albert Einstein's puzzle.
+Einstein said that only those with an intelligence quotient of 98
+percentile and higher should be able to solve it.
+
+See the WWW site for the rules of the game.
+
+WWW: http://www.babichev.info/en/projects/einstein/
+Author: Alexander Babichev <asso@babichev.info>
diff --git a/games/einstein/pkg-message b/games/einstein/pkg-message
new file mode 100644
index 000000000000..e626ebf3814f
--- /dev/null
+++ b/games/einstein/pkg-message
@@ -0,0 +1,3 @@
+This game doesn't come with a proper manual. Please see
+http://www.babichev.info/en/projects/einstein/ for more information
+on how the game is supposed to be played.
diff --git a/games/einstein/pkg-plist b/games/einstein/pkg-plist
new file mode 100644
index 000000000000..687fc2d114a0
--- /dev/null
+++ b/games/einstein/pkg-plist
@@ -0,0 +1 @@
+bin/einstein