aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-11-21 21:36:51 +0800
committermartymac <martymac@FreeBSD.org>2013-11-21 21:36:51 +0800
commitfd0231b70311c30833ec29c0864e37ea628a686a (patch)
tree1d5776b5c132177d61afe71424f59b9e813e4d59 /games
parent77a9a3609ea4e74e727596f77573ea00d4594768 (diff)
downloadfreebsd-ports-gnome-fd0231b70311c30833ec29c0864e37ea628a686a.tar.gz
freebsd-ports-gnome-fd0231b70311c30833ec29c0864e37ea628a686a.tar.zst
freebsd-ports-gnome-fd0231b70311c30833ec29c0864e37ea628a686a.zip
- Enable staging
- Use new LIB_DEPENDS format - Update USES - Always stage documentation
Diffstat (limited to 'games')
-rw-r--r--games/cosmosmash/Makefile21
-rw-r--r--games/cosmosmash/pkg-plist3
2 files changed, 5 insertions, 19 deletions
diff --git a/games/cosmosmash/Makefile b/games/cosmosmash/Makefile
index 5e52ea26aadc..37c2b52ac16d 100644
--- a/games/cosmosmash/Makefile
+++ b/games/cosmosmash/Makefile
@@ -13,35 +13,22 @@ COMMENT= A clone of the Intellivision(TM) game Astrosmash(TM)
LICENSE= GPLv2
-LIB_DEPENDS= flatzebra:${PORTSDIR}/devel/flatzebra \
- aa:${PORTSDIR}/graphics/aalib \
- mikmod:${PORTSDIR}/audio/libmikmod \
+LIB_DEPENDS= libflatzebra-0.1.so:${PORTSDIR}/devel/flatzebra \
+ libaa.so:${PORTSDIR}/graphics/aalib \
+ libmikmod.so:${PORTSDIR}/audio/libmikmod \
libaudiofile.so:${PORTSDIR}/audio/libaudiofile
USE_SDL= sdl image mixer
USE_XORG= x11 xau xdmcp
-USES= iconv pkgconfig
-USE_GNOME= desktopfileutils
+USES= iconv pkgconfig desktop-file-utils
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} `${SDL_CONFIG} --libs`
-MAN6= cosmosmash.6
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} 's|^pkgsounddir = .*|pkgsounddir = ${DATADIR}/sounds|' \
${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} 's|^docdir = .*|docdir = ${DOCSDIR}|' \
${WRKSRC}/Makefile.in
-.if empty(PORT_OPTIONS:MDOCS)
- @${REINPLACE_CMD} 's|^install-data-am: .*|install-data-am: install-man|' \
- ${WRKSRC}/Makefile.in
-.endif
-
-post-install:
- @-update-desktop-database
.include <bsd.port.mk>
diff --git a/games/cosmosmash/pkg-plist b/games/cosmosmash/pkg-plist
index 5abcf7c49b5c..5cfdb228d507 100644
--- a/games/cosmosmash/pkg-plist
+++ b/games/cosmosmash/pkg-plist
@@ -1,4 +1,5 @@
bin/cosmosmash
+man/man6/cosmosmash.6.gz
share/applications/cosmosmash.desktop
share/pixmaps/cosmosmash.png
%%DATADIR%%/sounds/rock-hit-0.wav
@@ -18,5 +19,3 @@ share/pixmaps/cosmosmash.png
%%PORTDOCS%%%%DOCSDIR%%/THANKS
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true