aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-12-18 02:34:07 +0800
committeralepulver <alepulver@FreeBSD.org>2007-12-18 02:34:07 +0800
commit85070f81f98210ac6b4a1717a95c7d08b67b0ab8 (patch)
tree872ef318d29cff303fc9a43b409c2ef19ffa3e21 /games
parenta41eec62469ccd1dc2cb669c2fbe2868091f47ed (diff)
downloadfreebsd-ports-gnome-85070f81f98210ac6b4a1717a95c7d08b67b0ab8.tar.gz
freebsd-ports-gnome-85070f81f98210ac6b4a1717a95c7d08b67b0ab8.tar.zst
freebsd-ports-gnome-85070f81f98210ac6b4a1717a95c7d08b67b0ab8.zip
Legends is a fast-paced first-person-perspective online multiplayer game
released as freeware (software license). The game is designed to take advantage of the beautiful environments available from the Torque engine it is based on, while still offering the breakneck pacing and variety of styles available from such classics as Quake and Tribes. Gameplay is not the strafe-strafe-jump-strafe-shoot-strafe-run-like-hell style a lot of games espouse; the addition of a jetpack adds a third dimension of mobility that makes skill, forethought, and restraint necessities to winning. Team sizes are ideal between 10 and 15 on each side, and the network code allows 56k upwards to play smoothly. Game type offerings range from the classic Capture the Flag, Deathmatch and Duel to our own new types, e.g.. 'War'. Plenty of maps are provided by us, but the beauty of this game is its customization possibilities. Mission creation has never been easier, with a stable, full-featured editor integrated into the game engine itself. Skins, models, and effects can all be modified by the end-user with commonly available tools. The game has an Autodownload feature which means you never have to leave the game to join new user created Client-Side and Server-Side missions. WWW: http://legendsthegame.net/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/legends/Makefile61
-rw-r--r--games/legends/distinfo6
-rw-r--r--games/legends/pkg-descr24
-rw-r--r--games/legends/pkg-plist40
5 files changed, 132 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 6510281f7a4f..a2d6ebd8c9bb 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -400,6 +400,7 @@
SUBDIR += lbreakout
SUBDIR += lbreakout2
SUBDIR += ldmud
+ SUBDIR += legends
SUBDIR += lexter
SUBDIR += lgeneral
SUBDIR += lgeneral-data
diff --git a/games/legends/Makefile b/games/legends/Makefile
new file mode 100644
index 000000000000..d8b1ee4bcd7e
--- /dev/null
+++ b/games/legends/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: legends
+# Date created: 2007-12-16
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= legends
+PORTVERSION= 0.4.1.43
+CATEGORIES= games
+MASTER_SITES= http://legendsthegame.net/files/:game \
+ http://legendsthegame.net/files/maps/:maps
+DISTNAME= ${PORTNAME}_linux_gui-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:game \
+ ${MAP_PACK}:maps
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Fast-paced first-person-perspective online multiplayer game
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_MAKESELF= yes
+USE_LINUX= yes
+USE_GL= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+DATADIR= ${PREFIX}/lib/${PORTNAME}
+
+# Standard map pack used in official servers.
+MAP_PACK= BTMappack-1.05.unf
+PLIST_SUB= MAP_PACK="${MAP_PACK}"
+
+# Should be in bsd.commands.mk. Remove when ports/118749 is committed.
+UNMAKESELF_CMD?= ${LOCALBASE}/bin/unmakeself
+
+post-extract:
+ @cd ${WRKDIR} && ${TAR} xf legends.tar
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|#!/bin/bash|#!${LOCALBASE}/bin/bash|; \
+ s|`dirname $$0`|${DATADIR}|; s|./LinLegends|exec &|; s| &$$||' \
+ ${WRKSRC}/bin/runlegends
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} LinLegends lindedicated *.so* ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/runlegends ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/legends.ico ${PREFIX}/share/pixmaps
+ ${LN} -sf ${DATADIR}/runlegends ${PREFIX}/bin/${PORTNAME}
+.for f in common legends main.cs show
+ ${CP} -r ${WRKSRC}/${f} ${DATADIR}
+.endfor
+ ${INSTALL_DATA} ${DISTDIR}/${MAP_PACK} ${DATADIR}/legends
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/legends/distinfo b/games/legends/distinfo
new file mode 100644
index 000000000000..c5b6d6cedcc3
--- /dev/null
+++ b/games/legends/distinfo
@@ -0,0 +1,6 @@
+MD5 (legends_linux_gui-0.4.1.43.run) = 0b8f96d5550698e492eee7dcef67cc3b
+SHA256 (legends_linux_gui-0.4.1.43.run) = 3c0f2f300449ecba6c27d9037c24268a32f840ae6f55dce9873b7eb839de3328
+SIZE (legends_linux_gui-0.4.1.43.run) = 126135996
+MD5 (BTMappack-1.05.unf) = 4e94227f0bd898cdfe2e4ac78e36fa3a
+SHA256 (BTMappack-1.05.unf) = 9b7e3d0771e8f25890d9892533b840425ba8e611723236fbc66cf27d3662e4b5
+SIZE (BTMappack-1.05.unf) = 28075888
diff --git a/games/legends/pkg-descr b/games/legends/pkg-descr
new file mode 100644
index 000000000000..2a3668b4a096
--- /dev/null
+++ b/games/legends/pkg-descr
@@ -0,0 +1,24 @@
+Legends is a fast-paced first-person-perspective online multiplayer game
+released as freeware (software license). The game is designed to take
+advantage of the beautiful environments available from the Torque engine it is
+based on, while still offering the breakneck pacing and variety of styles
+available from such classics as Quake and Tribes.
+
+Gameplay is not the strafe-strafe-jump-strafe-shoot-strafe-run-like-hell style
+a lot of games espouse; the addition of a jetpack adds a third dimension of
+mobility that makes skill, forethought, and restraint necessities to winning.
+
+Team sizes are ideal between 10 and 15 on each side, and the network code
+allows 56k upwards to play smoothly. Game type offerings range from the
+classic Capture the Flag, Deathmatch and Duel to our own new types, e.g..
+'War'.
+
+Plenty of maps are provided by us, but the beauty of this game is its
+customization possibilities. Mission creation has never been easier, with a
+stable, full-featured editor integrated into the game engine itself. Skins,
+models, and effects can all be modified by the end-user with commonly
+available tools. The game has an Autodownload feature which means you never
+have to leave the game to join new user created Client-Side and Server-Side
+missions.
+
+WWW: http://legendsthegame.net/
diff --git a/games/legends/pkg-plist b/games/legends/pkg-plist
new file mode 100644
index 000000000000..2f52a365c803
--- /dev/null
+++ b/games/legends/pkg-plist
@@ -0,0 +1,40 @@
+bin/legends
+%%DATADIR%%/LinLegends
+%%DATADIR%%/common/client.unf
+%%DATADIR%%/common/edit.unf
+%%DATADIR%%/common/main.cs
+%%DATADIR%%/common/server.unf
+%%DATADIR%%/common/ui.unf
+%%DATADIR%%/legends/%%MAP_PACK%%
+%%DATADIR%%/legends/data.unf
+%%DATADIR%%/legends/interiors.unf
+%%DATADIR%%/legends/main.cs
+%%DATADIR%%/legends/missions.unf
+%%DATADIR%%/legends/prefs/adminuserlist.cs
+%%DATADIR%%/legends/prefs/mapcycle.cs
+%%DATADIR%%/legends/scripts.unf
+%%DATADIR%%/legends/sounds.unf
+%%DATADIR%%/legends/voices.unf
+%%DATADIR%%/libSDL-1.2.so.0
+%%DATADIR%%/libSDL-1.3.so.0
+%%DATADIR%%/libogg.so.0
+%%DATADIR%%/libopenal.so
+%%DATADIR%%/libvorbis.so.0
+%%DATADIR%%/lindedicated
+%%DATADIR%%/main.cs
+%%DATADIR%%/runlegends
+%%DATADIR%%/show/defaults.cs
+%%DATADIR%%/show/main.cs
+%%DATADIR%%/show/scripts.unf
+%%DATADIR%%/show/ui.unf
+%%PORTDOCS%%%%DOCSDIR%%/ReadMe.txt
+%%PORTDOCS%%%%DOCSDIR%%/ReadMe_legals.txt
+%%PORTDOCS%%%%DOCSDIR%%/default.keybinds.txt
+%%PORTDOCS%%%%DOCSDIR%%/linux.txt
+share/pixmaps/legends.ico
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/show
+@dirrm %%DATADIR%%/legends/prefs
+@dirrm %%DATADIR%%/legends
+@dirrm %%DATADIR%%/common
+@dirrm %%DATADIR%%