aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-10-06 02:15:44 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-10-06 02:15:44 +0800
commit09a0e6d8bd7f1e871c4f749ec92443b6de6a28d8 (patch)
treefdb58a110e0a09a400ba3fb01c201ea8a59d8987 /games
parent571ec8f91bacb7f6e88e6d49d426b9b63080abb8 (diff)
downloadfreebsd-ports-gnome-09a0e6d8bd7f1e871c4f749ec92443b6de6a28d8.tar.gz
freebsd-ports-gnome-09a0e6d8bd7f1e871c4f749ec92443b6de6a28d8.tar.zst
freebsd-ports-gnome-09a0e6d8bd7f1e871c4f749ec92443b6de6a28d8.zip
- Update to 5.02
- Optionize DOCS - Update WWW PR: 212656 Submitted by: amdmi3 Approved by: maintainer timeout (hym@cocoa.freemail.ne.jp, 2 weeks)
Diffstat (limited to 'games')
-rw-r--r--games/sl/Makefile8
-rw-r--r--games/sl/distinfo5
-rw-r--r--games/sl/files/patch-sl.c60
-rw-r--r--games/sl/pkg-descr2
4 files changed, 10 insertions, 65 deletions
diff --git a/games/sl/Makefile b/games/sl/Makefile
index 90537cf70c3d..2b8349c220c3 100644
--- a/games/sl/Makefile
+++ b/games/sl/Makefile
@@ -2,21 +2,23 @@
# $FreeBSD$
PORTNAME= sl
-PORTVERSION=5.01
+PORTVERSION= 5.02
CATEGORIES= games
MAINTAINER= hym@cocoa.freemail.ne.jp
COMMENT= Steam locomotive runs across the screen if you type "sl" instead of "ls"
-USES= ncurses
USE_GITHUB= yes
GH_ACCOUNT= mtoyoda
+USES= ncurses
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz \
man/ja/man1/${PORTNAME}.1.gz
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
do-build:
${CC} ${CFLAGS} -I${WRKSRC} -o ${WRKSRC}/sl ${WRKSRC}/sl.c \
${LDFLAGS} -lncurses
@@ -25,6 +27,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.ja ${STAGEDIR}${MANPREFIX}/man/ja/man1/${PORTNAME}.1
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in README.md README.ja.md LICENSE
${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
diff --git a/games/sl/distinfo b/games/sl/distinfo
index a74e2e93bb36..8445ddb3df49 100644
--- a/games/sl/distinfo
+++ b/games/sl/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mtoyoda-sl-5.01_GH0.tar.gz) = b16fcaa40cb195105e97f86280e3f37a9011d0c01d7e534946386d126408f6da
-SIZE (mtoyoda-sl-5.01_GH0.tar.gz) = 5251
+TIMESTAMP = 1473706488
+SHA256 (mtoyoda-sl-5.02_GH0.tar.gz) = 1e5996757f879c81f202a18ad8e982195cf51c41727d3fea4af01fdcbbb5563a
+SIZE (mtoyoda-sl-5.02_GH0.tar.gz) = 5353
diff --git a/games/sl/files/patch-sl.c b/games/sl/files/patch-sl.c
deleted file mode 100644
index 6282cd1c8b74..000000000000
--- a/games/sl/files/patch-sl.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- sl.c.orig 2014-01-04 00:18:33.000000000 -0500
-+++ sl.c 2014-03-16 16:16:47.000000000 -0400
-@@ -37,6 +37,12 @@
- #include <unistd.h>
- #include "sl.h"
-
-+int add_sl(int);
-+int add_C51(int);
-+int add_D51(int);
-+void add_man(int, int);
-+void add_smoke(int, int);
-+
- int ACCIDENT = 0;
- int LOGO = 0;
- int FLY = 0;
-@@ -99,6 +105,8 @@
- }
- mvcur(0, COLS - 1, LINES - 1, 0);
- endwin();
-+
-+ return 0;
- }
-
-
-@@ -143,7 +151,7 @@
- }
-
-
--add_D51(int x)
-+int add_D51(int x)
- {
- static char *d51[D51PATTERNS][D51HIGHT + 1]
- = {{D51STR1, D51STR2, D51STR3, D51STR4, D51STR5, D51STR6, D51STR7,
-@@ -183,7 +191,7 @@
- return OK;
- }
-
--add_C51(int x)
-+int add_C51(int x)
- {
- static char *c51[C51PATTERNS][C51HIGHT + 1]
- = {{C51STR1, C51STR2, C51STR3, C51STR4, C51STR5, C51STR6, C51STR7,
-@@ -224,7 +232,7 @@
- }
-
-
--int add_man(int y, int x)
-+void add_man(int y, int x)
- {
- static char *man[2][2] = {{"", "(O)"}, {"Help!", "\\O/"}};
- int i;
-@@ -235,7 +243,7 @@
- }
-
-
--int add_smoke(int y, int x)
-+void add_smoke(int y, int x)
- #define SMOKEPTNS 16
- {
- static struct smokes {
diff --git a/games/sl/pkg-descr b/games/sl/pkg-descr
index 5a32c9635db1..405d506be751 100644
--- a/games/sl/pkg-descr
+++ b/games/sl/pkg-descr
@@ -4,4 +4,4 @@ runs across your screen if you type "sl" (Steam Locomotive) instead of
This program was written by TOYODA Masashi
-WWW: http://www.is.titech.ac.jp/~toyoda/
+WWW: http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html