aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-30 20:53:45 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-30 20:53:45 +0800
commit0f0e74821880174dddb5205381976b9cdb62f26a (patch)
tree11602f3249a5d09b1c0d87e53c6f16b97f6c98bd /games
parentec87f9f948aa282720b91916f32b537b48b6b902 (diff)
downloadfreebsd-ports-gnome-0f0e74821880174dddb5205381976b9cdb62f26a.tar.gz
freebsd-ports-gnome-0f0e74821880174dddb5205381976b9cdb62f26a.tar.zst
freebsd-ports-gnome-0f0e74821880174dddb5205381976b9cdb62f26a.zip
- fix build for png-1.4.1
- fix build for option WITHOUT_NLS
Diffstat (limited to 'games')
-rw-r--r--games/xbubble/Makefile1
-rw-r--r--games/xbubble/files/patch-src-loadpng.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/xbubble/Makefile b/games/xbubble/Makefile
index ce9302da3fc5..64db594bc3e3 100644
--- a/games/xbubble/Makefile
+++ b/games/xbubble/Makefile
@@ -21,6 +21,7 @@ MAN6= xbubble.6
USE_XORG= x11 xmu
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_GETTEXT= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/libpng" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
diff --git a/games/xbubble/files/patch-src-loadpng.c b/games/xbubble/files/patch-src-loadpng.c
new file mode 100644
index 000000000000..d7bf605ecb2a
--- /dev/null
+++ b/games/xbubble/files/patch-src-loadpng.c
@@ -0,0 +1,11 @@
+--- src/loadpng.c.orig 2003-09-30 14:55:20.000000000 +0200
++++ src/loadpng.c 2010-03-30 12:09:13.000000000 +0200
+@@ -55,7 +55,7 @@
+ }
+ /* ensure that we opened a PNG file */
+ fread( header, 1, 8, fd );
+- if ( ! png_check_sig( header, 8 ) ) {
++ if ( png_sig_cmp( header, 0, 8 ) ) {
+ fclose(fd);
+ fprintf(stderr,_("File %s does not have a valid PNG signature.\n"), file);
+ return NULL;