aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-13 16:59:49 +0800
committeredwin <edwin@FreeBSD.org>2007-09-13 16:59:49 +0800
commit107ed4f27d27e02ee08964564ee663d1ddce91f3 (patch)
tree3ee3bf5b011adb82be5304b34db4c3b5d01234f5 /games
parent283114fbeeeb1b3d3af98bd52716ac164c1108a0 (diff)
downloadfreebsd-ports-gnome-107ed4f27d27e02ee08964564ee663d1ddce91f3.tar.gz
freebsd-ports-gnome-107ed4f27d27e02ee08964564ee663d1ddce91f3.tar.zst
freebsd-ports-gnome-107ed4f27d27e02ee08964564ee663d1ddce91f3.zip
Add option to disable Assembly for the algorythm.
Submitted by: James Cook <james.cook@utoronto.ca>
Diffstat (limited to 'games')
-rw-r--r--games/liquidwar/Makefile14
-rw-r--r--games/liquidwar/pkg-descr5
2 files changed, 16 insertions, 3 deletions
diff --git a/games/liquidwar/Makefile b/games/liquidwar/Makefile
index 1a1eb30d20f8..1954966a3f1c 100644
--- a/games/liquidwar/Makefile
+++ b/games/liquidwar/Makefile
@@ -7,7 +7,7 @@
PORTNAME= liquidwar
PORTVERSION= 5.6.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://liquidwar.sunsite.dk/archive/ \
${MASTER_SITE_SAVANNAH} \
@@ -22,7 +22,7 @@ LIB_DEPENDS= alleg.42:${PORTSDIR}/devel/allegro
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --disable-target-opt --disable-doc-ps --disable-doc-pdf
-USE_PYTHON_BUILD= yes
+USE_PYTHON_BUILD=yes
INFO= liquidwar
@@ -31,4 +31,12 @@ MAN6= liquidwar.6 \
liquidwar-server.6 \
liquidwar-mapgen.6
-.include <bsd.port.mk>
+OPTIONS= ASM "Disable assembly code (if it crashes)" OFF
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_ASM)
+CONFIGURE_ARGS+= --disable-asm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/liquidwar/pkg-descr b/games/liquidwar/pkg-descr
index c8aba97e64d1..2176687141aa 100644
--- a/games/liquidwar/pkg-descr
+++ b/games/liquidwar/pkg-descr
@@ -14,4 +14,9 @@ very often controls several thousands fighters at the same time.
And when fighters from different teams meet, they eat each other,
it is as simple as that.
+Note: If the game crashes this might resolve it:
+ Inside liquidwar, go to options->rules->advanced and change
+ Algorithm from "Assembly" to "Standard C"
+See also the "ASM" option in the port build options.
+
WWW: http://www.ufoot.org/liquidwar/