aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-11-04 10:16:37 +0800
committerdanfe <danfe@FreeBSD.org>2011-11-04 10:16:37 +0800
commit12b14a02b2136b9a852be6f18c04ed8ab8fa72d1 (patch)
tree194eb77d70ffb80ce864b72a386e3eea3ccf0371 /games
parent588c3fb2f0b939f638e6c77c5d5c25bd6bdebf26 (diff)
downloadfreebsd-ports-gnome-12b14a02b2136b9a852be6f18c04ed8ab8fa72d1.tar.gz
freebsd-ports-gnome-12b14a02b2136b9a852be6f18c04ed8ab8fa72d1.tar.zst
freebsd-ports-gnome-12b14a02b2136b9a852be6f18c04ed8ab8fa72d1.zip
Adjust a comment and move -fpermissive from CFLAGS into CXXFLAGS.
Diffstat (limited to 'games')
-rw-r--r--games/battletanks/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index a2500bbc6803..dca22b273b60 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -29,7 +29,7 @@ USE_SDL= image sdl
USE_SCONS= yes
SCONS_ARGS= prefix=${PREFIX} resources_dir=${DATADIR}
SCONS_BUILDENV= CC="${CC}" CXX="${CXX}" \
- CFLAGS="${CFLAGS} -fpermissive" CXXFLAGS="${CXXFLAGS}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS} -fpermissive" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" \
CPPPATH="${LOCALBASE}/include" LIBPATH="${LOCALBASE}/lib"
@@ -42,7 +42,7 @@ DESKTOP_ENTRIES="Battle Tanks" "${COMMENT}" "" "${PORTNAME}" \
"Application;Game;" false
pre-build:
-# Must regenerate `sl08.h' after we patch `sl08.py' (patching header itself
+# Regenerate `sl08.h' after we patch `sl08.py' (as patching the header itself
# would have resulted in a larger diff and gratuitous difference with Debian)
@cd ${WRKSRC} && python engine/sl08/sl08.py > engine/sl08/sl08.h