aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-01 07:51:02 +0800
committertobik <tobik@FreeBSD.org>2018-09-01 07:51:02 +0800
commit149ac85855ecb483df27db4830255ceebb1f3395 (patch)
treed577be340dc8be112e0d9be217b83b3f8cfee963 /games
parent9c4fa361e560f90f8538b8334eb2f97e79c58330 (diff)
downloadfreebsd-ports-gnome-149ac85855ecb483df27db4830255ceebb1f3395.tar.gz
freebsd-ports-gnome-149ac85855ecb483df27db4830255ceebb1f3395.tar.zst
freebsd-ports-gnome-149ac85855ecb483df27db4830255ceebb1f3395.zip
games/gillo: Fix build with Clang 6
src/entity.h:63:21: error: in-class initializer for static data member of type 'const float' requires 'constexpr' specifier [-Wstatic-float-init] static const float defaultCharge = 10; ^ http://beefy11.nyi.freebsd.org/data/head-i386-default/p478276_s338342/logs/errors/gillo-1.0.b1_10.log
Diffstat (limited to 'games')
-rw-r--r--games/gillo/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/gillo/Makefile b/games/gillo/Makefile
index 90913cea2601..5d57e8d66194 100644
--- a/games/gillo/Makefile
+++ b/games/gillo/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= libode.so:devel/ode
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= tar:bzip2
+USE_CXXSTD= c++98
USE_GL= glu
USE_SDL= yes