aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-30 05:43:17 +0800
committeradamw <adamw@FreeBSD.org>2014-07-30 05:43:17 +0800
commit1cf7c15bcf2522cd43d51dede202cd9250bad11f (patch)
tree626d2288bada68bcb887f72d08c8de3dfe0595dc /games
parentd67e1883b6d3deed93b173e9acc01cbe37453ad1 (diff)
downloadfreebsd-ports-gnome-1cf7c15bcf2522cd43d51dede202cd9250bad11f.tar.gz
freebsd-ports-gnome-1cf7c15bcf2522cd43d51dede202cd9250bad11f.tar.zst
freebsd-ports-gnome-1cf7c15bcf2522cd43d51dede202cd9250bad11f.zip
Convert some more USE_BZIP2 to USES=tar:bzip2
Approved by: portmgr (not really, but touches unstaged ports)
Diffstat (limited to 'games')
-rw-r--r--games/battalion/Makefile2
-rw-r--r--games/bsdrain/Makefile2
-rw-r--r--games/bsp/Makefile2
-rw-r--r--games/bubbros/Makefile2
-rw-r--r--games/criticalmass/Makefile2
-rw-r--r--games/doom-hacx/Makefile2
-rw-r--r--games/gnushogi/Makefile.common2
-rw-r--r--games/jinput/Makefile2
-rw-r--r--games/jutils/Makefile2
-rw-r--r--games/linux-skulltag/Makefile2
-rw-r--r--games/pysolfc/Makefile2
-rw-r--r--games/rftg/Makefile2
-rw-r--r--games/shaaft/Makefile2
-rw-r--r--games/slump/Makefile2
-rw-r--r--games/vdrift-data/Makefile2
-rw-r--r--games/vegastrike-data/Makefile2
16 files changed, 16 insertions, 16 deletions
diff --git a/games/battalion/Makefile b/games/battalion/Makefile
index 355e4c819786..85ef9bf6bdb0 100644
--- a/games/battalion/Makefile
+++ b/games/battalion/Makefile
@@ -12,7 +12,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Monsters, explosions, destruction game for X Window System
-USE_BZIP2= yes
+USES= tar:bzip2
USE_GL= glu
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LIBS="${LIBS}"
diff --git a/games/bsdrain/Makefile b/games/bsdrain/Makefile
index 52b031c4440e..a3886a484629 100644
--- a/games/bsdrain/Makefile
+++ b/games/bsdrain/Makefile
@@ -14,6 +14,6 @@ COMMENT= The original BSD rain program, ported from NetBSD
PLIST_FILES= bin/rain \
man/man6/rain.6.gz
-USE_BZIP2= yes
+USES= tar:bzip2
.include <bsd.port.mk>
diff --git a/games/bsp/Makefile b/games/bsp/Makefile
index bd6a008c3a64..791b89ac3222 100644
--- a/games/bsp/Makefile
+++ b/games/bsp/Makefile
@@ -11,7 +11,7 @@ COMMENT= Node builder for Doom
LICENSE= GPLv2
-USE_BZIP2= yes
+USES= tar:bzip2
GNU_CONFIGURE= yes
OPTIONS_DEFINE= DOCS
diff --git a/games/bubbros/Makefile b/games/bubbros/Makefile
index 971d8a3e6fd3..87b28d0163f7 100644
--- a/games/bubbros/Makefile
+++ b/games/bubbros/Makefile
@@ -14,7 +14,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
BUILD_DEPENDS:= ${RUN_DEPENDS}
USE_PYTHON= yes
-USE_BZIP2= yes
+USES= tar:bzip2
NO_STAGE= yes
post-patch:
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 96ccb7ea3a4b..1dbe3de95f6a 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
CONFLICTS= shaaft-[0-9]*
-USE_BZIP2= yes
+USES= tar:bzip2
USE_SDL= image mixer sdl
USE_GL= gl
USE_XORG= x11
diff --git a/games/doom-hacx/Makefile b/games/doom-hacx/Makefile
index 674d57108846..9dc24c5bef95 100644
--- a/games/doom-hacx/Makefile
+++ b/games/doom-hacx/Makefile
@@ -12,7 +12,7 @@ EXTRACT_SUFX= .bz2
MAINTAINER= ports@FreeBSD.org
COMMENT= Full TC using the Doom II engine
-USE_BZIP2= yes
+USES= tar:bzip2
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/games/gnushogi/Makefile.common b/games/gnushogi/Makefile.common
index 41c476ad6caf..13278ffb7b90 100644
--- a/games/gnushogi/Makefile.common
+++ b/games/gnushogi/Makefile.common
@@ -7,6 +7,6 @@ GNUSHOGI_PORTVERSION= 1.4.0
GNUSHOGI_MASTER_SITES= ${MASTER_SITE_GNU}
GNUSHOGI_DISTNAME= ${GNUSHOGI_PORTNAME}-${GNUSHOGI_PORTVERSION}
GNUSHOGI_MASTER_SITE_SUBDIR= ${GNUSHOGI_PORTNAME}
-USE_BZIP2= yes
+USES= tar:bzip2
DISTINFO_FILE= ${.CURDIR}/../../games/gnushogi/distinfo
diff --git a/games/jinput/Makefile b/games/jinput/Makefile
index a14ee9ff1d51..3bab7a2756d8 100644
--- a/games/jinput/Makefile
+++ b/games/jinput/Makefile
@@ -12,7 +12,7 @@ COMMENT= Java Game Controller API
BUILD_DEPENDS= ${JAVALIBDIR}/jutils/jutils.jar:${PORTSDIR}/games/jutils
RUN_DEPENDS= ${JAVALIBDIR}/jutils/jutils.jar:${PORTSDIR}/games/jutils
-USE_BZIP2= yes
+USES= tar:bzip2
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/games/jutils/Makefile b/games/jutils/Makefile
index 2b4cd831a23c..02991c2a1c40 100644
--- a/games/jutils/Makefile
+++ b/games/jutils/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= LOCAL/loader
MAINTAINER= ports@FreeBSD.org
COMMENT= Common utilities for Java Game Technology Group projects
-USE_BZIP2= yes
+USES= tar:bzip2
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/games/linux-skulltag/Makefile b/games/linux-skulltag/Makefile
index 6dcbffc4bed3..e2433bc34836 100644
--- a/games/linux-skulltag/Makefile
+++ b/games/linux-skulltag/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LINUXBASE}/lib/libfmodexp-4.24.16.so:${PORTSDIR}/audio/linux-fmod
USE_LINUX= yes
USE_LINUX_APPS= sdl12
ONLY_FOR_ARCHS= i386
-USE_BZIP2= yes
+USES= tar:bzip2
NO_BUILD= yes
SUB_FILES= skulltag.sh pkg-message
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index d7d35680e932..675826ca4cd9 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -17,7 +17,7 @@ LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
-USE_BZIP2= yes
+USES= tar:bzip2
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_AUTOPLIST= yes
diff --git a/games/rftg/Makefile b/games/rftg/Makefile
index 2e148e23cb58..8beeab296eec 100644
--- a/games/rftg/Makefile
+++ b/games/rftg/Makefile
@@ -14,7 +14,7 @@ LEGAL= Redistribution not authorized
GNU_CONFIGURE= yes
USE_GNOME= gtk20
-USE_BZIP2= yes
+USES= tar:bzip2
DOWNLOAD_URL= http://www.keldon.net/rftg/
NO_STAGE= yes
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index 4c72d351512a..40cd3139a320 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
CONFLICTS= criticalmass-*
-USE_BZIP2= yes
+USES= tar:bzip2
USE_SDL= mixer image sdl
USE_GL= yes
USE_GCC= any
diff --git a/games/slump/Makefile b/games/slump/Makefile
index ecb029c89d2e..6a6f2cbf3075 100644
--- a/games/slump/Makefile
+++ b/games/slump/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2 # (or later)
OPTIONS_DEFINE= DOCS
-USE_BZIP2= yes
+USES= tar:bzip2
MAKE_ARGS= FLAGS="${CFLAGS}"
PORTDOCS= README
diff --git a/games/vdrift-data/Makefile b/games/vdrift-data/Makefile
index 290c865bb4e0..f16b003104fc 100644
--- a/games/vdrift-data/Makefile
+++ b/games/vdrift-data/Makefile
@@ -14,7 +14,7 @@ COMMENT= Vdrift driving simulation data files
LICENSE= GPLv2
-USE_BZIP2= yes
+USES= tar:bzip2
NO_BUILD= yes
DATADIR= ${PREFIX}/share/vdrift
PLIST= ${WRKDIR}/pkg-plist
diff --git a/games/vegastrike-data/Makefile b/games/vegastrike-data/Makefile
index 4bb63fe0306c..30086393311b 100644
--- a/games/vegastrike-data/Makefile
+++ b/games/vegastrike-data/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Vega Strike data files
-USE_BZIP2= yes
+USES= tar:bzip2
NO_BUILD= yes
MANUAL_PACKAGE_BUILD=huge