aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-29 05:14:43 +0800
committermarino <marino@FreeBSD.org>2014-07-29 05:14:43 +0800
commit21fbad537c3245a56a9865acb0ce172b6253c656 (patch)
tree452af3e7e7227b810f18b4ff946ed9cf3a320630 /games
parent9bb82f829eb04aa48ed163569c342f64432843d3 (diff)
downloadfreebsd-ports-gnome-21fbad537c3245a56a9865acb0ce172b6253c656.tar.gz
freebsd-ports-gnome-21fbad537c3245a56a9865acb0ce172b6253c656.tar.zst
freebsd-ports-gnome-21fbad537c3245a56a9865acb0ce172b6253c656.zip
games/frogatto: Attempt to unbreak
Portsmon says this is broken everywhere. Maybe this untested PR from the maintainer will fix it. PR: 192126 Submitted by: maintainer (Green Dog)
Diffstat (limited to 'games')
-rw-r--r--games/frogatto/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index c816fd55455e..74e07ef1b729 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -3,6 +3,7 @@
PORTNAME= frogatto
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= fiziologus@gmail.com
@@ -20,13 +21,15 @@ GH_COMMIT= 58bd7c6
USES= gmake pkgconfig
ALL_TARGET= game server
-USE_GL= glew
-USE_SDL= image mixer ttf
+USE_GL= glew glu
+USE_SDL= sdl image mixer ttf
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-server
post-patch:
- @${ECHO_CMD} >> ${WRKSRC}/src/difficulty.hpp
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|-Werror||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,%lu,%u,' ${WRKSRC}/src/server.cpp
@${REINPLACE_CMD} -e 's,__linux__,__${OPSYS}__,' \
${WRKSRC}/src/clipboard.cpp