aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-08-25 03:22:07 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-08-25 03:22:07 +0800
commit2426249b1102a0f2f7ca041ee24ab44bbf92e75a (patch)
treebe64ae29d86cfa58dee492d8430ac9804451dd09 /games
parent9c21cccffdcfc6e706dd2c3cd950a1ff19e82a41 (diff)
downloadfreebsd-ports-gnome-2426249b1102a0f2f7ca041ee24ab44bbf92e75a.tar.gz
freebsd-ports-gnome-2426249b1102a0f2f7ca041ee24ab44bbf92e75a.tar.zst
freebsd-ports-gnome-2426249b1102a0f2f7ca041ee24ab44bbf92e75a.zip
An open-source re-implementation of RollerCoaster Tycoon 2. A construction and
management simulation video game that simulates amusement park management. WWW: https://openrct2.website/ PR: 221375 Submitted by: pkubaj@anongoth.pl
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/openrct2/Makefile44
-rw-r--r--games/openrct2/distinfo3
-rw-r--r--games/openrct2/files/patch-src_openrct2_config_Config.cpp11
-rw-r--r--games/openrct2/files/pkg-message.in10
-rw-r--r--games/openrct2/pkg-descr4
-rw-r--r--games/openrct2/pkg-plist43
7 files changed, 116 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 4c7190416b0c..0c2e8aa481a6 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -702,6 +702,7 @@
SUBDIR += openomf
SUBDIR += openpref
SUBDIR += openra
+ SUBDIR += openrct2
SUBDIR += opensfx
SUBDIR += opensonic
SUBDIR += openspades
diff --git a/games/openrct2/Makefile b/games/openrct2/Makefile
new file mode 100644
index 000000000000..ea297b78f7de
--- /dev/null
+++ b/games/openrct2/Makefile
@@ -0,0 +1,44 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= openrct2
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.1
+CATEGORIES= games
+EXTRACT_ONLY= ${PORTNAME}-${PORTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}_GH0${EXTRACT_SUFX}
+
+MAINTAINER= pkubaj@anongoth.pl
+COMMENT= Open source re-implementation of RollerCoaster Tycoon 2
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/licence.txt
+
+LIB_DEPENDS= libpng.so:graphics/png \
+ libjansson.so:devel/jansson \
+ libzip.so:archivers/libzip \
+ libspeexdsp.so:audio/speexdsp \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libcurl.so:ftp/curl \
+ libfreetype.so:print/freetype2
+
+USE_GITHUB= yes
+
+WRKSRC= ${WRKDIR}/OpenRCT2-${PORTVERSION}
+INSTALLS_ICONS= yes
+USES= compiler:c++14-lang cmake:outsource iconv localbase:ldflags pkgconfig ssl
+USE_GL= gl
+USE_LDCONFIG= yes
+USE_SDL= sdl2
+SUB_FILES= pkg-message
+SUB_LIST= DISTVERSIONPREFIX=${DISTVERSIONPREFIX} \
+ DISTVERSION=${DISTVERSION} \
+ PORTNAME=${PORTNAME}
+CMAKE_ARGS= -DDOWNLOAD_TITLE_SEQUENCES=OFF
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
+ ${WRKSRC}/src/openrct2/config/Config.cpp
+
+.include <bsd.port.mk>
diff --git a/games/openrct2/distinfo b/games/openrct2/distinfo
new file mode 100644
index 000000000000..9c8e9804dece
--- /dev/null
+++ b/games/openrct2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502898621
+SHA256 (openrct2-openrct2-v0.1.1_GH0.tar.gz) = 5d7a6c7f3c770e7de506958f86789c438c543c27d312fd096322cde4e89f50ad
+SIZE (openrct2-openrct2-v0.1.1_GH0.tar.gz) = 6284135
diff --git a/games/openrct2/files/patch-src_openrct2_config_Config.cpp b/games/openrct2/files/patch-src_openrct2_config_Config.cpp
new file mode 100644
index 000000000000..ff81e3d573d7
--- /dev/null
+++ b/games/openrct2/files/patch-src_openrct2_config_Config.cpp
@@ -0,0 +1,11 @@
+--- src/openrct2/config/Config.cpp.orig 2017-08-09 22:02:59 UTC
++++ src/openrct2/config/Config.cpp
+@@ -591,6 +591,8 @@ namespace Config
+ {
+ log_verbose("config_find_rct2_path(...)");
+
++ return "%%DATADIR%%";
++
+ static const utf8 * searchLocations[] =
+ {
+ "C:\\GOG Games\\RollerCoaster Tycoon 2 Triple Thrill Pack",
diff --git a/games/openrct2/files/pkg-message.in b/games/openrct2/files/pkg-message.in
new file mode 100644
index 000000000000..ad95fb9ab3e0
--- /dev/null
+++ b/games/openrct2/files/pkg-message.in
@@ -0,0 +1,10 @@
+================================================================================
+
+To complete the installation of this port, you need to download the file
+https://github.com/OpenRCT2/title-sequences/releases/download/%%DISTVERSIONPREFIX%%%%DISTVERSION%%/title-sequence-%%DISTVERSIONPREFIX%%%%DISTVERSION%%.zip
+and unpack it to %%PREFIX%%/share/%%PORTNAME%%/title.
+
+You need to follow https://openrct2.website/getting-started/index.html
+to finish installation.
+
+================================================================================
diff --git a/games/openrct2/pkg-descr b/games/openrct2/pkg-descr
new file mode 100644
index 000000000000..a9ef0f37f562
--- /dev/null
+++ b/games/openrct2/pkg-descr
@@ -0,0 +1,4 @@
+An open-source re-implementation of RollerCoaster Tycoon 2. A construction and
+management simulation video game that simulates amusement park management.
+
+WWW: https://openrct2.website/
diff --git a/games/openrct2/pkg-plist b/games/openrct2/pkg-plist
new file mode 100644
index 000000000000..b53a61802a29
--- /dev/null
+++ b/games/openrct2/pkg-plist
@@ -0,0 +1,43 @@
+bin/openrct2
+lib/libopenrct2.a
+share/applications/openrct2.desktop
+%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
+%%PORTDOCS%%%%DOCSDIR%%/contributors.md
+%%PORTDOCS%%%%DOCSDIR%%/licence.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+share/icons/hicolor/128x128/apps/openrct2.png
+share/icons/hicolor/16x16/apps/openrct2.png
+share/icons/hicolor/256x256/apps/openrct2.png
+share/icons/hicolor/32x32/apps/openrct2.png
+share/icons/hicolor/64x64/apps/openrct2.png
+share/icons/hicolor/scalable/apps/openrct2.svg
+man/man6/openrct2.6.gz
+%%DATADIR%%/g2.dat
+%%DATADIR%%/language/ca-ES.txt
+%%DATADIR%%/language/cs-CZ.txt
+%%DATADIR%%/language/de-DE.txt
+%%DATADIR%%/language/en-GB.txt
+%%DATADIR%%/language/en-US.txt
+%%DATADIR%%/language/es-ES.txt
+%%DATADIR%%/language/fi-FI.txt
+%%DATADIR%%/language/fr-FR.txt
+%%DATADIR%%/language/hu-HU.txt
+%%DATADIR%%/language/it-IT.txt
+%%DATADIR%%/language/ja-JP.txt
+%%DATADIR%%/language/ko-KR.txt
+%%DATADIR%%/language/nb-NO.txt
+%%DATADIR%%/language/nl-NL.txt
+%%DATADIR%%/language/pl-PL.txt
+%%DATADIR%%/language/pt-BR.txt
+%%DATADIR%%/language/ru-RU.txt
+%%DATADIR%%/language/sv-SE.txt
+%%DATADIR%%/language/zh-CN.txt
+%%DATADIR%%/language/zh-TW.txt
+%%DATADIR%%/shaders/copyframebuffer.frag
+%%DATADIR%%/shaders/copyframebuffer.vert
+%%DATADIR%%/shaders/drawimage.frag
+%%DATADIR%%/shaders/drawimage.vert
+%%DATADIR%%/shaders/drawline.frag
+%%DATADIR%%/shaders/drawline.vert
+%%DATADIR%%/shaders/fillrect.frag
+%%DATADIR%%/shaders/fillrect.vert