aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-07-28 19:45:08 +0800
committerpav <pav@FreeBSD.org>2009-07-28 19:45:08 +0800
commit291da30e08e6256cb9c448d12d81e18bfcef7895 (patch)
treeed5f09afdd626c922e88015da3aeeb6ae1eff9bd /games
parentdb5c7bc390ded3a323a9e1b04bb27d75d82b8182 (diff)
downloadfreebsd-ports-gnome-291da30e08e6256cb9c448d12d81e18bfcef7895.tar.gz
freebsd-ports-gnome-291da30e08e6256cb9c448d12d81e18bfcef7895.tar.zst
freebsd-ports-gnome-291da30e08e6256cb9c448d12d81e18bfcef7895.zip
- Update boost to 1.39
- Split boost port to separate components, with boost-all metaport PR: ports/137054 Submitted by: Alexander Churanov <churanov.port.maintainer@gmail.com> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/alephone/Makefile2
-rw-r--r--games/flightgear/Makefile2
-rw-r--r--games/flyhard/Makefile2
-rw-r--r--games/galaxyhack/Makefile2
-rw-r--r--games/glob2/Makefile2
-rw-r--r--games/lordsawar/Makefile4
-rw-r--r--games/love/Makefile2
-rw-r--r--games/mkhexgrid/Makefile2
-rw-r--r--games/pingus/Makefile2
-rw-r--r--games/plee-the-bear/Makefile2
-rw-r--r--games/pokerth/Makefile2
-rw-r--r--games/secretmaryochronicles/Makefile2
-rw-r--r--games/spring/Makefile2
-rw-r--r--games/wesnoth-devel/Makefile2
-rw-r--r--games/wesnoth/Makefile2
-rw-r--r--games/widelands/Makefile2
-rw-r--r--games/windstille/Makefile2
17 files changed, 19 insertions, 17 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 8a7184afcf66..810dade3f5a8 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -14,7 +14,7 @@ DISTNAME= AlephOne-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= The open source version of Bungie's Marathon game
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
USE_BZIP2= yes
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 9a5ffa12aa8e..864eba69eda5 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -23,7 +23,7 @@ MAINTAINER= ganael.laplanche@martymac.com
COMMENT= The FlightGear flight simulator
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- boost_thread.4:${PORTSDIR}/devel/boost
+ boost_thread.4:${PORTSDIR}/devel/boost-libs
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
diff --git a/games/flyhard/Makefile b/games/flyhard/Makefile
index 72313b7146e6..afa4148c4ba9 100644
--- a/games/flyhard/Makefile
+++ b/games/flyhard/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Game resembling Thrust, but with lots of shooting and puzzles
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index 8213c86c41eb..38f0012b0b0e 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -16,7 +16,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= AI script based strategy game
-LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost \
+LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index 197cbb3b43bf..74059316bff0 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION:R}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Globulation 2 - a free and innovative strategy game
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/rational.hpp:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/rational.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
speex.1:${PORTSDIR}/audio/speex \
fribidi.0:${PORTSDIR}/converters/fribidi\
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
index 950a32ac5334..06cd994c0be5 100644
--- a/games/lordsawar/Makefile
+++ b/games/lordsawar/Makefile
@@ -17,7 +17,9 @@ COMMENT= A Warlords II clone
LIB_DEPENDS= glademm-2.4:${PORTSDIR}/devel/libglademm24 \
gnet-2.0:${PORTSDIR}/net/gnet2 \
uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
-BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
+
+BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
+ ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/games/love/Makefile b/games/love/Makefile
index 981e4bff8d4f..55c3a841757b 100644
--- a/games/love/Makefile
+++ b/games/love/Makefile
@@ -17,7 +17,7 @@ COMMENT= Open-source 2D game engine
LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
physfs.1:${PORTSDIR}/devel/physfs \
freetype.9:${PORTSDIR}/print/freetype2
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/games/mkhexgrid/Makefile b/games/mkhexgrid/Makefile
index 42374b09d6e6..48b4b8f8d45b 100644
--- a/games/mkhexgrid/Makefile
+++ b/games/mkhexgrid/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A fully-configurable hex grid generator
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/lexical_cast.hpp:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/lexical_cast.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
USE_GMAKE= yes
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index 9f446b86b633..c658b1d7b0ac 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= Free Lemmings-like game
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- boost_regex.4:${PORTSDIR}/devel/boost \
+ boost_regex.4:${PORTSDIR}/devel/boost-libs \
physfs.1:${PORTSDIR}/devel/physfs
USE_BZIP2= yes
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
index 562654c11a55..cb27c32ce5dd 100644
--- a/games/plee-the-bear/Makefile
+++ b/games/plee-the-bear/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-light
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 2D platform jump and run game
-LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost \
+LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
claw_application.1:${PORTSDIR}/devel/libclaw
USE_BZIP2= yes
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index 91d14152c7a5..2e696b417454 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -14,7 +14,7 @@ DISTNAME= PokerTH-${PORTVERSION}-src
MAINTAINER= mad@madpilot.net
COMMENT= A poker game written in C++/QT4
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
mikmod.2:${PORTSDIR}/audio/libmikmod \
gnutls.26:${PORTSDIR}/security/gnutls \
curl.5:${PORTSDIR}/ftp/curl
diff --git a/games/secretmaryochronicles/Makefile b/games/secretmaryochronicles/Makefile
index 1086a19758f6..3a28894b14cc 100644
--- a/games/secretmaryochronicles/Makefile
+++ b/games/secretmaryochronicles/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Secret Maryo Chronicles two-dimensional platform game
LIB_DEPENDS= CEGUIBase.3:${PORTSDIR}/graphics/cegui \
- boost_filesystem.4:${PORTSDIR}/devel/boost \
+ boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
diff --git a/games/spring/Makefile b/games/spring/Makefile
index f86e071254fa..d92c1cf3d482 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -18,7 +18,7 @@ COMMENT= A project aiming to create a new and versatile RTS Engine
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
openal.0:${PORTSDIR}/audio/openal \
GLEW.1:${PORTSDIR}/graphics/glew \
- boost_thread.4:${PORTSDIR}/devel/boost \
+ boost_thread.4:${PORTSDIR}/devel/boost-libs \
IL.2:${PORTSDIR}/graphics/devil \
ogg.6:${PORTSDIR}/audio/libogg \
vorbis.4:${PORTSDIR}/audio/libvorbis
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index f86995f025df..8bd81135595c 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= wesnoth
MAINTAINER= philip@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
freetype.9:${PORTSDIR}/print/freetype2
CONFLICTS= wesnoth-1.4* wesnoth-1.6*
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 1980d62d3d35..c050337b0ad0 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= wesnoth
MAINTAINER= philip@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
freetype.9:${PORTSDIR}/print/freetype2
CONFLICTS= wesnoth-1.5*
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 3a6fb21d4bf6..559a54ffbbdc 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Realtime strategy game inspired by Settlers II
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- boost_thread.4:${PORTSDIR}/devel/boost
+ boost_thread.4:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
USE_GETTEXT= yes
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
index e1f9f8288fc6..0b4f67c932d7 100644
--- a/games/windstille/Makefile
+++ b/games/windstille/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
GLEW.1:${PORTSDIR}/graphics/glew \
squirrel.0:${PORTSDIR}/lang/squirrel \
freetype.9:${PORTSDIR}/print/freetype2
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
USE_SCONS= yes