aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbar <bar@FreeBSD.org>2014-05-12 05:23:09 +0800
committerbar <bar@FreeBSD.org>2014-05-12 05:23:09 +0800
commit2a3bc2941013d595b3624149fbdb8c1689c3acf7 (patch)
tree07f5100afccc024728dabf7ba440cfe46207c6a4 /games
parentc25c792a50b8aa9b72fe2be179b56d46e2e6ae91 (diff)
downloadfreebsd-ports-gnome-2a3bc2941013d595b3624149fbdb8c1689c3acf7.tar.gz
freebsd-ports-gnome-2a3bc2941013d595b3624149fbdb8c1689c3acf7.tar.zst
freebsd-ports-gnome-2a3bc2941013d595b3624149fbdb8c1689c3acf7.zip
- Support STAGEDIR
- Use options helpers
Diffstat (limited to 'games')
-rw-r--r--games/linux-enemyterritory-jaymod/Makefile35
-rw-r--r--games/linux-enemyterritory-jaymod/pkg-plist4
2 files changed, 14 insertions, 25 deletions
diff --git a/games/linux-enemyterritory-jaymod/Makefile b/games/linux-enemyterritory-jaymod/Makefile
index 059f5fa8896d..185f5979149d 100644
--- a/games/linux-enemyterritory-jaymod/Makefile
+++ b/games/linux-enemyterritory-jaymod/Makefile
@@ -24,12 +24,9 @@ DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
CLIENT_PK3= ${PORTNAME}-${PORTVERSION}.pk3
PLIST_SUB= CLIENT_PK3="${CLIENT_PK3}"
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OMNIBOT_RUN_DEPENDS= et-omni-bot:${PORTSDIR}/games/linux-enemyterritory-omni-bot
-.if ${PORT_OPTIONS:MOMNIBOT}
-RUN_DEPENDS+= et-omni-bot:${PORTSDIR}/games/linux-enemyterritory-omni-bot
-.endif
+.include <bsd.port.options.mk>
do-build:
.for f in et etded
@@ -40,26 +37,18 @@ do-build:
do-install:
.for f in et etded
- ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${CLIENT_PK3} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${STAGEDIR}${DATADIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${CLIENT_PK3} ${STAGEDIR}${DATADIR}
.for f in jaymod.cfg server.cfg
- ${CP} -p ${WRKSRC}/${f} ${DATADIR}/${f}.sample
+ @${CP} -p ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}/${f}.sample
+.endfor
+ @${CP} -r ${WRKSRC}/linux ${WRKSRC}/mapscripts ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in README.txt doc/jaymod.pdf
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${f} ${STAGEDIR}${DOCSDIR}
.endfor
- ${CP} -r ${WRKSRC}/linux ${WRKSRC}/mapscripts ${DATADIR}
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README.txt doc/jaymod.pdf ${DOCSDIR}
-.endif
-
-post-install:
- @if [ ! -f ${DATADIR}/jaymod.cfg ]; then \
- ${CP} -p ${DATADIR}/jaymod.cfg.sample ${DATADIR}/jaymod.cfg ; \
- fi
- @if [ ! -f ${DATADIR}/server.cfg ]; then \
- ${CP} -p ${DATADIR}/server.cfg.sample ${DATADIR}/server.cfg ; \
- fi
.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-jaymod/pkg-plist b/games/linux-enemyterritory-jaymod/pkg-plist
index c23a95f7fac7..6ebca1d10202 100644
--- a/games/linux-enemyterritory-jaymod/pkg-plist
+++ b/games/linux-enemyterritory-jaymod/pkg-plist
@@ -2,7 +2,7 @@ bin/et-jaymod
bin/etded-jaymod
@unexec if cmp %D/lib/enemyterritory/jaymod/jaymod.cfg %D/lib/enemyterritory/jaymod/jaymod.cfg.sample; then rm -f %D/lib/enemyterritory/jaymod/jaymod.cfg; fi
%%DATADIR%%/jaymod.cfg.sample
-@exec if [ ! -f %D/lib/enemyterritory/jaymod/jaymod.cfg ] ; then cp -p %D/lib/enemyterritory/jaymod/jaymod.cfg.sample %D/lib/enemyterritory/jaymod/jaymod.cfg; fi
+@exec if [ ! -f %D/lib/enemyterritory/jaymod/jaymod.cfg ] ; then cp -p %D/%F %B/jaymod.cfg; fi
%%DATADIR%%/%%CLIENT_PK3%%
%%DATADIR%%/linux/convert_shrub
%%DATADIR%%/linux/serverctl
@@ -18,7 +18,7 @@ bin/etded-jaymod
%%DATADIR%%/qagame.mp.i386.so
@unexec if cmp %D/lib/enemyterritory/jaymod/server.cfg %D/lib/enemyterritory/jaymod/server.cfg.sample; then rm -f %D/lib/enemyterritory/jaymod/server.cfg; fi
%%DATADIR%%/server.cfg.sample
-@exec if [ ! -f %D/lib/enemyterritory/jaymod/server.cfg ] ; then cp -p %D/lib/enemyterritory/jaymod/server.cfg.sample %D/lib/enemyterritory/jaymod/server.cfg; fi
+@exec if [ ! -f %D/lib/enemyterritory/jaymod/server.cfg ] ; then cp -p %D/%F %B/server.cfg; fi
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/jaymod.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%