aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-07-20 01:54:49 +0800
committerkrion <krion@FreeBSD.org>2004-07-20 01:54:49 +0800
commit312d5962895fa9bb1343ece27300b54db312a361 (patch)
treed370ab964d420e71e09e4b7680922c94a1b6053b /games
parent0ca5794ef9ecedda639efdfad1e1e6da0fbe3d0c (diff)
downloadfreebsd-ports-gnome-312d5962895fa9bb1343ece27300b54db312a361.tar.gz
freebsd-ports-gnome-312d5962895fa9bb1343ece27300b54db312a361.tar.zst
freebsd-ports-gnome-312d5962895fa9bb1343ece27300b54db312a361.zip
Update to version 0.0.9
PR: ports/69296 Submitted by: Ports Fury
Diffstat (limited to 'games')
-rw-r--r--games/libggz/Makefile18
-rw-r--r--games/libggz/distinfo4
-rw-r--r--games/libggz/files/patch-ltmain.sh15
3 files changed, 14 insertions, 23 deletions
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
index 130aba6552f8..043cf1b1250f 100644
--- a/games/libggz/Makefile
+++ b/games/libggz/Makefile
@@ -7,22 +7,20 @@
#
PORTNAME= libggz
-PORTVERSION= 0.0.8
-PORTREVISION= 1
+PORTVERSION= 0.0.9
CATEGORIES= games
-MASTER_SITES= http://ggzgamingzone.org/pub/ggz/%SUBDIR%/
+MASTER_SITES= http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The GGZ Gaming Zone - Base Library
-#LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
USE_GNOME= gnomehack gnometarget
-USE_OPENSSL= yes
+USE_LIBTOOL_VER= 15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-debug --with-tls
+CONFIGURE_ARGS= --disable-debug
INSTALLS_SHLIB= yes
MAN3= ggz.h.3
@@ -30,4 +28,12 @@ MAN3= ggz.h.3
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.12:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --with-tls=GnuTLS
+.else
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-tls=OpenSSL
+.endif
+
.include <bsd.port.mk>
diff --git a/games/libggz/distinfo b/games/libggz/distinfo
index 9ab11237a366..b47fc049260c 100644
--- a/games/libggz/distinfo
+++ b/games/libggz/distinfo
@@ -1,2 +1,2 @@
-MD5 (libggz-0.0.8.tar.gz) = c3fcf431c6c53a099352bb9769c67862
-SIZE (libggz-0.0.8.tar.gz) = 410286
+MD5 (libggz-0.0.9.tar.gz) = 1d905aa0564e1727f394e96d115b89e4
+SIZE (libggz-0.0.9.tar.gz) = 434410
diff --git a/games/libggz/files/patch-ltmain.sh b/games/libggz/files/patch-ltmain.sh
deleted file mode 100644
index 7436b6c83012..000000000000
--- a/games/libggz/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Wed Oct 8 22:11:50 2003
-+++ ltmain.sh Wed Oct 8 22:12:05 2003
-@@ -4325,10 +4325,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"