aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
committeranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
commit3c76fd7fad82c9f137407348028fde08754f2866 (patch)
tree9818557f7ca7be09aba8db3b18a8262f50280603 /games
parenta861bc861bc7251a2f2399f845d673f742a19ee1 (diff)
downloadfreebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.gz
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.zst
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.zip
- Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,
and make XFREE86_VERSION map to it. XFREE86_VERSION is now deprecated. - Make xorg the default X_WINDOW_SYSTEM on -current. - Add several new X_*_PORT variables which point to various pieces of X11 based on the setting of X_WINDOW_SYSTEM, and make ports use them. - Add information to CHANGES about how to handle the transition. PR: ports/68763 Approved by: portmgr (marcus) Approved by: re (scottl)
Diffstat (limited to 'games')
-rw-r--r--games/atitd/Makefile4
-rw-r--r--games/linux-q3ademo/Makefile2
-rw-r--r--games/linux-quake3-demo/Makefile2
-rw-r--r--games/qix/Makefile11
-rw-r--r--games/xarchon/Makefile10
-rw-r--r--games/xjewel/Makefile12
6 files changed, 14 insertions, 27 deletions
diff --git a/games/atitd/Makefile b/games/atitd/Makefile
index 3b58e53b3296..09acd773b0dc 100644
--- a/games/atitd/Makefile
+++ b/games/atitd/Makefile
@@ -16,11 +16,11 @@ EXTRACT_ONLY=
MAINTAINER= mdodd@freebsd.org
COMMENT= The Linux "A Tale in the Desert" (ATITD) client
-RUN_DEPENDS= ${X11BASE}/bin/xhost:${PORTSDIR}/x11/XFree86-4-clients
+RUN_DEPENDS= ${X11BASE}/bin/xhost:${X_CLIENTS_PORT}
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} == 4
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.else
RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
diff --git a/games/linux-q3ademo/Makefile b/games/linux-q3ademo/Makefile
index 8814a1ff8d0e..fe6974906428 100644
--- a/games/linux-q3ademo/Makefile
+++ b/games/linux-q3ademo/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} == 4
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
RUN_DEPENDS += /compat/linux/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.else
RUN_DEPENDS += /compat/linux/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
diff --git a/games/linux-quake3-demo/Makefile b/games/linux-quake3-demo/Makefile
index 8814a1ff8d0e..fe6974906428 100644
--- a/games/linux-quake3-demo/Makefile
+++ b/games/linux-quake3-demo/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
.include <bsd.port.pre.mk>
-.if ${XFREE86_VERSION} == 4
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
RUN_DEPENDS += /compat/linux/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.else
RUN_DEPENDS += /compat/linux/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
diff --git a/games/qix/Makefile b/games/qix/Makefile
index 4436602c1051..19139c016948 100644
--- a/games/qix/Makefile
+++ b/games/qix/Makefile
@@ -14,18 +14,15 @@ MASTER_SITE_SUBDIR= jmz
MAINTAINER= jmz@FreeBSD.org
COMMENT= The classic arcade game
+BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
+RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
+
.if defined(WITHOUT_X11)
MAKE_ARGS= NO_X11=yes
-.include <bsd.port.pre.mk>
.else
USE_X_PREFIX= yes
-.include <bsd.port.pre.mk>
PLIST= pkg-plist.x11
.endif
-.if ${XFREE86_VERSION} == 4
-BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
-.endif
.if !defined(DISPLAY) || ${DISPLAY} == ""
IGNORE= Requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X.
@@ -41,4 +38,4 @@ do-configure:
${SED} -e s:/usr/local:${PREFIX}: -e s:/usr/X11R6:${PREFIX}: \
< ${WRKSRC}/Makefile~ > ${WRKSRC}/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xarchon/Makefile b/games/xarchon/Makefile
index c8dc22921037..e3ae05dffa6c 100644
--- a/games/xarchon/Makefile
+++ b/games/xarchon/Makefile
@@ -19,6 +19,7 @@ COMMENT= A chess-like strategy game with battle options
USE_XLIB= yes
USE_GNOME= esound gtk12
USE_GMAKE= yes
+USE_XPM= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
@@ -27,12 +28,5 @@ MAN6= xarchon.6
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
-.include <bsd.port.pre.mk>
-
-.if ${XFREE86_VERSION} == 3
-LIB_DEPENDS+= Xpm.4:${PORTSDIR}/graphics/xpm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xjewel/Makefile b/games/xjewel/Makefile
index 02d345718fa1..a86d7aa9d65a 100644
--- a/games/xjewel/Makefile
+++ b/games/xjewel/Makefile
@@ -15,14 +15,10 @@ EXTRACT_SUFX= .tar.z
MAINTAINER= jmz@FreeBSD.org
COMMENT= X11 dropping jewels game
-USE_IMAKE= yes
-
-.include <bsd.port.pre.mk>
+BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
+RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
-.if ${XFREE86_VERSION} == 4
-BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
-.endif
+USE_IMAKE= yes
MAN6= xjewel.6
@@ -37,4 +33,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/bitmaps/seven_seg.pcf.gz ${PREFIX}/${FONTSDIR}
@(cd ${PREFIX}/${FONTSDIR} ; mkfontdir)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>