aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-10-29 12:40:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-10-29 12:40:29 +0800
commit40b94636ee9dc4c6c31fc61179feadfaadec1dd7 (patch)
tree8574f3563a4fe9551144453644c806ddd752b945 /games
parenta6badf0e19e9941a3e6d800843ec44b83ce6fdd3 (diff)
downloadfreebsd-ports-gnome-40b94636ee9dc4c6c31fc61179feadfaadec1dd7.tar.gz
freebsd-ports-gnome-40b94636ee9dc4c6c31fc61179feadfaadec1dd7.tar.zst
freebsd-ports-gnome-40b94636ee9dc4c6c31fc61179feadfaadec1dd7.zip
Pioneer Space Simulator.
Pioneer is a space adventure game set in the Milky Way galaxy at the turn of the 31st century. The game is open-ended, and you are free to explore the millions of star systems in the game. You can land on planets, slingshot past gas giants, and burn yourself to a crisp flying between binary star systems. You can try your hand at piracy, make your fortune trading between systems, or do missions for the various factions fighting for power, freedom or self-determination. WWW: http://pioneerspacesim.net WWW: http://github.com/pioneerspacesim/pioneer PR: 193213 Submitted by: lightside@gmx.com
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/pioneer/Makefile105
-rw-r--r--games/pioneer/distinfo2
-rw-r--r--games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp10
-rw-r--r--games/pioneer/files/patch-src_GameConfig.h12
-rw-r--r--games/pioneer/files/patch-src_posix_OSPosix.cpp11
-rw-r--r--games/pioneer/files/pkg-message.in7
-rw-r--r--games/pioneer/pkg-descr13
8 files changed, 161 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 2d3208f61dad..1e3b460d641a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -715,6 +715,7 @@
SUBDIR += pinball
SUBDIR += pingus
SUBDIR += pink-pony
+ SUBDIR += pioneer
SUBDIR += pioneers
SUBDIR += pipenightdreams
SUBDIR += pipepanic
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
new file mode 100644
index 000000000000..e72a84cc5fa9
--- /dev/null
+++ b/games/pioneer/Makefile
@@ -0,0 +1,105 @@
+# Created by: lightside <lightside@gmx.com>
+# $FreeBSD$
+
+PORTNAME= pioneer
+PORTVERSION= 0.0.${GH_TAGNAME}
+CATEGORIES= games
+MASTER_SITES= http://github.com/${GH_ACCOUNT}/${GH_PROJECT}/archive/${GH_TAGNAME}.tar.gz?dummy=/
+
+MAINTAINER= lightside@gmx.com
+COMMENT= Space adventure game set in the Milky Way galaxy
+
+LICENSE= APACHE20 GPLv3 MIT ZLIB CCBYSAv3 DejaVu GLEW SIL
+LICENSE_COMB= multi
+LICENSE_NAME_CCBYSAv3= Creative Commons Attribution-ShareAlike 3.0 Unported license
+LICENSE_NAME_DejaVu= Bitstream Vera and Arev fonts license
+LICENSE_NAME_GLEW= The OpenGL Extension Wrangler Library license
+LICENSE_NAME_SIL= SIL open font license version 1.1
+LICENSE_FILE_APACHE20= ${WRKSRC}/licenses/Apache-2.0.txt
+LICENSE_FILE_CCBYSAv3= ${WRKSRC}/licenses/CC-BY-SA-3.0.txt
+LICENSE_FILE_DejaVu= ${WRKSRC}/licenses/DejaVu-license.txt
+LICENSE_FILE_GLEW= ${WRKSRC}/licenses/GLEW.txt
+LICENSE_FILE_GPLv3= ${WRKSRC}/licenses/GPL-3.txt
+LICENSE_FILE_SIL= ${WRKSRC}/licenses/SIL-1.1.txt
+LICENSE_PERMS_CCBYSAv3= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_GLEW= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_SIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= ${LOCALBASE}/include/GL/glu.h:${PORTSDIR}/graphics/libGLU
+LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libassimp.so:${PORTSDIR}/multimedia/assimp
+
+GH_ACCOUNT= pioneerspacesim
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= 20141021
+
+WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME}
+
+USES= gmake pkgconfig
+USE_AUTOTOOLS= aclocal autoconf automake
+AUTOMAKE_ARGS= --add-missing
+USE_GL= gl
+USE_SDL= image2 sdl2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= PIONEER_DATA_DIR="${DATADIR}/data"
+CONFIGURE_ARGS= --with-version=${GH_TAGNAME}
+EXTRACT_AFTER_ARGS= --exclude .gitignore
+
+PORTDATA= data
+PORTDOCS= AUTHORS.txt Changelog.txt Modelviewer.txt Quickstart.txt README.txt
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+DESKTOP_ENTRIES="Pioneer" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" "${PORTNAME}" \
+ "Game;Simulation;" false
+
+SUB_FILES= pkg-message
+SUB_LIST= QUICKSTART_PATH="${QUICKSTART_PATH}"
+
+OPTIONS_DEFINE= DOCS MODELCOMPILER
+OPTIONS_DEFAULT= MODELCOMPILER
+MODELCOMPILER_DESC= Build/install modelcompiler tool
+MODELCOMPILER_PLIST_FILES= bin/${PORTNAME}-modelcompiler
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 1000054
+USE_GCC= yes
+.else
+USES+= compiler:c++11-lang
+CPPFLAGS+= -I${LOCALBASE}/include
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+QUICKSTART_PATH= ${DOCSDIR}
+.else
+QUICKSTART_PATH= \
+ https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${GH_TAGNAME}
+.endif
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e '/^OPTIMISE=/d' \
+ ${WRKSRC}/configure.ac
+ ${REINPLACE_CMD} -e 's/modelviewer/${PORTNAME} -modelviewer/' \
+ ${WRKSRC}/Modelviewer.txt
+.if !${PORT_OPTIONS:MMODELCOMPILER}
+ ${REINPLACE_CMD} -e 's/pioneer modelcompiler/pioneer/' \
+ ${WRKSRC}/src/Makefile.am
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MMODELCOMPILER}
+ @${MV} ${STAGEDIR}${PREFIX}/bin/modelcompiler ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-modelcompiler
+.endif
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/application-icon/pngs/pioneer-256x256.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.include <bsd.port.mk>
diff --git a/games/pioneer/distinfo b/games/pioneer/distinfo
new file mode 100644
index 000000000000..5eee090cf558
--- /dev/null
+++ b/games/pioneer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pioneer-0.0.20141021.tar.gz) = 55d98c6781fefb9f0f3ffe86966f31c40c455b7e66c2bae6977f215e9a7defbe
+SIZE (pioneer-0.0.20141021.tar.gz) = 174100164
diff --git a/games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp b/games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp
new file mode 100644
index 000000000000..4c8a2847a567
--- /dev/null
+++ b/games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp
@@ -0,0 +1,10 @@
+--- contrib/PicoDDS/PicoDDS.cpp.orig 2014-08-28 18:02:26.000000000 +0400
++++ contrib/PicoDDS/PicoDDS.cpp 2014-09-01 03:31:59.000000000 +0400
+@@ -48,6 +48,7 @@
+ */
+
+ #include "PicoDDS.h"
++#include <stdlib.h>
+ #include <cstdio>
+ #include <cstring>
+ #include <cassert>
diff --git a/games/pioneer/files/patch-src_GameConfig.h b/games/pioneer/files/patch-src_GameConfig.h
new file mode 100644
index 000000000000..cd7854029c9d
--- /dev/null
+++ b/games/pioneer/files/patch-src_GameConfig.h
@@ -0,0 +1,12 @@
+--- src/GameConfig.h.orig 2014-08-28 18:02:26.000000000 +0400
++++ src/GameConfig.h 2014-09-01 03:51:12.000000000 +0400
+@@ -8,7 +8,8 @@
+
+ class GameConfig : public IniConfig {
+ public:
+- GameConfig(const std::map<std::string,std::string> &override_ = std::map<std::string,std::string>());
++ typedef std::map<std::string, std::string> map_string;
++ GameConfig(const map_string &override_ = map_string());
+
+ void Load();
+ bool Save();
diff --git a/games/pioneer/files/patch-src_posix_OSPosix.cpp b/games/pioneer/files/patch-src_posix_OSPosix.cpp
new file mode 100644
index 000000000000..c91799784f57
--- /dev/null
+++ b/games/pioneer/files/patch-src_posix_OSPosix.cpp
@@ -0,0 +1,11 @@
+--- src/posix/OSPosix.cpp.orig 2014-08-28 18:02:26.000000000 +0400
++++ src/posix/OSPosix.cpp 2014-08-31 21:03:27.000000000 +0400
+@@ -111,7 +111,7 @@
+ }
+
+ char infoString[2048];
+-#if defined(__APPLE__)
++#if defined(__APPLE__) || defined(__FREEBSD__)
+ snprintf(infoString, 2048, "System Name: %s\nHost Name: %s\nRelease(Kernel) Version: %s\nKernel Build Timestamp: %s\nMachine Arch: %s\n",
+ uts.sysname, uts.nodename, uts.release, uts.version, uts.machine);
+ #else
diff --git a/games/pioneer/files/pkg-message.in b/games/pioneer/files/pkg-message.in
new file mode 100644
index 000000000000..442e3460ae39
--- /dev/null
+++ b/games/pioneer/files/pkg-message.in
@@ -0,0 +1,7 @@
+Pioneer has been installed.
+
+Pioneer is alpha-quality software. Saved games are not guaranteed to load in
+different versions of Pioneer. The universe might not be the same in the next
+version of Pioneer. Anything can change. The game is not finished.
+
+Take a look at %%QUICKSTART_PATH%%/Quickstart.txt for more info.
diff --git a/games/pioneer/pkg-descr b/games/pioneer/pkg-descr
new file mode 100644
index 000000000000..40b1737858dd
--- /dev/null
+++ b/games/pioneer/pkg-descr
@@ -0,0 +1,13 @@
+Pioneer Space Simulator.
+
+Pioneer is a space adventure game set in the Milky Way galaxy at the turn of
+the 31st century.
+
+The game is open-ended, and you are free to explore the millions of star
+systems in the game. You can land on planets, slingshot past gas giants, and
+burn yourself to a crisp flying between binary star systems. You can try your
+hand at piracy, make your fortune trading between systems, or do missions for
+the various factions fighting for power, freedom or self-determination.
+
+WWW: http://pioneerspacesim.net
+WWW: http://github.com/pioneerspacesim/pioneer