aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-29 20:42:04 +0800
committerbapt <bapt@FreeBSD.org>2012-06-29 20:42:04 +0800
commit42034a997e9bbb7dd2e66f6719377aebbe4c7abd (patch)
tree44dc0e86776cb3ba9a994d27c2ee2b7a934bcdd2 /games
parentff094d05cd8d446e528963491389242e738416e1 (diff)
downloadfreebsd-ports-gnome-42034a997e9bbb7dd2e66f6719377aebbe4c7abd.tar.gz
freebsd-ports-gnome-42034a997e9bbb7dd2e66f6719377aebbe4c7abd.tar.zst
freebsd-ports-gnome-42034a997e9bbb7dd2e66f6719377aebbe4c7abd.zip
Convert to new option framework
Diffstat (limited to 'games')
-rw-r--r--games/hinversi/Makefile14
-rw-r--r--games/znibbles/Makefile15
2 files changed, 15 insertions, 14 deletions
diff --git a/games/hinversi/Makefile b/games/hinversi/Makefile
index 3cfc810c349c..51f05acbf7ee 100644
--- a/games/hinversi/Makefile
+++ b/games/hinversi/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= SF/${PORTNAME}/latest
MAINTAINER= ports@FreeBSD.org
COMMENT= Reversi/Othello clone
-OPTIONS= NLS "Native Language Support via gettext utilities" on
+OPTIONS_DEFINE= NLS
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
@@ -24,15 +24,15 @@ USE_LDCONFIG= yes
MAN1= hinversi-cli.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE}
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -42,4 +42,4 @@ post-patch:
/_la_LIBADD/s|=$$|= $$(LTLIBINTL)|' ${WRKSRC}/${file}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/znibbles/Makefile b/games/znibbles/Makefile
index a4fff68eaa46..5beea89c4e2e 100644
--- a/games/znibbles/Makefile
+++ b/games/znibbles/Makefile
@@ -18,7 +18,8 @@ COMMENT= A multi-player networked nibbles game
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-OPTIONS= GTK "Build GTK+ client" on
+OPTIONS_DEFINE= GTK1
+OPTIONS_DEFAULT= GTK1
USE_MOTIF= yes
WANT_GNOME= yes
@@ -28,14 +29,14 @@ MAKE_JOBS_SAFE= yes
MAN6= nibbles.6 znibbles.6 znibblesX.6
PLIST_FILES= bin/nibbles bin/znibbles bin/znibblesX
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GTK)
-CONFIGURE_ARGS+=--disable-gtk
-.else
+.if ${PORT_OPTIONS:MGTK1}
USE_GNOME+= gtk12
MAN6+= gznibbles.6
PLIST_FILES+= bin/gznibbles
+.else
+CONFIGURE_ARGS+=--disable-gtk
.endif
post-extract:
@@ -58,8 +59,8 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/nibbles.6 ${MAN6PREFIX}/man/man6
${INSTALL_MAN} ${WRKSRC}/doc/znibbles.6 ${MAN6PREFIX}/man/man6
${INSTALL_MAN} ${WRKSRC}/doc/znibblesX.6 ${MAN6PREFIX}/man/man6
-.if !defined(WITHOUT_GTK)
+.if ${PORT_OPTIONS:MGTK1}
${INSTALL_MAN} ${WRKSRC}/doc/gznibbles.6 ${MAN6PREFIX}/man/man6
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>