aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-07-03 00:45:05 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-07-03 00:45:05 +0800
commit43c0793b722a1caa5ff96036e55d64d7f2ae4f2e (patch)
tree5d2392499c4faef4a79b76e9b8c872d5732bcd40 /games
parentdb07ac747b2ec50a2f967009ef8f7df1649ec3d0 (diff)
downloadfreebsd-ports-gnome-43c0793b722a1caa5ff96036e55d64d7f2ae4f2e.tar.gz
freebsd-ports-gnome-43c0793b722a1caa5ff96036e55d64d7f2ae4f2e.tar.zst
freebsd-ports-gnome-43c0793b722a1caa5ff96036e55d64d7f2ae4f2e.zip
- Add LICENSE
- Switch to USES=localbase - Fix build with clang 6 - Switch to options helpers - Cosmetic fixes
Diffstat (limited to 'games')
-rw-r--r--games/blinkensisters/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/games/blinkensisters/Makefile b/games/blinkensisters/Makefile
index dca5a46f891f..963b6f6cb9ef 100644
--- a/games/blinkensisters/Makefile
+++ b/games/blinkensisters/Makefile
@@ -10,14 +10,16 @@ MASTER_SITES= SF/${PORTNAME}/Blinkensisters%20-%20Lost%20Pixels/LostPixels%20${P
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Parallax-style 2D scrolling platform game
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/DOC/LICENSE
+
BROKEN_sparc64= does not compile on sparc64
+USES= cmake compiler:c++11-lang localbase perl5 # actually, old gcc fails in theora.h
USE_SDL= sdl image ttf
USE_PERL5= build
-USES= cmake perl5 compiler:c++11-lang # actually, old gcc fails in theora.h
-CFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -Wno-c++11-narrowing
WRKSRC= ${WRKDIR}/blinkensisters/lostpixels/game/software
ADDONS_WRKSRC= ${WRKDIR}/blinkensisters/lostpixels/game/addons
@@ -49,18 +51,13 @@ SDL_NET_PLIST_FILES= bin/blpmatrix \
THEORA_CMAKE_ON= -DUSE_THEORA:BOOL=ON
THEORA_LIB_DEPENDS= libtheora.so:multimedia/libtheora
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MADDONS}
-DISTNAME= LostPixels-${PORTVERSION}-source-with-addons
-PKGNAMESUFFIX= -with-addons
-.else
-DISTNAME= LostPixels-${PORTVERSION}-source
-.endif
+ADDONS_VARS= DISTNAME=LostPixels-${PORTVERSION}-source-with-addons \
+ PKGNAMESUFFIX=-with-addons
+ADDONS_VARS_OFF= DISTNAME=LostPixels-${PORTVERSION}-source
post-patch:
- @${REINPLACE_CMD} -e 's|share/blinkensisters|${DATADIR:S,${PREFIX}/,,}|; \
- s|share/doc/blinkensisters|${DOCSDIR:S,${PREFIX}/,,}|' \
+ @${REINPLACE_CMD} -e 's|share/blinkensisters|${DATADIR_REL}|; \
+ s|share/doc/blinkensisters|${DOCSDIR_REL}|' \
${WRKSRC}/CMakeLists.txt
post-patch-ADDONS-on:
@@ -71,7 +68,7 @@ post-build-ADDONS-on:
cd ${ADDONS_WRKSRC} && ${MAKE}
post-install-ADDONS-on:
- ${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${ADDONS_WRKSRC}/for_upload/*.bmf ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>