aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-27 16:45:15 +0800
committermiwi <miwi@FreeBSD.org>2008-04-27 16:45:15 +0800
commit49e3941a233849f67266bac6746f546a31035919 (patch)
tree10e592a12b5b4fe604a0d6eba2b20d5bb8ee05e1 /games
parent3e7053999c7fe9fd7f145a6e6fc48010ec1bce3e (diff)
downloadfreebsd-ports-gnome-49e3941a233849f67266bac6746f546a31035919.tar.gz
freebsd-ports-gnome-49e3941a233849f67266bac6746f546a31035919.tar.zst
freebsd-ports-gnome-49e3941a233849f67266bac6746f546a31035919.zip
Passage is meant to be a memento mori game. It presents an entire
life, from young adulthood through old age and death, in the span of five minutes. Of course, it's a game, not a painting or a film, so the choices that you make as the player are crucial. There's no "right" way to play Passage, just as there's no right way to interpret it. WWW: http://hcsoftware.sourceforge.net/passage PR: ports/123031 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/passage/Makefile40
-rw-r--r--games/passage/distinfo3
-rw-r--r--games/passage/files/patch-Makefile.all13
-rw-r--r--games/passage/pkg-descr8
-rw-r--r--games/passage/pkg-plist19
6 files changed, 84 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 29c4b5154eb1..042e97c3ad4b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -560,6 +560,7 @@
SUBDIR += p5-Games-Tournament-RoundRobin
SUBDIR += pachi
SUBDIR += palomino
+ SUBDIR += passage
SUBDIR += pathological
SUBDIR += pcgen
SUBDIR += pear-Games_Chess
diff --git a/games/passage/Makefile b/games/passage/Makefile
new file mode 100644
index 000000000000..e4a88cb7ab2a
--- /dev/null
+++ b/games/passage/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: passage
+# Date created: 23 Apr 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= passage
+PORTVERSION= 3
+CATEGORIES= games
+MASTER_SITES= SF/hcsoftware
+DISTNAME= Passage_v${PORTVERSION}_UnixSource
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= An experimental video game by Jason Rohrer
+
+USE_SDL= sdl
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/gamma256/gameSource
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.GnuLinux
+ @${REINPLACE_CMD} -e 's|"graphics"|"${DATADIR}/graphics"|' \
+ ${WRKSRC}/common.cpp
+ @${REINPLACE_CMD} -e 's|"music"|"${DATADIR}/music"|' \
+ ${WRKSRC}/musicPlayer.cpp
+ @${REINPLACE_CMD} -e 's|"settings"|"${DATADIR}/settings"|' \
+ ${WRKDIR}/${DISTNAME}/minorGems/util/SettingsManager.cpp
+
+do-configure:
+ cd ${WRKSRC} && ${CAT} Makefile.GnuLinux Makefile.all > Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Passage ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for d in graphics music settings
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/passage/distinfo b/games/passage/distinfo
new file mode 100644
index 000000000000..0fc4d29b724b
--- /dev/null
+++ b/games/passage/distinfo
@@ -0,0 +1,3 @@
+MD5 (Passage_v3_UnixSource.tar.gz) = 183c9dac9e10dbad8d53a9f60972cd8d
+SHA256 (Passage_v3_UnixSource.tar.gz) = 67bf36415a8cde717184abb075112d3ad4495dcd9b032653bc3c7272b9f4a182
+SIZE (Passage_v3_UnixSource.tar.gz) = 424772
diff --git a/games/passage/files/patch-Makefile.all b/games/passage/files/patch-Makefile.all
new file mode 100644
index 000000000000..109f9c150d5c
--- /dev/null
+++ b/games/passage/files/patch-Makefile.all
@@ -0,0 +1,13 @@
+--- Makefile.all.orig 2007-12-11 21:44:49.000000000 +0300
++++ Makefile.all 2008-04-23 20:47:45.000000000 +0400
+@@ -1,8 +1,8 @@
+
+ ROOT_PATH = ../..
+
+-COMPILE = g++ ${PLATFORM_COMPILE_FLAGS} -Wall -g -I${ROOT_PATH} -c
+-LINK = g++ -I${ROOT_PATH}
++COMPILE = ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --cflags` -Wall -I${ROOT_PATH} -c
++LINK = ${CXX} `${SDL_CONFIG} --libs`
+
+
+
diff --git a/games/passage/pkg-descr b/games/passage/pkg-descr
new file mode 100644
index 000000000000..a6d524de9add
--- /dev/null
+++ b/games/passage/pkg-descr
@@ -0,0 +1,8 @@
+Passage is meant to be a memento mori game. It presents an entire
+life, from young adulthood through old age and death, in the span
+of five minutes. Of course, it's a game, not a painting or a film,
+so the choices that you make as the player are crucial. There's no
+"right" way to play Passage, just as there's no right way to interpret
+it.
+
+WWW: http://hcsoftware.sourceforge.net/passage
diff --git a/games/passage/pkg-plist b/games/passage/pkg-plist
new file mode 100644
index 000000000000..090d9954dbd6
--- /dev/null
+++ b/games/passage/pkg-plist
@@ -0,0 +1,19 @@
+bin/Passage
+%%DATADIR%%/graphics/characterSprite.tga
+%%DATADIR%%/graphics/characterSpriteSad.tga
+%%DATADIR%%/graphics/chest.tga
+%%DATADIR%%/graphics/chestDust.tga
+%%DATADIR%%/graphics/chestPrize.tga
+%%DATADIR%%/graphics/heart.tga
+%%DATADIR%%/graphics/numerals.tga
+%%DATADIR%%/graphics/spouseSprite.tga
+%%DATADIR%%/graphics/tileSet.tga
+%%DATADIR%%/graphics/title.tga
+%%DATADIR%%/music/music.tga
+%%DATADIR%%/settings/fullscreen.ini
+%%DATADIR%%/settings/screenHeight.ini
+%%DATADIR%%/settings/screenWidth.ini
+@dirrm %%DATADIR%%/settings
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%