aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-02-21 18:47:28 +0800
committerjylefort <jylefort@FreeBSD.org>2006-02-21 18:47:28 +0800
commit4d7c39dbd15b42a5015b1d15fb26b94502fe7a18 (patch)
tree3900b5bdf960549875ca378c79baaba6c3d731ca /games
parentdd9bb3bd5454f935fa2ca7fdebb81407bba3d58c (diff)
downloadfreebsd-ports-gnome-4d7c39dbd15b42a5015b1d15fb26b94502fe7a18.tar.gz
freebsd-ports-gnome-4d7c39dbd15b42a5015b1d15fb26b94502fe7a18.tar.zst
freebsd-ports-gnome-4d7c39dbd15b42a5015b1d15fb26b94502fe7a18.zip
Add timeseal.
timeseal is a program that has been developed to improve chess on internet. Netlag often causes players to lose valuable seconds or even minutes on their chess clocks. Transmission time is counted against you, unless the chess server can tell exactly when information is transmitted. The timeseal program acts as a relay station and keeps track of transmission times. What timeseal does is record your thinking time, so that transmission time is not counted against you. Timeseal will not prevent netlag but it makes the games fairer when lag occurs. WWW: http://www.freechess.org/WWWhelp/timeseal.html
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/timeseal/Makefile37
-rw-r--r--games/timeseal/distinfo3
-rw-r--r--games/timeseal/pkg-descr13
-rw-r--r--games/timeseal/pkg-message.aout13
5 files changed, 67 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 2e39667104b3..b7a4cb8d4cff 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -584,6 +584,7 @@
SUBDIR += thevalley
SUBDIR += thudboard
SUBDIR += tileworld
+ SUBDIR += timeseal
SUBDIR += tinymux
SUBDIR += tkmoo
SUBDIR += tksol
diff --git a/games/timeseal/Makefile b/games/timeseal/Makefile
new file mode 100644
index 000000000000..a110843c6b7d
--- /dev/null
+++ b/games/timeseal/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: timeseal
+# Date created: 21 Feb 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= timeseal
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://ftp3.ru.freebsd.org/.3/games/freechess/timeseal/ \
+ ftp://ftp3.ru.freebsd.org/.3/games/freechess/timeseal/
+DISTFILES= timeseal.BSD386-1.0-i386
+EXTRACT_ONLY=
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= Account for network lag in FICS chess games
+
+NO_BUILD= yes
+STRIP= # strip(1) does not support a.out binaries
+PLIST_FILES= bin/timeseal
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+PKGMESSAGE= pkg-message.aout
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${_DISTDIR}/${_DISTFILES} ${PREFIX}/bin/timeseal
+
+.if defined(PKGMESSAGE)
+post-install:
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/timeseal/distinfo b/games/timeseal/distinfo
new file mode 100644
index 000000000000..370c01cd4590
--- /dev/null
+++ b/games/timeseal/distinfo
@@ -0,0 +1,3 @@
+MD5 (timeseal.BSD386-1.0-i386) = 70e73137b5c79512ebfc6eb59fcad313
+SHA256 (timeseal.BSD386-1.0-i386) = 488ce5a3d0398f3cb3cbb4f625d541507c9ffd8688defe708ace402e090ae2d0
+SIZE (timeseal.BSD386-1.0-i386) = 64289
diff --git a/games/timeseal/pkg-descr b/games/timeseal/pkg-descr
new file mode 100644
index 000000000000..87025d964918
--- /dev/null
+++ b/games/timeseal/pkg-descr
@@ -0,0 +1,13 @@
+timeseal is a program that has been developed to improve chess on internet.
+Netlag often causes players to lose valuable seconds or even minutes on their
+chess clocks. Transmission time is counted against you, unless the chess
+server can tell exactly when information is transmitted. The timeseal program
+acts as a relay station and keeps track of transmission times. What timeseal
+does is record your thinking time, so that transmission time is not counted
+against you. Timeseal will not prevent netlag but it makes the games fairer
+when lag occurs.
+
+WWW: http://www.freechess.org/WWWhelp/timeseal.html
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org
diff --git a/games/timeseal/pkg-message.aout b/games/timeseal/pkg-message.aout
new file mode 100644
index 000000000000..4d6468a73da2
--- /dev/null
+++ b/games/timeseal/pkg-message.aout
@@ -0,0 +1,13 @@
+===============================================================================
+
+timeseal requires a.out support, which is provided by the a.out kernel module.
+
+To load the kernel module immediately, type the following command:
+
+ kldload aout
+
+To load the kernel module at boot, add the following line to /boot/loader.conf:
+
+ aout_load="YES"
+
+===============================================================================