aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2018-02-05 00:34:17 +0800
committermartymac <martymac@FreeBSD.org>2018-02-05 00:34:17 +0800
commit50c3e1411362b405ec93175f43939b0e83ec9720 (patch)
tree1d529c77ae2377aab4415be820489c4389e2e8fd /games
parent268b9e0c56d197a6897a27a462848a50b625bde0 (diff)
downloadfreebsd-ports-gnome-50c3e1411362b405ec93175f43939b0e83ec9720.tar.gz
freebsd-ports-gnome-50c3e1411362b405ec93175f43939b0e83ec9720.tar.zst
freebsd-ports-gnome-50c3e1411362b405ec93175f43939b0e83ec9720.zip
Fix build with Clang 6 (C++14 by default)
Diffstat (limited to 'games')
-rw-r--r--games/afternoonstalker/Makefile1
-rw-r--r--games/burgerspace/Makefile1
-rw-r--r--games/cosmosmash/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/games/afternoonstalker/Makefile b/games/afternoonstalker/Makefile
index d614d56ec979..8878c6bb921c 100644
--- a/games/afternoonstalker/Makefile
+++ b/games/afternoonstalker/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libflatzebra-0.1.so:devel/flatzebra
USES= pkgconfig
+USE_CXXSTD= gnu++98
USE_SDL= mixer sdl
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/burgerspace/Makefile b/games/burgerspace/Makefile
index 2b253a08950e..617063b5dbbb 100644
--- a/games/burgerspace/Makefile
+++ b/games/burgerspace/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libflatzebra-0.1.so:devel/flatzebra
USES= pkgconfig
+USE_CXXSTD= gnu++98
USE_SDL= mixer sdl
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/cosmosmash/Makefile b/games/cosmosmash/Makefile
index 5bca43ba0d4f..55da1bcff08c 100644
--- a/games/cosmosmash/Makefile
+++ b/games/cosmosmash/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= libflatzebra-0.1.so:devel/flatzebra \
libaudiofile.so:audio/libaudiofile
USES= iconv pkgconfig desktop-file-utils
+USE_CXXSTD= gnu++98
USE_SDL= sdl image mixer
USE_XORG= x11 xau xdmcp
GNU_CONFIGURE= yes