aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-28 07:03:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-28 07:03:51 +0800
commit5c46cc50a7cf783c9bbc1d149130de3ee0d206df (patch)
tree7835e9d97a5204420c082915e14066492059c9e2 /games
parent5ff785fab1ab3d71f3e19a5a194d6b57d76aea46 (diff)
downloadfreebsd-ports-gnome-5c46cc50a7cf783c9bbc1d149130de3ee0d206df.tar.gz
freebsd-ports-gnome-5c46cc50a7cf783c9bbc1d149130de3ee0d206df.tar.zst
freebsd-ports-gnome-5c46cc50a7cf783c9bbc1d149130de3ee0d206df.zip
- Fix build
- Specify shlib version for xerces, to distinguish from xerces-c3
Diffstat (limited to 'games')
-rw-r--r--games/enigma/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 6387c3a3bc55..40d3907f39da 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -11,9 +11,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-64bit
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
-LIB_DEPENDS= libxerces-c.so:${PORTSDIR}/textproc/xerces-c2 \
+LIB_DEPENDS= libxerces-c.so.27:${PORTSDIR}/textproc/xerces-c2 \
libpng.so:${PORTSDIR}/graphics/png \
- libtoluaxx-${LUA_VER}.so:${PORTSDIR}/lang/tolua++
+ libtolua++-${LUA_VER}.so:${PORTSDIR}/lang/tolua++
BUILD_DEPENDS= ${LOCALBASE}/lib/libenet.a:${PORTSDIR}/net/enet
USES= gettext gmake lua:51
@@ -44,5 +44,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e '/Exec=/s,enigma,${PREFIX}/bin/enigma,g' \
${WRKSRC}/etc/enigma.desktop
+ @${REINPLACE_CMD} -e 's|-llua|&-${LUA_VER}|; s|-ltolua++|&-${LUA_VER}|' \
+ ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>