aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /games
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'games')
-rw-r--r--games/adgali/Makefile2
-rw-r--r--games/freecell-solver/Makefile2
-rw-r--r--games/gnome-games/Makefile2
-rw-r--r--games/gnomegames2/Makefile2
-rw-r--r--games/libmaitretarot/Makefile2
-rw-r--r--games/libmt_client/Makefile2
-rw-r--r--games/quakeforge/Makefile2
-rw-r--r--games/xfce4-toys/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index c79ce4b627b7..f31ef1c8612e 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -25,7 +25,7 @@ USE_SDL= sdl
USE_GNOME= gnometarget
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 59c1530f4b3f..82bbc448fff5 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://vipe.technion.ac.il/~shlomif/freecell-solver/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A program that automatically solves games of Freecell
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
MAN6= fc-solve-board_gen.6 fc-solve.6 \
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 4c6e339ce0b2..f17dee8d1c2c 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intlhack lthack libgnomeui \
librsvg2
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/gnomegames2/Makefile b/games/gnomegames2/Makefile
index 4c6e339ce0b2..f17dee8d1c2c 100644
--- a/games/gnomegames2/Makefile
+++ b/games/gnomegames2/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intlhack lthack libgnomeui \
librsvg2
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/games/libmaitretarot/Makefile b/games/libmaitretarot/Makefile
index 50c5074094b3..51e39bc417e0 100644
--- a/games/libmaitretarot/Makefile
+++ b/games/libmaitretarot/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= thierry@FreeBSD.org
COMMENT= Core library of MaitreTarot, a Tarot card game
USE_BZIP2= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
USE_GNOME= glib20 libxml2 lthack
INSTALLS_SHLIB= yes
diff --git a/games/libmt_client/Makefile b/games/libmt_client/Makefile
index a47dea34fdbb..27415f4bc863 100644
--- a/games/libmt_client/Makefile
+++ b/games/libmt_client/Makefile
@@ -17,7 +17,7 @@ COMMENT= Client-side library of MaitreTarot, a Tarot card game
LIB_DEPENDS= maitretarot.0:${PORTSDIR}/games/libmaitretarot
USE_BZIP2= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
USE_GNOME= glib20 libxml2 lthack
INSTALLS_SHLIB= yes
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 44497789b9fd..4b0b61f91e2c 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -31,7 +31,7 @@ WADFILE= quakesw-1.0.6.tar.gz
PROGFILE= qwsv-2.30-glibc-i386-unknown-linux2.0.tar.gz
SKINFILES= skinbase.zip qw_skins.zip
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
USE_XLIB= yes
USE_REINPLACE= yes
diff --git a/games/xfce4-toys/Makefile b/games/xfce4-toys/Makefile
index 0aa240e46be3..3f4a728aeec1 100644
--- a/games/xfce4-toys/Makefile
+++ b/games/xfce4-toys/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \