aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-05-22 18:52:44 +0800
committermatthew <matthew@FreeBSD.org>2016-05-22 18:52:44 +0800
commit5cdd27d7fb9e44673f9bb26594e8f14095624d86 (patch)
tree11614345c7dfeab8d4ba1cd03e07f16921dbc832 /games
parentae608736bd02e8d8d75614fe9b85e32072a72fda (diff)
downloadfreebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.tar.gz
freebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.tar.zst
freebsd-ports-gnome-5cdd27d7fb9e44673f9bb26594e8f14095624d86.zip
Reorganise and modernise the py-sqlalchemy ports.
- Introduce new ports for the sqlalchemy 0.9 and 1.0 release branches. - Deprecate the ports for the 0.6 and 0.7 release branches, as these have been declared EoL and are no longer supported by upstream. - Update to the latest available version in each branch. In detail: Port Version Maintainer ---------------------------------------------- py-sqlalchemy06 0.6.9 nivit@FreeBSD.org (Deprecate 2016-08-20) [1] py-sqlalchemy07 0.7.10 nivit@FreeBSD.org (renamed py-sqlalchemy, Deprecate 2016-08-20) [1] py-sqlalchemy08 0.8.7 nivit@FreeBSD.org (renamed py-sqlalchemy-devel) [1] py-sqlalchemy09 0.9.10 m.tsatsenko@gmail.com (new, repocopy from py-sqlalchemy-devel) [2] py-sqlalchemy10 1.0.13 m.tsatsenko@gmail.com (new, repocopy from py-sqlalchemy-devel) [2] - Use options-helpers and option dependent make targets. - Use autoplist for documents as well as python code - Add all the docments to the packages: previously an arbitrary subset was added in a way that excluded CSS, images and other HTML assets. - Use TEST_DEPENDS and add a TEST_TARGET instead of having a 'TEST' option. - Use py-pytest for 0.9.x and later, rather than py-nose. - Add CONFLICTS_INSTALL between all of the py-sqlalchemyXY ports. PR: 191442 Submitted by: robak Reviewed by: robak Reviewed by: pi Approved by: nivit (maintainer timeout, ~300days) [1] Approved by: m.tsatsenko@gmail.com (maintainer) [2] Sponsored by: https://reviews.freebsd.org/D908
Diffstat (limited to 'games')
-rw-r--r--games/anki/Makefile2
-rw-r--r--games/childsplay/Makefile2
-rw-r--r--games/pyfa/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/games/anki/Makefile b/games/anki/Makefile
index c7ae4c3b9434..6e860b0db928 100644
--- a/games/anki/Makefile
+++ b/games/anki/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= lame:audio/lame \
mplayer:multimedia/mplayer \
${PYTHON_PKGNAMEPREFIX}pyaudio>0:audio/py-pyaudio \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>0:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}qt4-network>=4.4:net/py-qt4-network \
${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:www/py-beautifulsoup32 \
diff --git a/games/childsplay/Makefile b/games/childsplay/Makefile
index e4672a9325b4..d503fc81da7c 100644
--- a/games/childsplay/Makefile
+++ b/games/childsplay/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3 # only
LICENSE_FILE= ${WRKSRC}/gpl-3.0.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:databases/py-sqlalchemy \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>0:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game
NO_BUILD= yes
diff --git a/games/pyfa/Makefile b/games/pyfa/Makefile
index e6c90d83586c..a0cff33a078c 100644
--- a/games/pyfa/Makefile
+++ b/games/pyfa/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.6:databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy07>=0.6:databases/py-sqlalchemy07 \
${PYTHON_PKGNAMEPREFIX}requests>=2.3.0:www/py-requests
USE_GITHUB= yes