aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-17 08:28:16 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-17 08:28:16 +0800
commit5e327ff9fab936ed5e93e654aef9f022c9ce4469 (patch)
tree519523c2f7fd22c2e096c05f01d3dc27ade567ea /games
parent7430a709eacd7b347242681b0363ec2c22ee6d8f (diff)
downloadfreebsd-ports-gnome-5e327ff9fab936ed5e93e654aef9f022c9ce4469.tar.gz
freebsd-ports-gnome-5e327ff9fab936ed5e93e654aef9f022c9ce4469.tar.zst
freebsd-ports-gnome-5e327ff9fab936ed5e93e654aef9f022c9ce4469.zip
- Add stage support
Diffstat (limited to 'games')
-rw-r--r--games/jinput/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/games/jinput/Makefile b/games/jinput/Makefile
index 14d80f5684ec..a14ee9ff1d51 100644
--- a/games/jinput/Makefile
+++ b/games/jinput/Makefile
@@ -23,15 +23,16 @@ ALL_TARGET= simple_linux
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}/${PORTNAME}.jar
PLIST_DIRS= %%JAVAJARDIR%%/${PORTNAME}
-NO_STAGE= yes
post-patch:
@${LN} -sf ${JAVALIBDIR}/jutils/jutils.jar ${WRKSRC}/lib/
+do-build:
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${ANT} ${ALL_TARGET})
+
do-install:
- @${ECHO_MSG} -n ">> Install JAR files in ${JAVAJARDIR}/${PORTNAME}/ ..."
- @${MKDIR} ${JAVAJARDIR}/${PORTNAME}
- @${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar \
- ${JAVAJARDIR}/${PORTNAME}/
- @${ECHO_MSG} " [ DONE ]"
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}/
.include <bsd.port.mk>