aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-06-01 23:28:29 +0800
committermarino <marino@FreeBSD.org>2014-06-01 23:28:29 +0800
commit609349d09e283b36d3ff627f7ab815cb5394b6e3 (patch)
treea60835aa71b563cea376eaa0213f34f52f978511 /games
parentf76656b9cc16c2c85581dc019c8f0e343e7f24b9 (diff)
downloadfreebsd-ports-gnome-609349d09e283b36d3ff627f7ab815cb5394b6e3.tar.gz
freebsd-ports-gnome-609349d09e283b36d3ff627f7ab815cb5394b6e3.tar.zst
freebsd-ports-gnome-609349d09e283b36d3ff627f7ab815cb5394b6e3.zip
games: ioquak3* iourbanterror* openarena*: Update and stage support
The patch applied without incident. Tested on DragonFly poudriere, everything built fine. It include an i386 fix, which is why the previous commit was reverted. The only modification was to change EXTRACT_CMD to TAR in a couple of places. PR: ports/187859 submitted by; maintainer (Dominic Fandrey)
Diffstat (limited to 'games')
-rw-r--r--games/ioquake3-devel-server/Makefile1
-rw-r--r--games/ioquake3-devel/Makefile9
-rw-r--r--games/ioquake3-devel/distinfo4
-rw-r--r--games/ioquake3-devel/pkg-descr3
-rw-r--r--games/ioquake3-server/Makefile1
-rw-r--r--games/ioquake3/Makefile20
-rw-r--r--games/ioquake3/files/patch-code-qcommon-vm_x86.c14
-rw-r--r--games/iourbanterror-server/Makefile1
-rw-r--r--games/iourbanterror/Makefile19
-rw-r--r--games/iourbanterror/files/patch-code-qcommon-q_shared.h14
-rw-r--r--games/iourbanterror/files/patch-code-qcommon-vm_interpreted.c35
-rw-r--r--games/iourbanterror/files/patch-code-qcommon-vm_x86.c58
-rw-r--r--games/openarena-data/Makefile9
-rw-r--r--games/openarena-oax/Makefile7
-rw-r--r--games/openarena-oax/distinfo4
-rw-r--r--games/openarena-server/Makefile1
-rw-r--r--games/openarena/Makefile1
-rw-r--r--games/openarena/files/patch-code-qcommon-vm_x86.c14
-rw-r--r--games/urbanterror-data/Makefile12
-rw-r--r--games/urbanterror-data/distinfo4
-rw-r--r--games/urbanterror-data/pkg-plist12
21 files changed, 124 insertions, 119 deletions
diff --git a/games/ioquake3-devel-server/Makefile b/games/ioquake3-devel-server/Makefile
index eff4808c9958..894b994d48a1 100644
--- a/games/ioquake3-devel-server/Makefile
+++ b/games/ioquake3-devel-server/Makefile
@@ -12,5 +12,4 @@ MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER GAMELIBS
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/games/ioquake3-devel/Makefile b/games/ioquake3-devel/Makefile
index 8a585952828a..0048d7456263 100644
--- a/games/ioquake3-devel/Makefile
+++ b/games/ioquake3-devel/Makefile
@@ -17,11 +17,16 @@ DISTINFO_FILE?= ${.CURDIR}/../${PORTNAME}/distinfo
PATCHDIR?= ${.CURDIR}/../${PORTNAME}/files
PKGMESSAGE?= ${.CURDIR}/../${PORTNAME}/pkg-message
-GITREVISION?= 2178
+GITREVISION?= 2390
BINSUFFIX?= -devel
IOQ3?= CLIENT TOOLS DLRENDERER GAMELIBS OPUS OPENGL2
IOQ3ARCH?= ${ARCH:S/i386/x86/:S/amd64/x86_64/}
-NO_STAGE= yes
+Q3DOCS?= README.md \
+ id-readme.txt \
+ md4-readme.txt \
+ opengl2-readme.txt \
+ voip-readme.txt
+
.include "${MASTERDIR}/Makefile"
diff --git a/games/ioquake3-devel/distinfo b/games/ioquake3-devel/distinfo
index 0816e0a3d488..068c5d1c2bbb 100644
--- a/games/ioquake3-devel/distinfo
+++ b/games/ioquake3-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ioquake3-devel-GIT2178.tar.xz) = 9567243047c7c0ef6f9e329a1c8be826bdce4f12d02685eb51ec3a8058324eb9
-SIZE (ioquake3-devel-GIT2178.tar.xz) = 4167780
+SHA256 (ioquake3-devel-GIT2390.tar.xz) = 1ad3a8bfccaa54ed39221f86539676479187f5f832a4140cf5d7ee7be9a1b1be
+SIZE (ioquake3-devel-GIT2390.tar.xz) = 4310568
diff --git a/games/ioquake3-devel/pkg-descr b/games/ioquake3-devel/pkg-descr
index b43e2fb2ddf0..a821988320fa 100644
--- a/games/ioquake3-devel/pkg-descr
+++ b/games/ioquake3-devel/pkg-descr
@@ -2,4 +2,7 @@ This port builds development snapshots of icculus.org/quake3. The project is
known to seldomly produce releases. Due to the conservative development goals
of the project, development snapshots are generally considered reliable.
+This port is based of a repository with FreeBSD specific changes:
+https://github.com/lonkamikaze/ioq3-freebsd/tree/freebsd
+
WWW: http://ioquake3.org/
diff --git a/games/ioquake3-server/Makefile b/games/ioquake3-server/Makefile
index b5c3312c447f..157753675370 100644
--- a/games/ioquake3-server/Makefile
+++ b/games/ioquake3-server/Makefile
@@ -12,5 +12,4 @@ MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER GAMELIBS
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index db5c822912b6..a236ca7d5bff 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -14,7 +14,6 @@ COMMENT?= Cleaned-up and enhanced version of Quake 3
USES= pkgconfig gmake
-NO_STAGE= yes
# Port configuration flags:
# CLIENT SERVER TOOLS DLRENDERER GAMELIBS OPUS OPENGL2
IOQ3?= CLIENT TOOLS GAMELIBS
@@ -131,7 +130,7 @@ MAKE_ARGS+= BUILD_SERVER=0
.endif
.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
MAKE_ARGS+= USE_CURL=1 USE_CURL_DLOPEN=0
.else
MAKE_ARGS+= USE_CURL=0
@@ -145,18 +144,27 @@ MAKE_ARGS+= USE_OPENAL=0
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+NEED_OGG= yes
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
MAKE_ARGS+= USE_CODEC_VORBIS=1
.else
MAKE_ARGS+= USE_CODEC_VORBIS=0
.endif
.if ${PORT_OPTIONS:MOPUS}
-MAKE_ARGS+= USE_CODEC_OPUS=1 USE_INTERNAL_OPUS=1
+NEED_OGG= yes
+LIB_DEPENDS+= libopusfile.so:${PORTSDIR}/audio/opusfile \
+ libopus.so:${PORTSDIR}/audio/opus
+MAKE_ARGS+= USE_CODEC_OPUS=1 USE_INTERNAL_OPUS=0
.else
MAKE_ARGS+= USE_CODEC_OPUS=0
.endif
+.if defined(NEED_OGG)
+LIB_DEPENDS+= libogg.so:${PORTSDIR}/audio/libogg
+MAKE_ARGS+= USE_INTERNAL_OGG=0
+.endif
+
.if ${PORT_OPTIONS:MMUMBLE}
MAKE_ARGS+= USE_MUMBLE=1
.else
@@ -226,11 +234,11 @@ PLIST_FILES+= ${inst:C/.*;//}
# Generate install target
do-install: ${Q3INSTALL}
.for dir in ${PLIST_DIRS}
- ${MKDIR} ${PREFIX}/${dir}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${dir}
.endfor
.for inst in ${IOQ3_INST}
${INSTALL_${inst:C/;.*//}} ${BUILDDIR}/${inst:C/[^;]*;//:C/;.*//} \
- ${PREFIX}/${inst:C/.*;//}
+ ${STAGEDIR}${PREFIX}/${inst:C/.*;//}
.endfor
post-install:
diff --git a/games/ioquake3/files/patch-code-qcommon-vm_x86.c b/games/ioquake3/files/patch-code-qcommon-vm_x86.c
index a24661785255..c5d8d1b8c766 100644
--- a/games/ioquake3/files/patch-code-qcommon-vm_x86.c
+++ b/games/ioquake3/files/patch-code-qcommon-vm_x86.c
@@ -1,5 +1,5 @@
--- code/qcommon/vm_x86.c.orig 2008-08-18 01:22:06.000000000 +0200
-+++ code/qcommon/vm_x86.c 2010-11-27 14:01:33.000000000 +0100
++++ code/qcommon/vm_x86.c 2013-11-14 11:44:27.000000000 +0100
@@ -36,7 +36,25 @@
/* need this on NX enabled systems (i386 with PAE kernel or
@@ -27,3 +27,15 @@
#define VM_X86_MMAP
#endif
+@@ -90,7 +108,11 @@
+ static void (*const asmCallPtr)(void) = AsmCall;
+
+
++#ifdef __clang__
++ int callMask = 0;
++#else
+ static int callMask = 0;
++#endif
+
+ static int instruction, pass;
+ static int lastConst = 0;
diff --git a/games/iourbanterror-server/Makefile b/games/iourbanterror-server/Makefile
index 3efb7d6fe1a6..51a1eb2d1a2b 100644
--- a/games/iourbanterror-server/Makefile
+++ b/games/iourbanterror-server/Makefile
@@ -12,5 +12,4 @@ MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index 7bd522d9758c..3277d5d10e0c 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -2,25 +2,25 @@
# $FreeBSD$
PORTNAME= iourbanterror
-PORTVERSION= ${GAMEVERSION}.g${GITREVISION}
+PORTVERSION= ${GAMEVERSION}.${DISTVERSION}
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= games
-DISTNAME= ioquake3-devel-GIT${GITREVISION}
+DISTNAME= ioquake3-${DISTVERSION}
MAINTAINER= kamikaze@bsdforen.de
COMMENT= Quake 3 engine modified for Urban Terror (based on ioquake3)
RUN_DEPENDS= ${Q3DIR}/q3ut4:${PORTSDIR}/games/urbanterror-data
-MASTERDIR= ${.CURDIR}/../ioquake3-devel
-DISTINFO_FILE= ${.CURDIR}/../ioquake3-devel/distinfo
+MASTERDIR= ${.CURDIR}/../ioquake3
-IOQ3?= CLIENT DLRENDERER OPUS OPENGL2
+IOQ3?= CLIENT
# The docs belong to ioquake3
OPTIONS_EXCLUDE= DOCS
-GAMEVERSION= 4.2.014
-Q3ENGINEVER= GIT${GITREVISION}+${GAMEVERSION}
+GAMEVERSION= 4.2.018
+Q3ENGINEVER= ${DISTVERSION}+${GAMEVERSION}
Q3TOTALCONV= yes
Q3DIR= ${PREFIX}/share/quake3
Q3ICON= ${PREFIX}/share/quake3/q3ut4/q3ut.ico
@@ -33,8 +33,11 @@ HOMEPATH= /.ioUrbanTerror
MAKE_ARGS+= BUILD_MISSIONPACK=0 \
BUILD_STANDALONE=1
-NO_STAGE= yes
post-patch:
+ @(cd ${WRKSRC} && \
+ for pfile in ${.CURDIR}/../${PORTNAME}/files/patch-*; do \
+ ${PATCH} < $${pfile}; \
+ done)
@${REINPLACE_CMD} \
-e 's/ioquake3/${Q3CLIENT}/g' \
-e 's/ioq3ded/${Q3SERVER}/g' \
diff --git a/games/iourbanterror/files/patch-code-qcommon-q_shared.h b/games/iourbanterror/files/patch-code-qcommon-q_shared.h
index 75f9a0ea9d9b..633760e3d5bb 100644
--- a/games/iourbanterror/files/patch-code-qcommon-q_shared.h
+++ b/games/iourbanterror/files/patch-code-qcommon-q_shared.h
@@ -1,6 +1,6 @@
---- code/qcommon/q_shared.h.orig 2011-10-27 02:45:12.000000000 +0200
-+++ code/qcommon/q_shared.h 2011-10-27 02:47:17.000000000 +0200
-@@ -27,15 +27,15 @@
+--- code/qcommon/q_shared.h.orig 2014-03-23 17:10:02.000000000 +0100
++++ code/qcommon/q_shared.h 2014-03-23 17:12:24.000000000 +0100
+@@ -27,11 +27,12 @@
// A user mod should never modify this file
#ifdef STANDALONE
@@ -8,17 +8,13 @@
- #define BASEGAME "foobar"
- #define CLIENT_WINDOW_TITLE "changeme"
- #define CLIENT_WINDOW_MIN_TITLE "changeme2"
+- #define GAMENAME_FOR_MASTER "iofoo3" // must NOT contain whitespaces
+ #define PRODUCT_NAME "ioq3+UT"
+ #define BASEGAME "q3ut4"
+ #define CLIENT_WINDOW_TITLE "ioUrbanTerror"
+ #define CLIENT_WINDOW_MIN_TITLE "ioUT"
- #define HOMEPATH_NAME_UNIX HOMEPATH
- #define HOMEPATH_NAME_WIN "FooBar"
- #define HOMEPATH_NAME_MACOSX HOMEPATH_NAME_WIN
-- #define GAMENAME_FOR_MASTER "foobar" // must NOT contain whitespace
--// #define LEGACY_PROTOCOL // You probably don't need this for your standalone game
+ #define GAMENAME_FOR_MASTER "Quake3Arena" // must NOT contain whitespace
-+ #define LEGACY_PROTOCOL // You probably don't need this for your standalone game
++ #define LEGACY_PROTOCOL
#else
#define PRODUCT_NAME "ioq3"
#define BASEGAME "baseq3"
diff --git a/games/iourbanterror/files/patch-code-qcommon-vm_interpreted.c b/games/iourbanterror/files/patch-code-qcommon-vm_interpreted.c
index 66e20bc6c3fb..d09b5be36ec6 100644
--- a/games/iourbanterror/files/patch-code-qcommon-vm_interpreted.c
+++ b/games/iourbanterror/files/patch-code-qcommon-vm_interpreted.c
@@ -1,37 +1,16 @@
---- code/qcommon/vm_interpreted.c.orig 2013-07-15 18:54:41.000000000 +0000
-+++ code/qcommon/vm_interpreted.c
-@@ -436,21 +436,21 @@ nextInstruction2:
- return 0;
- }
- #endif
-- r0 = opStack[opStackOfs] = *(int *) &image[r0 & dataMask & ~3 ];
-+ r0 = opStack[opStackOfs] = *(int *) &image[r0 & dataMask ];
- goto nextInstruction2;
- case OP_LOAD2:
-- r0 = opStack[opStackOfs] = *(unsigned short *)&image[ r0&dataMask&~1 ];
-+ r0 = opStack[opStackOfs] = *(unsigned short *)&image[ r0&dataMask ];
- goto nextInstruction2;
- case OP_LOAD1:
- r0 = opStack[opStackOfs] = image[ r0&dataMask ];
+--- code/qcommon/vm_interpreted.c.orig 2014-03-23 17:14:22.000000000 +0100
++++ code/qcommon/vm_interpreted.c 2014-03-23 17:17:07.000000000 +0100
+@@ -458,11 +458,11 @@
goto nextInstruction2;
case OP_STORE4:
- *(int *)&image[ r1&(dataMask & ~3) ] = r0;
-+ *(int *)&image[ r1&dataMask ] = r0;
- opStackOfs -= 2;
++ *(int *)&image[ r1&(dataMask) ] = r0;
+ opStack -= 2;
goto nextInstruction;
case OP_STORE2:
- *(short *)&image[ r1&(dataMask & ~1) ] = r0;
-+ *(short *)&image[ r1&dataMask ] = r0;
- opStackOfs -= 2;
++ *(short *)&image[ r1&(dataMask) ] = r0;
+ opStack -= 2;
goto nextInstruction;
case OP_STORE1:
-@@ -460,7 +460,7 @@ nextInstruction2:
-
- case OP_ARG:
- // single byte offset from programStack
-- *(int *)&image[ (codeImage[programCounter] + programStack)&dataMask&~3 ] = r0;
-+ *(int *)&image[ (codeImage[programCounter] + programStack)&dataMask ] = r0;
- opStackOfs--;
- programCounter += 1;
- goto nextInstruction;
diff --git a/games/iourbanterror/files/patch-code-qcommon-vm_x86.c b/games/iourbanterror/files/patch-code-qcommon-vm_x86.c
index c2e05d74b818..ce49e652baf8 100644
--- a/games/iourbanterror/files/patch-code-qcommon-vm_x86.c
+++ b/games/iourbanterror/files/patch-code-qcommon-vm_x86.c
@@ -1,38 +1,20 @@
---- code/qcommon/vm_x86.c.orig 2013-07-15 18:54:41.000000000 +0000
-+++ code/qcommon/vm_x86.c
-@@ -783,7 +783,7 @@ qboolean ConstOptimize(vm_t *vm, int cal
- return qtrue;
-
- case OP_STORE4:
-- EmitMovEAXStack(vm, (vm->dataMask & ~3));
-+ EmitMovEAXStack(vm, vm->dataMask);
- #if idx64
- EmitRexString(0x41, "C7 04 01"); // mov dword ptr [r9 + eax], 0x12345678
- Emit4(Constant4());
-@@ -798,7 +798,7 @@ qboolean ConstOptimize(vm_t *vm, int cal
- return qtrue;
-
- case OP_STORE2:
-- EmitMovEAXStack(vm, (vm->dataMask & ~1));
-+ EmitMovEAXStack(vm, vm->dataMask);
- #if idx64
- Emit1(0x66); // mov word ptr [r9 + eax], 0x1234
- EmitRexString(0x41, "C7 04 01");
-@@ -1369,7 +1369,7 @@ void VM_Compile(vm_t *vm, vmHeader_t *he
- case OP_STORE4:
- EmitMovEAXStack(vm, 0);
- EmitString("8B 54 9F FC"); // mov edx, dword ptr -4[edi + ebx * 4]
-- MASK_REG("E2", vm->dataMask & ~3); // and edx, 0x12345678
-+ MASK_REG("E2", vm->dataMask); // and edx, 0x12345678
- #if idx64
- EmitRexString(0x41, "89 04 11"); // mov dword ptr [r9 + edx], eax
- #else
-@@ -1381,7 +1381,7 @@ void VM_Compile(vm_t *vm, vmHeader_t *he
- case OP_STORE2:
- EmitMovEAXStack(vm, 0);
- EmitString("8B 54 9F FC"); // mov edx, dword ptr -4[edi + ebx * 4]
-- MASK_REG("E2", vm->dataMask & ~1); // and edx, 0x12345678
-+ MASK_REG("E2", vm->dataMask); // and edx, 0x12345678
- #if idx64
- Emit1(0x66); // mov word ptr [r9 + edx], eax
- EmitRexString(0x41, "89 04 11");
+--- code/qcommon/vm_x86.c.orig 2014-03-23 17:23:18.000000000 +0100
++++ code/qcommon/vm_x86.c 2014-03-23 17:24:58.000000000 +0100
+@@ -512,7 +512,7 @@
+ break;
+ }
+ if (code[pc+4] == OP_STORE4) {
+- opt = EmitMovEBXEDI(vm, (vm->dataMask & ~3));
++ opt = EmitMovEBXEDI(vm, (vm->dataMask));
+ EmitString( "B8" ); // mov eax, 0x12345678
+ Emit4( Constant4() );
+ // if (!opt) {
+@@ -527,7 +527,7 @@
+ break;
+ }
+ if (code[pc+4] == OP_STORE2) {
+- opt = EmitMovEBXEDI(vm, (vm->dataMask & ~1));
++ opt = EmitMovEBXEDI(vm, (vm->dataMask));
+ EmitString( "B8" ); // mov eax, 0x12345678
+ Emit4( Constant4() );
+ // if (!opt) {
diff --git a/games/openarena-data/Makefile b/games/openarena-data/Makefile
index 5c188763098b..54f931f8b3be 100644
--- a/games/openarena-data/Makefile
+++ b/games/openarena-data/Makefile
@@ -20,15 +20,14 @@ NO_BUILD= yes
OA_DATA= ${PKGNAMEPREFIX}${OA_DATA_VER}.zip
OA_DATA_VER= 0.8.8
-NO_STAGE= yes
.include "${.CURDIR}/../openarena/Makefile.include"
do-install:
- ${MKDIR} ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
.for _file in ${DISTFILES:C/:[^:]*//}
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${_file} \
- ${EXTRACT_AFTER_ARGS} -C ${DATADIR} --strip-components 2 \
- ${PKGNAMEPREFIX}\?.\?.\?/baseoa/
+ ${TAR} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${_file} \
+ ${EXTRACT_AFTER_ARGS} -C ${STAGEDIR}${DATADIR} \
+ --strip-components 2 ${PKGNAMEPREFIX}\?.\?.\?/baseoa/
.endfor
.include <bsd.port.post.mk>
diff --git a/games/openarena-oax/Makefile b/games/openarena-oax/Makefile
index 28e4f1345d28..61fad9553546 100644
--- a/games/openarena-oax/Makefile
+++ b/games/openarena-oax/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= oax
-PORTVERSION= B50
+PORTVERSION= B51
CATEGORIES= games
MASTER_SITES= http://files.poulsander.com/~poul19/public_files/eliminationSource/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -18,10 +18,9 @@ NO_BUILD= yes
OABASE= ${DISTNAME}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR})
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR})
.include "../openarena/Makefile.include"
diff --git a/games/openarena-oax/distinfo b/games/openarena-oax/distinfo
index d16caa564d35..03c40f292553 100644
--- a/games/openarena-oax/distinfo
+++ b/games/openarena-oax/distinfo
@@ -1,2 +1,2 @@
-SHA256 (oaxB50.zip) = 8c3a8846544acc4498a0bdc2fdbeb2206f9dd003be06498aab62e4573d7d108f
-SIZE (oaxB50.zip) = 472236
+SHA256 (oaxB51.zip) = cbc6580f608367718c69f139fba2fdd0a6bf68c18efd73bef620217931762656
+SIZE (oaxB51.zip) = 481791
diff --git a/games/openarena-server/Makefile b/games/openarena-server/Makefile
index a170cf131881..f2c5baa89550 100644
--- a/games/openarena-server/Makefile
+++ b/games/openarena-server/Makefile
@@ -12,5 +12,4 @@ MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/games/openarena/Makefile b/games/openarena/Makefile
index 102ac5f1cfbc..29b03a46cea1 100644
--- a/games/openarena/Makefile
+++ b/games/openarena/Makefile
@@ -38,5 +38,4 @@ Q3DIR= ${DATADIR}
# No icon included with OpenArena
Q3ICON=
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/games/openarena/files/patch-code-qcommon-vm_x86.c b/games/openarena/files/patch-code-qcommon-vm_x86.c
new file mode 100644
index 000000000000..546ec986ef99
--- /dev/null
+++ b/games/openarena/files/patch-code-qcommon-vm_x86.c
@@ -0,0 +1,14 @@
+--- code/qcommon/vm_x86.c.orig 2014-03-23 14:53:59.000000000 +0100
++++ code/qcommon/vm_x86.c 2014-03-23 14:55:33.000000000 +0100
+@@ -91,7 +91,11 @@
+ static void (*const asmCallPtr)(void) = AsmCall;
+
+
++#ifdef __clang__
++ int callMask = 0;
++#else
+ static int callMask = 0;
++#endif
+
+ static int instruction, pass;
+ static int lastConst = 0;
diff --git a/games/urbanterror-data/Makefile b/games/urbanterror-data/Makefile
index 48a8d638e241..bb989fef3fff 100644
--- a/games/urbanterror-data/Makefile
+++ b/games/urbanterror-data/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= data
-PORTVERSION= 4.2.014
+PORTVERSION= 4.2.018
CATEGORIES= games
MASTER_SITES= http://cdn.urbanterror.info/urt/42/zips/ \
http://www.f1m.fr/uploads/urt/ \
@@ -28,16 +28,22 @@ PLIST_SUB+= VER=${URT_VER}
OPTIONS_DEFINE= DOCS
+UTDOCS= readme${URT_VER}.txt \
+ How_To_Install.txt \
+ QIIIA_Game_Source_License.doc
+
.include <bsd.port.options.mk>
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/q3ut4
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTFILES} \
+ ${TAR} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTFILES} \
${EXTRACT_AFTER_ARGS} -C ${STAGEDIR}${DATADIR} --strip-components 1 \
UrbanTerror${URT_VER}/q3ut4
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${MV} ${STAGEDIR}${DATADIR}/q3ut4/readme${URT_VER}.txt ${STAGEDIR}${DOCSDIR}
+.for utdoc in ${UTDOCS}
+ ${MV} ${STAGEDIR}${DATADIR}/q3ut4/${utdoc} ${STAGEDIR}${DOCSDIR}
+.endfor
.else
${RM} ${STAGEDIR}${DATADIR}/q3ut4/readme${URT_VER}.txt
.endif
diff --git a/games/urbanterror-data/distinfo b/games/urbanterror-data/distinfo
index 090a29263e83..d77417f3ee1c 100644
--- a/games/urbanterror-data/distinfo
+++ b/games/urbanterror-data/distinfo
@@ -1,2 +1,2 @@
-SHA256 (UrbanTerror42_full014.zip) = 52618f40223baedf37b0a97fc99fd05d3915d20eaff38c71e4eeb66835c7d169
-SIZE (UrbanTerror42_full014.zip) = 1548345447
+SHA256 (UrbanTerror42_full018.zip) = 10710c5b762687a75a7abd3cc56de005ce12dcb7ac14c08f40bcb4e9d96f4e83
+SIZE (UrbanTerror42_full018.zip) = 1702949967
diff --git a/games/urbanterror-data/pkg-plist b/games/urbanterror-data/pkg-plist
index ed00678cfe95..d5f4575cbf9b 100644
--- a/games/urbanterror-data/pkg-plist
+++ b/games/urbanterror-data/pkg-plist
@@ -1,6 +1,6 @@
%%PORTDOCS%%%%DOCSDIR%%/readme%%VER%%.txt
-%%DATADIR%%/q3ut4/How_To_Install.txt
-%%DATADIR%%/q3ut4/QIIIA_Game_Source_License.doc
+%%PORTDOCS%%%%DOCSDIR%%/How_To_Install.txt
+%%PORTDOCS%%%%DOCSDIR%%/QIIIA_Game_Source_License.doc
%%DATADIR%%/q3ut4/autoexec_example.cfg
%%DATADIR%%/q3ut4/mapcycle_example.txt
%%DATADIR%%/q3ut4/server_example.cfg
@@ -28,7 +28,11 @@
%%DATADIR%%/q3ut4/zUrT42_0020.pk3
%%DATADIR%%/q3ut4/zUrT42_0021.pk3
%%DATADIR%%/q3ut4/zUrT42_0022.pk3
+%%DATADIR%%/q3ut4/zUrT42_0023.pk3
+%%DATADIR%%/q3ut4/zUrT42_0024.pk3
+%%DATADIR%%/q3ut4/zUrT42_0025.pk3
+%%DATADIR%%/q3ut4/zUrT42_0026.pk3
%%DATADIR%%/q3ut4/zUrT42_qvm.pk3
@dirrm %%DATADIR%%/q3ut4
-@dirrmtry %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry %%DATADIR%%%%PORTDOCS%%
+@dirrm %%DOCSDIR%%