aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-18 08:40:16 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-18 08:40:16 +0800
commit612ef9fd4c742d735d866cf3e047ff2051677bad (patch)
tree13127f64b344dfa6eacced2aed6f00b4b65ef70d /games
parentb83952849675c2345975964fd3c37d177aa038ef (diff)
downloadfreebsd-ports-gnome-612ef9fd4c742d735d866cf3e047ff2051677bad.tar.gz
freebsd-ports-gnome-612ef9fd4c742d735d866cf3e047ff2051677bad.tar.zst
freebsd-ports-gnome-612ef9fd4c742d735d866cf3e047ff2051677bad.zip
- Support staging
- convert USE_GMAKE to USES
Diffstat (limited to 'games')
-rw-r--r--games/pouetchess/Makefile17
-rw-r--r--games/pouetchess/pkg-plist32
2 files changed, 6 insertions, 43 deletions
diff --git a/games/pouetchess/Makefile b/games/pouetchess/Makefile
index 0a14c8decf66..dcac5a070a16 100644
--- a/games/pouetchess/Makefile
+++ b/games/pouetchess/Makefile
@@ -12,10 +12,12 @@ COMMENT= Open-source 3D chess game
USE_SDL= sdl image
USE_GL= gl
-USE_GMAKE= yes
+USES= gmake
WRKSRC= ${WRKDIR}/pouetChess_0.11
+PORTDATA= *
+
DESKTOP_ENTRIES="pouetChess" \
"Play chess" \
"${DATADIR}/textures/1.png" \
@@ -23,7 +25,6 @@ DESKTOP_ENTRIES="pouetChess" \
"Game;BoardGame;" \
false
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} \( -name "*.cpp" -o -name "*.h" -o -name Makefile \
-o -name config.ini \) -exec ${REINPLACE_CMD} -e \
@@ -40,14 +41,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/src/globalInfos.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/pouetChess ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/bin/config.ini ${PREFIX}/etc/pouetChess.conf.sample
- if [ ! -f ${PREFIX}/etc/pouetChess.conf ]; then \
- ${INSTALL_DATA} ${WRKSRC}/bin/config.ini ${PREFIX}/etc/pouetChess.conf; \
- fi
-.for i in objets3d textures icons
- ${MKDIR} ${DATADIR}/${i}
- ${INSTALL_DATA} ${WRKSRC}/bin/data/${i}/* ${DATADIR}/${i}
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/pouetChess ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/bin/config.ini ${STAGEDIR}${PREFIX}/etc/pouetChess.conf.sample
+ cd ${WRKSRC}/bin/data && ${COPYTREE_SHARE} "*" ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/games/pouetchess/pkg-plist b/games/pouetchess/pkg-plist
index c5bb31c749ac..96033a55bebb 100644
--- a/games/pouetchess/pkg-plist
+++ b/games/pouetchess/pkg-plist
@@ -2,35 +2,3 @@ bin/pouetChess
@unexec if cmp -s %D/etc/pouetChess.conf %D/etc/pouetChess.conf.sample; then rm -f %D/etc/pouetChess.conf; fi
etc/pouetChess.conf.sample
@exec if [ ! -f %D/etc/pouetChess.conf ]; then cp -p %D/etc/pouetChess.conf.sample %D/etc/pouetChess.conf; fi
-%%DATADIR%%/icons/pouetChess.bmp
-%%DATADIR%%/icons/pouetChess.png
-%%DATADIR%%/objets3d/cavalier.lwo
-%%DATADIR%%/objets3d/dame.lwo
-%%DATADIR%%/objets3d/fleche.lwo
-%%DATADIR%%/objets3d/fou.lwo
-%%DATADIR%%/objets3d/pion.lwo
-%%DATADIR%%/objets3d/plateau.lwo
-%%DATADIR%%/objets3d/roi.lwo
-%%DATADIR%%/objets3d/table.lwo
-%%DATADIR%%/objets3d/tour.lwo
-%%DATADIR%%/textures/1.png
-%%DATADIR%%/textures/2.png
-%%DATADIR%%/textures/blender.png
-%%DATADIR%%/textures/camera.png
-%%DATADIR%%/textures/credits.png
-%%DATADIR%%/textures/damier.jpg
-%%DATADIR%%/textures/exit.png
-%%DATADIR%%/textures/font.png
-%%DATADIR%%/textures/force.png
-%%DATADIR%%/textures/gimp.png
-%%DATADIR%%/textures/kate.png
-%%DATADIR%%/textures/murs.jpg
-%%DATADIR%%/textures/porte.jpg
-%%DATADIR%%/textures/quitter.png
-%%DATADIR%%/textures/sol.jpg
-%%DATADIR%%/textures/titre.png
-%%DATADIR%%/textures/tux.png
-@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%/objets3d
-@dirrm %%DATADIR%%/textures
-@dirrm %%DATADIR%%