aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-09-23 01:12:50 +0800
committermarino <marino@FreeBSD.org>2015-09-23 01:12:50 +0800
commit6256cba5c1a086b68f157f650ba35e235f8d2882 (patch)
treed3c5096ea6ffb9936964d2d3532c2d81c92f834f /games
parent650ce05dee3263597e6567270f1d95f551fe83ea (diff)
downloadfreebsd-ports-gnome-6256cba5c1a086b68f157f650ba35e235f8d2882.tar.gz
freebsd-ports-gnome-6256cba5c1a086b68f157f650ba35e235f8d2882.tar.zst
freebsd-ports-gnome-6256cba5c1a086b68f157f650ba35e235f8d2882.zip
games/frozen-bubble: Fix build on modern GCC
The -Qunused-arguments flags is unique to clang and the last few releases of GCC will break if they don't recognize the flag. Use compiler features to limit this cflag to clang. Covered by GCC support blanket.
Diffstat (limited to 'games')
-rw-r--r--games/frozen-bubble/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/frozen-bubble/Makefile b/games/frozen-bubble/Makefile
index 95a60f1fce49..c02f43ff02f1 100644
--- a/games/frozen-bubble/Makefile
+++ b/games/frozen-bubble/Makefile
@@ -22,10 +22,15 @@ RUN_DEPENDS= p5-SDL>=2.511:${PORTSDIR}/devel/p5-SDL \
p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
p5-Alien-SDL>=1.413:${PORTSDIR}/devel/p5-Alien-SDL
-USES= perl5 pkgconfig tar:bzip2
+USES= compiler:features perl5 pkgconfig tar:bzip2
USE_PERL5= modbuild
USE_SDL= mixer pango sdl ttf
+
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE:Mclang}
CFLAGS+= -Qunused-arguments
+.endif
DESKTOP_ENTRIES= "Frozen Bubble" "" \
"${PREFIX}/share/pixmaps/frozen-bubble.png" \
@@ -35,4 +40,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/share/icons/frozen-bubble-icon-64x64.png \
${STAGEDIR}${PREFIX}/share/pixmaps/frozen-bubble.png
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>