aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-09-25 06:20:49 +0800
committernemysis <nemysis@FreeBSD.org>2013-09-25 06:20:49 +0800
commit63a69d329eb63619893ee649c4bbe2bbd44c3043 (patch)
tree2524946fbbc1bc03233060f6c342fe8f25dd618f /games
parent15ce65699132a41bbd136f5edd250b567313c21a (diff)
downloadfreebsd-ports-gnome-63a69d329eb63619893ee649c4bbe2bbd44c3043.tar.gz
freebsd-ports-gnome-63a69d329eb63619893ee649c4bbe2bbd44c3043.tar.zst
freebsd-ports-gnome-63a69d329eb63619893ee649c4bbe2bbd44c3043.zip
- Change maintainer email gmx.ch --> FreeBSD.org
- Change Desktop entry file - Change REINPLACE_CMD, fix build with Clang - Mute dir install - Change pkg-plist, remove mtree Approved by: wg/pawel (mentors)
Diffstat (limited to 'games')
-rw-r--r--games/blockrage/Makefile37
-rw-r--r--games/blockrage/pkg-plist12
2 files changed, 16 insertions, 33 deletions
diff --git a/games/blockrage/Makefile b/games/blockrage/Makefile
index 8f6d41af00b7..a2ffa56be942 100644
--- a/games/blockrage/Makefile
+++ b/games/blockrage/Makefile
@@ -10,56 +10,51 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}:icons
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Falling blocks game with 2-player hotseat mode
LICENSE= GPLv2
+USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
ALL_TARGET= ${PORTNAME}
-USE_SDL= sdl image mixer
-
MAN6= ${PORTNAME}.6
PORTDOCS= ChangeLog KNOWN_BUGS README TODO
-OPTIONS_DEFINE= DOCS
-
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
SUB_FILES= ${PORTNAME}
-DESKTOP_ENTRIES="Block Rage" "${COMMENT}" \
- "share/pixmaps/${PORTNAME}.png" \
+DESKTOP_ENTRIES="Block Rage" "${COMMENT}" ${PORTNAME} \
"${PORTNAME}" "Game;ArcadeGame;" false
+OPTIONS_DEFINE= DOCS
+
NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|MYCC=gcc|MYCC=|' \
- -e 's| -O2 -Wall||' \
+ @${REINPLACE_CMD} \
+ -e 's|prefix=/usr/local|prefix=${PREFIX}|' \
+ -e 's|MYCC=gcc|MYCC?=${CC}|' \
+ -e 's|-s -O2 -Wall||' \
+ -e 's|sdl-config|$(SDL_CONFIG)|' \
+ -e 's|MAKE=make|MAKE=${MAKE}|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|gcc -s|${CC}|' \
+ ${WRKSRC}/src/Makefile.in
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${DATADIR}
-
.for d in data blockrage-fhs.rc blockrage.cfg blockrage.rc
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${DATADIR}
-post-install:
.for s in ${ICON_SIZES}
- ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ @${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps/
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
@@ -67,7 +62,7 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MAN6PREFIX}/man/man6/
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
diff --git a/games/blockrage/pkg-plist b/games/blockrage/pkg-plist
index ec6b85bc06fd..4dc4183ea58e 100644
--- a/games/blockrage/pkg-plist
+++ b/games/blockrage/pkg-plist
@@ -39,18 +39,6 @@ share/icons/hicolor/64x64/apps/blockrage.png
share/icons/hicolor/72x72/apps/blockrage.png
share/icons/hicolor/96x96/apps/blockrage.png
share/pixmaps/blockrage.png
-@dirrmtry share/icons/hicolor/96x96/apps
-@dirrmtry share/icons/hicolor/96x96
-@dirrmtry share/icons/hicolor/72x72/apps
-@dirrmtry share/icons/hicolor/72x72
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
@dirrm %%DATADIR%%/data/test
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%