aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
commit6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7 (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /games
parentb236a9c0408bb4c5dd28e3128687a5de61161a27 (diff)
downloadfreebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.gz
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.zst
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Diffstat (limited to 'games')
-rw-r--r--games/7kaa/Makefile3
-rw-r--r--games/burrtools/Makefile1
-rw-r--r--games/euchre/Makefile1
-rw-r--r--games/lander/Makefile3
4 files changed, 2 insertions, 6 deletions
diff --git a/games/7kaa/Makefile b/games/7kaa/Makefile
index 6798d26da1b4..8117fa36c5ff 100644
--- a/games/7kaa/Makefile
+++ b/games/7kaa/Makefile
@@ -15,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libenet.so:net/enet
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules \
- --disable-nls # no translations ATM
+CONFIGURE_ARGS= --disable-nls # no translations ATM
USES= gmake openal:al tar:xz
USE_SDL= sdl2
diff --git a/games/burrtools/Makefile b/games/burrtools/Makefile
index 651cc094cb33..7cc02dd00423 100644
--- a/games/burrtools/Makefile
+++ b/games/burrtools/Makefile
@@ -22,7 +22,6 @@ USE_GL= gl glu
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_ICE_IceConnectionNumber="no" \
ac_cv_search_glutInit="none required"
-CONFIGURE_ARGS= --disable-silent-rules
MAKE_ARGS= am_lua_liblua_a_OBJECTS='lua/luaclass.$$(OBJEXT)'
LDFLAGS+= -Wl,--as-needed # fltk deps
diff --git a/games/euchre/Makefile b/games/euchre/Makefile
index d7d5b5fd2c5b..4e9cac0150eb 100644
--- a/games/euchre/Makefile
+++ b/games/euchre/Makefile
@@ -19,7 +19,6 @@ LICENSE= GPLv2
USES= pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
diff --git a/games/lander/Makefile b/games/lander/Makefile
index aa481cc55010..a4eb7083ff4e 100644
--- a/games/lander/Makefile
+++ b/games/lander/Makefile
@@ -22,8 +22,7 @@ USE_SDL= sdl image mixer
USE_GL= gl glu
CONFIGURE_ARGS= --with-boost="${LOCALBASE}" \
- --with-boost-filesystem=boost_filesystem \
- --disable-silent-rules
+ --with-boost-filesystem=boost_filesystem
LDFLAGS= -L${LOCALBASE}/lib
PORTDOCS= *