aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-01-13 22:20:07 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-01-13 22:20:07 +0800
commit6f0c5d397b2dbf900ff8b173a80e3dc1a5b8d108 (patch)
treee5a5d98cc852f991851dea7fbb954da9df2ff559 /games
parent30603c64f35bce937d1628a60401ed00ffe8aa7b (diff)
downloadfreebsd-ports-gnome-6f0c5d397b2dbf900ff8b173a80e3dc1a5b8d108.tar.gz
freebsd-ports-gnome-6f0c5d397b2dbf900ff8b173a80e3dc1a5b8d108.tar.zst
freebsd-ports-gnome-6f0c5d397b2dbf900ff8b173a80e3dc1a5b8d108.zip
- Support staging
- Convert USE_GMAKE to USES - Use new LIB_DEPENDS syntax
Diffstat (limited to 'games')
-rw-r--r--games/f1spirit-remake/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/games/f1spirit-remake/Makefile b/games/f1spirit-remake/Makefile
index 7c0ff00447c5..48ed0cb90005 100644
--- a/games/f1spirit-remake/Makefile
+++ b/games/f1spirit-remake/Makefile
@@ -13,10 +13,10 @@ DISTNAME= f1spirit-linux
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Remake of classic F1 Spirit racing game
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USE_ZIP= yes
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl net image mixer sound
USE_GL= gl glu
USE_DOS2UNIX= *.h *.cpp
@@ -25,12 +25,13 @@ WRKSRC= "${WRKDIR}/F-1 Spirit"
BUILD_WRKSRC= ${WRKSRC}/sources
PLIST_FILES= bin/f1s
-
-PORTDOCS= readme.txt
+PORTDOCS= *
PORTDATA= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+
+post-extract:
+ @cd ${WRKSRC}/designs && ${RMDIR} endurance f3 f3000 # empty dirs
post-patch:
@${FIND} ${BUILD_WRKSRC} -name '*.cpp' -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
@@ -40,16 +41,11 @@ post-patch:
@${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/sources/F1Shttp.cpp
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/f1s ${PREFIX}/bin
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} 'demos designs f1spirit2.cfg graphics sound tracks' ${DATADIR}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/f1s ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ 'demos designs f1spirit2.cfg graphics sound tracks' \
+ ${STAGEDIR}${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>