aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-02-05 06:16:39 +0800
committermarino <marino@FreeBSD.org>2016-02-05 06:16:39 +0800
commit75b3e8293deaef9fa23c52003cce6438acef4e95 (patch)
tree5187fe481bdd90e1eeb9f1cedd516f0810657cd7 /games
parent735c2b15628a37f40cb59133a7ddad567fab6f56 (diff)
downloadfreebsd-ports-gnome-75b3e8293deaef9fa23c52003cce6438acef4e95.tar.gz
freebsd-ports-gnome-75b3e8293deaef9fa23c52003cce6438acef4e95.tar.zst
freebsd-ports-gnome-75b3e8293deaef9fa23c52003cce6438acef4e95.zip
games/bluemoon: document ncurses rqmt (USES+=ncurses), respect LDFLAGS
while here, line up PLIST_FILES to respect 80 columns approved by: infrastructure blanket
Diffstat (limited to 'games')
-rw-r--r--games/sl/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/sl/Makefile b/games/sl/Makefile
index 8c282bb147e9..90537cf70c3d 100644
--- a/games/sl/Makefile
+++ b/games/sl/Makefile
@@ -8,14 +8,18 @@ CATEGORIES= games
MAINTAINER= hym@cocoa.freemail.ne.jp
COMMENT= Steam locomotive runs across the screen if you type "sl" instead of "ls"
+USES= ncurses
USE_GITHUB= yes
GH_ACCOUNT= mtoyoda
-PLIST_FILES=bin/${PORTNAME} man/man1/${PORTNAME}.1.gz man/ja/man1/${PORTNAME}.1.gz
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ man/ja/man1/${PORTNAME}.1.gz
PORTDOCS= *
do-build:
- ${CC} ${CFLAGS} -I${WRKSRC} -o ${WRKSRC}/sl ${WRKSRC}/sl.c -lncurses
+ ${CC} ${CFLAGS} -I${WRKSRC} -o ${WRKSRC}/sl ${WRKSRC}/sl.c \
+ ${LDFLAGS} -lncurses
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin