aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-08-16 16:06:42 +0800
committertota <tota@FreeBSD.org>2012-08-16 16:06:42 +0800
commit76008659ea72c0dea19faa01462ab46623ae3067 (patch)
treeb52b480fbd89ab8e33864a582e17c146fb60d45d /games
parent9331895484faa026dae8a14abbc7a50bd56d26a4 (diff)
downloadfreebsd-ports-gnome-76008659ea72c0dea19faa01462ab46623ae3067.tar.gz
freebsd-ports-gnome-76008659ea72c0dea19faa01462ab46623ae3067.tar.zst
freebsd-ports-gnome-76008659ea72c0dea19faa01462ab46623ae3067.zip
- Add a new port: games/gti
It's a program that displays a badly made ASCII-art animation to punish you for your typing error - and after that magically launches the command you meant to launch. The code is available under an MIT-like license on github - though of course anybody can write his or her own version in a couple of minutes. This whole thing is heavily inspired by sl, which displays a steam locomotive. However, gti is actually nicer than sl as it at least executes git after the animation. :-) WWW: http://r-wos.org/hacks/gti
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/gti/Makefile33
-rw-r--r--games/gti/distinfo2
-rw-r--r--games/gti/pkg-descr13
4 files changed, 49 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c674b9bcb9eb..b762c80c26c3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -355,6 +355,7 @@
SUBDIR += grubinvaders
SUBDIR += gshisen
SUBDIR += gtetrinet
+ SUBDIR += gti
SUBDIR += gtkatlantic
SUBDIR += gtkballs
SUBDIR += gtklife
diff --git a/games/gti/Makefile b/games/gti/Makefile
new file mode 100644
index 000000000000..4b79828f4127
--- /dev/null
+++ b/games/gti/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gti
+# Date created: 2012-08-16
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gti
+PORTVERSION= 0.0.2012.08.15
+CATEGORIES= games
+MASTER_SITES= https://github.com/rwos/gti/tarball/master/
+DISTNAME= ${GITNAME}-${GITVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Just a silly git launcher, basically. Inspired by sl
+
+GITUSER= rwos
+GITREPONAME= ${PORTNAME}
+GITNAME= ${GITUSER}-${GITREPONAME}
+GITVERSION= ee63b3f
+
+FETCH_ARGS= -pRr
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-build:
+ @${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/gti/distinfo b/games/gti/distinfo
new file mode 100644
index 000000000000..2ce418002e02
--- /dev/null
+++ b/games/gti/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rwos-gti-ee63b3f.tar.gz) = f7c14215a35d502be7195b601039ab40fedd70c5c7bdde2d2f8d190ac9bb049d
+SIZE (rwos-gti-ee63b3f.tar.gz) = 1583
diff --git a/games/gti/pkg-descr b/games/gti/pkg-descr
new file mode 100644
index 000000000000..db992e6f4232
--- /dev/null
+++ b/games/gti/pkg-descr
@@ -0,0 +1,13 @@
+It's a program that displays a badly made ASCII-art animation to
+punish you for your typing error - and after that magically launches
+the command you meant to launch.
+
+The code is available under an MIT-like license on github - though
+of course anybody can write his or her own version in a couple of
+minutes.
+
+This whole thing is heavily inspired by sl, which displays a steam
+locomotive. However, gti is actually nicer than sl as it at least
+executes git after the animation. :-)
+
+WWW: http://r-wos.org/hacks/gti